summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cli11
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2020-05-13 20:56:48 -0700
committerKhem Raj <raj.khem@gmail.com>2020-05-13 23:40:04 -0700
commit4e494eedfee1ad133cd15912d1b0c59349143904 (patch)
tree6e072a7867ba34eccbe5ba7b04568650bc81ca2b /meta-oe/recipes-support/cli11
parent6105a7bd4dbb8f02d4c70335b3b3480df5268378 (diff)
downloadmeta-openembedded-4e494eedfee1ad133cd15912d1b0c59349143904.tar.gz
cli11: upgrade 1.8.0 -> 1.9.0
Variants of the patches are now included upstream so the local patching can be removed. Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/cli11')
-rw-r--r--meta-oe/recipes-support/cli11/cli11_1.9.0.bb (renamed from meta-oe/recipes-support/cli11/cli11_1.8.0.bb)8
-rw-r--r--meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch25
-rw-r--r--meta-oe/recipes-support/cli11/files/0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch39
3 files changed, 1 insertions, 71 deletions
diff --git a/meta-oe/recipes-support/cli11/cli11_1.8.0.bb b/meta-oe/recipes-support/cli11/cli11_1.9.0.bb
index dd129cbec9..151653b22d 100644
--- a/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
+++ b/meta-oe/recipes-support/cli11/cli11_1.9.0.bb
@@ -6,18 +6,12 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b73927b18d5c6cd8d2ed28a6ad539733"
6SRCREV = "13becaddb657eacd090537719a669d66d393b8b2" 6SRCREV = "13becaddb657eacd090537719a669d66d393b8b2"
7PV .= "+git${SRCPV}" 7PV .= "+git${SRCPV}"
8 8
9SRC_URI += "gitsm://github.com/CLIUtils/CLI11 \ 9SRC_URI += "gitsm://github.com/CLIUtils/CLI11"
10 file://0001-Add-CLANG_TIDY-check.patch \
11 file://0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch \
12 "
13 10
14S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
15 12
16inherit cmake 13inherit cmake
17inherit ptest 14inherit ptest
18 15
19EXTRA_OECMAKE += "-DCLANG_TIDY=OFF"
20DEPENDS += "boost"
21
22# cli11 is a header only C++ library, so the main package will be empty. 16# cli11 is a header only C++ library, so the main package will be empty.
23RDEPENDS_${PN}-dev = "" 17RDEPENDS_${PN}-dev = ""
diff --git a/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch b/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch
deleted file mode 100644
index 02b3c9bd7e..0000000000
--- a/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From 902b251fd8d6408ee6623e7a92692948cf90187d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 12 Feb 2019 13:22:21 -0800
4Subject: [PATCH] Add CLANG_TIDY check
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8
9---
10 CMakeLists.txt | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/CMakeLists.txt b/CMakeLists.txt
14index 7073a0b..2dd2c02 100644
15--- a/CMakeLists.txt
16+++ b/CMakeLists.txt
17@@ -60,7 +60,7 @@ if(CMAKE_PROJECT_NAME STREQUAL PROJECT_NAME)
18 endif()
19 endif()
20
21- if(CMAKE_VERSION VERSION_GREATER 3.6)
22+ if(CMAKE_VERSION VERSION_GREATER 3.6 AND CLANG_TIDY)
23 # Add clang-tidy if available
24 option(CLANG_TIDY_FIX "Perform fixes for Clang-Tidy" OFF)
25 find_program(
diff --git a/meta-oe/recipes-support/cli11/files/0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch b/meta-oe/recipes-support/cli11/files/0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch
deleted file mode 100644
index 4541cd929d..0000000000
--- a/meta-oe/recipes-support/cli11/files/0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 8c51221f748bca1483fe1141e584867d2ff34a07 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 19 Dec 2019 16:26:39 -0800
4Subject: [PATCH] Use GNUInstallDirs instead of hard-coded path
5
6Upstream-Status: Submitted [https://github.com/CLIUtils/CLI11/pull/373]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 CMakeLists.txt | 5 +++--
10 1 file changed, 3 insertions(+), 2 deletions(-)
11
12diff --git a/CMakeLists.txt b/CMakeLists.txt
13index 7073a0b..5236fd2 100644
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -120,17 +120,18 @@ endif()
17 configure_file("${CMAKE_CURRENT_SOURCE_DIR}/cmake/CLI11ConfigVersion.cmake.in"
18 "${CMAKE_CURRENT_BINARY_DIR}/CLI11ConfigVersion.cmake" @ONLY)
19
20+include(GNUInstallDirs)
21 # These installs only make sense for a local project
22 if(CUR_PROJ)
23 # Make version available in the install
24 install(FILES "${CMAKE_CURRENT_BINARY_DIR}/CLI11ConfigVersion.cmake"
25- DESTINATION lib/cmake/CLI11)
26+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/CLI11)
27
28 # Install the export target as a file
29 install(EXPORT CLI11Targets
30 FILE CLI11Config.cmake
31 NAMESPACE CLI11::
32- DESTINATION lib/cmake/CLI11)
33+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/CLI11)
34
35 # Use find_package on the installed package
36 export(TARGETS CLI11
37--
382.24.1
39