summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/canonical-multitouch
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-01-26 12:55:21 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:58:07 +0100
commitbb3bc1ad97ff94bea8d8d53110c671f38982ac6b (patch)
treee52c0fbaf724860f5c185f9200fe15c3c1a66d31 /meta-oe/recipes-support/canonical-multitouch
parent574d27737333ca727b39a7e59e8aefccfc3d28e8 (diff)
downloadmeta-openembedded-bb3bc1ad97ff94bea8d8d53110c671f38982ac6b.tar.gz
geis: initial add 2.2.17
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/canonical-multitouch')
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
new file mode 100644
index 000000000..9403bdf22
--- /dev/null
+++ b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
@@ -0,0 +1,52 @@
1SUMMARY = "An implementation of the GEIS interface"
2DESCRIPTION = "An implementation of the GEIS (Gesture Engine Interface and Support) \
3interface\
4GEIS is a library for applications and toolkit programmers which \
5provides a consistent platform independent interface for any \
6system-wide input gesture recognition mechanism."
7
8HOMEPAGE = "https://launchpad.net/geis"
9
10LICENSE = "GPLv3 & LGPLv3"
11LIC_FILES_CHKSUM = " \
12 file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6 \
13 file://COPYING.GPL;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
14"
15
16inherit autotools pkgconfig python3native lib_package
17
18DEPENDS += "grail dbus-glib python3"
19
20SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz"
21SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf"
22SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb"
23
24EXTRA_OECONF = "--disable-integration-tests"
25
26FILES_${PN}-bin = "${bindir}"
27RDEPENDS_${PN}-bin = " \
28 python3-compression \
29 python3-core \
30 python3-crypt \
31 python3-ctypes \
32 python3-fcntl \
33 python3-misc \
34 python3-pickle \
35 python3-shell \
36 python3-stringold \
37 python3-subprocess \
38 python3-textutils \
39 python3-threading \
40"
41
42FILES_${PN} += " \
43 ${datadir}/geisview \
44 ${libdir}/${PYTHON_DIR}/site-packages/geis* \
45 ${libdir}/${PYTHON_DIR}/site-packages/_*.so \
46"
47
48FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
49
50FILES_${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/_*.la"
51
52FILES_${PN}-staticdev += "${libdir}/${PYTHON_DIR}/site-packages/_*.a"