summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/c-ares/c-ares_1.27.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-06 16:43:05 +0800
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:20 -0800
commitb618b07daab814db28853104a9613ca311489154 (patch)
treead81269a27f3ba792826a6b65aa0c373df87ff16 /meta-oe/recipes-support/c-ares/c-ares_1.27.0.bb
parent6bf3bc30c5c6be3995ae5d965126ddd6c47dea2b (diff)
downloadmeta-openembedded-b618b07daab814db28853104a9613ca311489154.tar.gz
c-ares: upgrade 1.26.0 -> 1.27.0
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/c-ares/c-ares_1.27.0.bb')
-rw-r--r--meta-oe/recipes-support/c-ares/c-ares_1.27.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/c-ares/c-ares_1.27.0.bb b/meta-oe/recipes-support/c-ares/c-ares_1.27.0.bb
new file mode 100644
index 000000000..2d91ac173
--- /dev/null
+++ b/meta-oe/recipes-support/c-ares/c-ares_1.27.0.bb
@@ -0,0 +1,30 @@
1# Copyright (c) 2012-2014 LG Electronics, Inc.
2SUMMARY = "c-ares is a C library that resolves names asynchronously."
3HOMEPAGE = "http://daniel.haxx.se/projects/c-ares/"
4SECTION = "libs"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fdbc58a6da11a9f68aa73c453818decc"
7
8SRC_URI = "https://c-ares.org/download/${BPN}-${PV}.tar.gz \
9 file://run-ptest"
10SRC_URI[sha256sum] = "0a72be66959955c43e2af2fbd03418e82a2bd5464604ec9a62147e37aceb420b"
11
12PACKAGECONFIG ?= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
13PACKAGECONFIG[manpages] = ""
14PACKAGECONFIG[tests] = "-DCARES_BUILD_TESTS=ON,-DCARES_BUILD_TESTS=OFF,googletest"
15
16inherit cmake manpages pkgconfig ptest
17
18EXTRA_OECMAKE = "-DCARES_STATIC=${@ 'ON' if d.getVar('DISABLE_STATIC') == '' else 'OFF' }"
19
20do_install_ptest () {
21 install -d ${D}${PTEST_PATH}
22 install -m 0755 ${B}/bin/arestest ${D}${PTEST_PATH}
23 install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}
24}
25
26PACKAGE_BEFORE_PN = "${PN}-utils"
27
28FILES:${PN}-utils = "${bindir}"
29
30BBCLASSEXTEND = "native nativesdk"