summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/bdwgc/bdwgc_8.2.4.bb
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2023-05-28 17:22:22 +0300
committerKhem Raj <raj.khem@gmail.com>2023-05-28 16:35:00 -0700
commit902725991f622f0d950191c8b34eca72c18d104e (patch)
tree603d6cc925e412cd025e6df9d8624dea4709551f /meta-oe/recipes-support/bdwgc/bdwgc_8.2.4.bb
parent9e0a8642b1be28e904afe87dbdf96d28e9c487e4 (diff)
downloadmeta-openembedded-902725991f622f0d950191c8b34eca72c18d104e.tar.gz
bdwgc: upgrade 8.2.2 -> 8.2.4
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/bdwgc/bdwgc_8.2.4.bb')
-rw-r--r--meta-oe/recipes-support/bdwgc/bdwgc_8.2.4.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bdwgc/bdwgc_8.2.4.bb b/meta-oe/recipes-support/bdwgc/bdwgc_8.2.4.bb
new file mode 100644
index 000000000..f02c45728
--- /dev/null
+++ b/meta-oe/recipes-support/bdwgc/bdwgc_8.2.4.bb
@@ -0,0 +1,37 @@
1SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "https://www.hboehm.info/gc/"
20SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=dd27361ad00943bb27bc3e0589037075"
23
24DEPENDS = "libatomic-ops"
25
26SRCREV = "d1ff06cc503a74dca0150d5e988f2c93158b0cdf"
27SRC_URI = "git://github.com/ivmai/bdwgc.git;branch=release-8_2;protocol=https"
28
29S = "${WORKDIR}/git"
30
31inherit autotools pkgconfig
32
33EXTRA_OECONF += "--enable-cplusplus"
34
35FILES:${PN}-doc = "${datadir}"
36
37BBCLASSEXTEND = "native nativesdk"