summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-01-20 11:32:05 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-22 13:17:55 +0100
commitbe12fb6c0762fe474a4d7cda94e814c0c622dfb5 (patch)
tree849afe25bf3f083ab8cc8e03ba79d34fc8b71809 /meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
parent7eee72b05de181af1dd6cf6abc6b9d8528a77134 (diff)
downloadmeta-openembedded-be12fb6c0762fe474a4d7cda94e814c0c622dfb5.tar.gz
apcupsd: add 3.14.10
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb')
-rw-r--r--meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
new file mode 100644
index 000000000..e50d03f6b
--- /dev/null
+++ b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
@@ -0,0 +1,35 @@
1SUMMARY = "foo"
2
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c12853cc7fdf20d17b4fddefd26b7802"
5
6SRC_URI = "http://garr.dl.sourceforge.net/project/apcupsd/apcupsd%20-%20Stable/3.14.10/apcupsd-${PV}.tar.gz"
7SRC_URI[md5sum] = "5928822d855c5cf7ac29655e3e0b8c23"
8SRC_URI[sha256sum] = "0707b5ec9916fbde9e44eb8d18037c8d8f75dfd6aeef51aba5487e189eef2032"
9
10inherit autotools
11
12LD = "${CXX}"
13
14EXTRA_OECONF = "--enable-usb \
15 --with-distname=${DISTRO}"
16
17do_configure() {
18 export topdir=${S}
19 cp -a ${S}/autoconf/configure.in ${S}
20
21 if ! [ -d ${S}/platforms/${DISTRO} ] ; then
22 cp -a ${S}/platforms/unknown ${S}/platforms/${DISTRO}
23 fi
24
25 gnu-configize --force
26 # install --help says '-c' is an ignored option, but it turns out that the argument to -c isn't ignored, so drop the complete '-c path/to/strip' line
27 sed -i -e 's:$(INSTALL_PROGRAM) $(STRIP):$(INSTALL_PROGRAM):g' ${S}/autoconf/targets.mak
28 # Searching in host dirs triggers the QA checks
29 sed -i -e 's:-I/usr/local/include::g' -e 's:-L/usr/local/lib64::g' -e 's:-L/usr/local/lib::g' ${S}/configure
30
31 # m4 macros are missing, using autotools_do_configure leads to linking errors with gethostname_re
32 oe_runconf
33}
34
35