diff options
author | Armin Kuster <akuster808@gmail.com> | 2018-06-01 16:44:54 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-06-01 18:54:49 -0700 |
commit | aeaa543515c7eca49b7c8cb8f462077367387ca4 (patch) | |
tree | 3c2e5f828673c1356ff28af8717f313118031779 /meta-oe/recipes-security/nmap/files | |
parent | 61868e1272df15ce6626f50d33473757c0e5890a (diff) | |
download | meta-openembedded-aeaa543515c7eca49b7c8cb8f462077367387ca4.tar.gz |
nmap: move recipe from meta-security to meta-oe
[V2]
Remove obsolete sed operations
Remove zenmap as python-pygtk was obsoleted in core
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-security/nmap/files')
-rw-r--r-- | meta-oe/recipes-security/nmap/files/nmap-redefine-the-python-library-dir.patch | 37 | ||||
-rw-r--r-- | meta-oe/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch | 48 |
2 files changed, 85 insertions, 0 deletions
diff --git a/meta-oe/recipes-security/nmap/files/nmap-redefine-the-python-library-dir.patch b/meta-oe/recipes-security/nmap/files/nmap-redefine-the-python-library-dir.patch new file mode 100644 index 0000000000..356b5071bf --- /dev/null +++ b/meta-oe/recipes-security/nmap/files/nmap-redefine-the-python-library-dir.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | [PATCH] redefine the python library install dir | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | If install-lib is not defined, it is always /usr/lib/, but it | ||
6 | maybe /usr/lib64 for multilib | ||
7 | |||
8 | Signed-off-by: Roy Li <rongqing.li@windriver.com> | ||
9 | --- | ||
10 | Makefile.in | 4 ++-- | ||
11 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/Makefile.in b/Makefile.in | ||
14 | index 1bb062c..cced2fb 100644 | ||
15 | --- a/Makefile.in | ||
16 | +++ b/Makefile.in | ||
17 | @@ -311,7 +311,7 @@ build-zenmap: $(ZENMAPDIR)/setup.py $(ZENMAPDIR)/zenmapCore/Version.py | ||
18 | |||
19 | install-zenmap: $(ZENMAPDIR)/setup.py | ||
20 | $(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 | ||
21 | - cd $(ZENMAPDIR) && $(PYTHON) setup.py --quiet install --prefix "$(prefix)" --force $(if $(DESTDIR),--root "$(DESTDIR)") | ||
22 | + cd $(ZENMAPDIR) && $(PYTHON) setup.py --quiet install --prefix "$(prefix)" --install-lib="${PYTHON_SITEPACKAGES_DIR}" --force $(if $(DESTDIR),--root "$(DESTDIR)") | ||
23 | $(INSTALL) -c -m 644 docs/zenmap.1 $(DESTDIR)$(mandir)/man1/ | ||
24 | # Create a symlink from nmapfe to zenmap if nmapfe doesn't exist or is | ||
25 | # already a link. | ||
26 | @@ -328,7 +328,7 @@ build-nping: $(NPINGDIR)/Makefile nbase_build nsock_build netutil_build $(NPINGD | ||
27 | @cd $(NPINGDIR) && $(MAKE) | ||
28 | |||
29 | install-ndiff: | ||
30 | - cd $(NDIFFDIR) && $(PYTHON) setup.py install --prefix "$(prefix)" $(if $(DESTDIR),--root "$(DESTDIR)") | ||
31 | + cd $(NDIFFDIR) && $(PYTHON) setup.py install --prefix "$(prefix)" --install-lib="${PYTHON_SITEPACKAGES_DIR}" $(if $(DESTDIR),--root "$(DESTDIR)") | ||
32 | |||
33 | NSE_FILES = scripts/script.db scripts/*.nse | ||
34 | NSE_LIB_LUA_FILES = nselib/*.lua nselib/*.luadoc | ||
35 | -- | ||
36 | 1.9.1 | ||
37 | |||
diff --git a/meta-oe/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch b/meta-oe/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch new file mode 100644 index 0000000000..cfe043af4b --- /dev/null +++ b/meta-oe/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | [PATCH] replace "./shtool mkdir" with coreutils mkdir command | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | "./shtool mkdir" is used when mkdir has not -p parameter, but mkdir in today | ||
6 | most release has supportted the -p parameter, not need to use shtool, and it | ||
7 | can not fix the race if two process are running mkdir to create same dir | ||
8 | |||
9 | Signed-off-by: Roy Li <rongqing.li@windriver.com> | ||
10 | --- | ||
11 | ncat/Makefile.in | 4 ++-- | ||
12 | nmap-update/Makefile.in | 2 +- | ||
13 | 2 files changed, 3 insertions(+), 3 deletions(-) | ||
14 | |||
15 | diff --git a/ncat/Makefile.in b/ncat/Makefile.in | ||
16 | index cfd306d..2166e08 100644 | ||
17 | --- a/ncat/Makefile.in | ||
18 | +++ b/ncat/Makefile.in | ||
19 | @@ -163,11 +163,11 @@ $(NSOCKDIR)/libnsock.a: $(NSOCKDIR)/Makefile | ||
20 | |||
21 | install: $(TARGET) | ||
22 | @echo Installing Ncat; | ||
23 | - $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 | ||
24 | + mkdir -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 | ||
25 | $(INSTALL) -c -m 755 ncat $(DESTDIR)$(bindir)/ncat | ||
26 | $(STRIP) -x $(DESTDIR)$(bindir)/ncat | ||
27 | if [ -n "$(DATAFILES)" ]; then \ | ||
28 | - $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(pkgdatadir); \ | ||
29 | + mkdir -p -m 755 $(DESTDIR)$(pkgdatadir); \ | ||
30 | $(INSTALL) -c -m 644 $(DATAFILES) $(DESTDIR)$(pkgdatadir)/; \ | ||
31 | fi | ||
32 | $(INSTALL) -c -m 644 docs/$(TARGET).1 $(DESTDIR)$(mandir)/man1/$(TARGET).1 | ||
33 | diff --git a/nmap-update/Makefile.in b/nmap-update/Makefile.in | ||
34 | index 89ff928..93f48d8 100644 | ||
35 | --- a/nmap-update/Makefile.in | ||
36 | +++ b/nmap-update/Makefile.in | ||
37 | @@ -37,7 +37,7 @@ $(NBASELIB): | ||
38 | cd $(NBASEDIR) && $(MAKE) | ||
39 | |||
40 | install: nmap-update | ||
41 | - $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 | ||
42 | + mkdir -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 | ||
43 | $(INSTALL) -c -m 755 nmap-update $(DESTDIR)$(bindir) | ||
44 | $(STRIP) -x $(DESTDIR)$(bindir)/nmap-update | ||
45 | $(INSTALL) -c -m 644 ../docs/nmap-update.1 $(DESTDIR)$(mandir)/man1/ | ||
46 | -- | ||
47 | 1.9.1 | ||
48 | |||