summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb')
-rw-r--r--meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb b/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb
new file mode 100644
index 000000000..1f61c39e3
--- /dev/null
+++ b/meta-oe/recipes-sato/claws-mail/claws-mail_3.9.0.bb
@@ -0,0 +1,55 @@
1SECTION = "x11/network"
2SUMMARY = "Mail user agent"
3DEPENDS = "gtk+ libetpan openssl aspell curl libgcrypt"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e059bde2972c1790af786f3e86bac22e"
6
7
8inherit autotools pkgconfig gettext
9
10# translation patch: http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=1774
11SRC_URI = "\
12 ${SOURCEFORGE_MIRROR}/project/claws-mail/Claws%20Mail/${PV}/claws-mail-${PV}.tar.bz2;name=archive "
13SRC_URI[archive.md5sum] = "4c5ac7b21f0ed17d0f6404124c2229a4"
14SRC_URI[archive.sha256sum] = "ed70975a5056b3ffc4fe6e977f0d9606febc1499763c090241b029a73ff24e65"
15
16do_configure_append() {
17 cd ${S}/po ; for PO in *.po ; do MO=`echo $PO | sed s/\\.po//`.gmo ; if ! test -f $MO ; then msgfmt $PO -o $MO ; fi ; done; cd ${B}
18}
19
20PACKAGECONFIG ??= "startup-notification dbus"
21PACKAGECONFIG[enchant] = "--enable-enchant,--disable-enchant,enchant"
22PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
23PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
24PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,openldap"
25
26# FIXME: maemo builds may want --enable-maemo
27# FIXME: some platforms may want --enable-generic-umpc
28EXTRA_OECONF = " \
29 --disable-manual \
30 --disable-crash-dialog \
31 --disable-jpilot \
32 --disable-trayicon-plugin \
33 --disable-spamassassin-plugin \
34 --disable-bogofilter-plugin \
35 --disable-pgpcore-plugin \
36 --disable-pgpmime-plugin \
37 --disable-pgpinline-plugin \
38 --disable-dillo-viewer-plugin \
39 --disable-valgrind \
40"
41
42# Remove enchant references:
43do_install_prepend() {
44 sed -i -e 's:${STAGING_INCDIR}:${includedir}:g;s:${STAGING_LIBDIR}:${libdir}:g' claws-mail.pc
45}
46
47# Work-around broken GPE icon lookup:
48do_install_append() {
49 rm -r ${D}${datadir}/icons
50 install -d ${D}${datadir}/pixmaps
51 install -m 0644 ${S}/claws-mail.png ${D}${datadir}/pixmaps/
52 sed -i 's/Icon=[^.]*$/&.png/' ${D}${datadir}/applications/claws-mail.desktop
53}
54
55RSUGGESTS_${PN} = "claws-plugin-gtkhtml2-viewer claws-plugin-mailmbox claws-plugin-rssyl"