summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-qt
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-qt')
-rw-r--r--meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb28
-rw-r--r--meta-oe/recipes-qt/libconnman-qt/libconnman-qt_0.4.0.bb34
-rw-r--r--meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb6
-rw-r--r--meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb18
-rw-r--r--meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb32
5 files changed, 59 insertions, 59 deletions
diff --git a/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
index 9d590fdc6..c31261a4c 100644
--- a/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
+++ b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
@@ -12,7 +12,7 @@ PR = "r0"
12inherit qt4x11 pkgconfig 12inherit qt4x11 pkgconfig
13 13
14SRC_URI = " \ 14SRC_URI = " \
15 http://hqh.unlink.org/harmattan/fingerterm-${PV}.tar.gz \ 15 http://hqh.unlink.org/harmattan/fingerterm-${PV}.tar.gz \
16" 16"
17 17
18SRC_URI[md5sum] = "d53b0f463c025583cd52accf95715448" 18SRC_URI[md5sum] = "d53b0f463c025583cd52accf95715448"
@@ -21,24 +21,24 @@ SRC_URI[sha256sum] = "c21a07cc411d09739bd7fa248eba2bf96427b3f032382a044b6674dd82
21S = "${WORKDIR}/${PN}" 21S = "${WORKDIR}/${PN}"
22 22
23FILES_${PN} = " \ 23FILES_${PN} = " \
24 ${bindir}/${PN} \ 24 ${bindir}/${PN} \
25 ${datadir}/applications/${PN}.desktop \ 25 ${datadir}/applications/${PN}.desktop \
26 ${datadir}/pixmaps/${PN}.png \ 26 ${datadir}/pixmaps/${PN}.png \
27" 27"
28 28
29do_install() { 29do_install() {
30 install -d ${D}${bindir} 30 install -d ${D}${bindir}
31 install -m 0744 ${S}/${PN} ${D}${bindir} 31 install -m 0744 ${S}/${PN} ${D}${bindir}
32 32
33 sed -i -e '/Exec.*/d' fingerterm.desktop 33 sed -i -e '/Exec.*/d' fingerterm.desktop
34 sed -i -e '/Icon.*/d' fingerterm.desktop 34 sed -i -e '/Icon.*/d' fingerterm.desktop
35 35
36 echo 'Exec=${bindir}/${PN}' >> fingerterm.desktop 36 echo 'Exec=${bindir}/${PN}' >> fingerterm.desktop
37 echo 'Icon=${PN}' >> fingerterm.desktop 37 echo 'Icon=${PN}' >> fingerterm.desktop
38 38
39 install -d ${D}${datadir}/applications 39 install -d ${D}${datadir}/applications
40 install -m 0644 ${S}/${PN}.desktop ${D}${datadir}/applications 40 install -m 0644 ${S}/${PN}.desktop ${D}${datadir}/applications
41 41
42 install -d ${D}${datadir}/pixmaps 42 install -d ${D}${datadir}/pixmaps
43 install -m 0644 ${S}/${PN}.png ${D}${datadir}/pixmaps 43 install -m 0644 ${S}/${PN}.png ${D}${datadir}/pixmaps
44} 44}
diff --git a/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_0.4.0.bb b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_0.4.0.bb
index d15d8d760..50c149f37 100644
--- a/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_0.4.0.bb
+++ b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_0.4.0.bb
@@ -22,8 +22,8 @@ BRANCH = "master"
22SRCREV = "3af5bd38d82255942f582398160a5d3354346ca3" 22SRCREV = "3af5bd38d82255942f582398160a5d3354346ca3"
23 23
24SRC_URI = " \ 24SRC_URI = " \
25 git://github.com/nemomobile/${PN}.git;branch=${BRANCH} \ 25 git://github.com/nemomobile/${PN}.git;branch=${BRANCH} \
26 file://0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch \ 26 file://0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch \
27" 27"
28 28
29S = "${WORKDIR}/git" 29S = "${WORKDIR}/git"
@@ -33,37 +33,37 @@ QT_IMPORTS_DIR = "${libdir}/qt4/imports"
33PLUGINS_TARGET = "${QT_IMPORTS_DIR}/MeeGo/Connman" 33PLUGINS_TARGET = "${QT_IMPORTS_DIR}/MeeGo/Connman"
34 34
35EXTRA_QMAKEVARS_PRE = " \ 35EXTRA_QMAKEVARS_PRE = " \
36 CONFIG+=notest \ 36 CONFIG+=notest \
37" 37"
38 38
39do_configure_prepend() { 39do_configure_prepend() {
40 # Hack *.pro variables 40 # Hack *.pro variables
41 find ${S}/plugin/*.pro -exec sed -i -e 's,$$\[QT_INSTALL_IMPORTS\],${QT_IMPORTS_DIR},g' '{}' ';' 41 find ${S}/plugin/*.pro -exec sed -i -e 's,$$\[QT_INSTALL_IMPORTS\],${QT_IMPORTS_DIR},g' '{}' ';'
42} 42}
43 43
44do_install() { 44do_install() {
45 export INSTALL_ROOT=${D} 45 export INSTALL_ROOT=${D}
46 oe_runmake install 46 oe_runmake install
47} 47}
48 48
49FILES_${PN} = " \ 49FILES_${PN} = " \
50 ${libdir}/libconnman-qt4${SOLIBS} \ 50 ${libdir}/libconnman-qt4${SOLIBS} \
51" 51"
52 52
53FILES_${PN}-dev = " \ 53FILES_${PN}-dev = " \
54 ${includedir}/connman-qt/* \ 54 ${includedir}/connman-qt/* \
55 ${libdir}/libconnman-qt4${SOLIBSDEV} \ 55 ${libdir}/libconnman-qt4${SOLIBSDEV} \
56 ${libdir}/libconnman-qt4.prl \ 56 ${libdir}/libconnman-qt4.prl \
57 ${libdir}/pkgconfig/connman-qt4.pc \ 57 ${libdir}/pkgconfig/connman-qt4.pc \
58 ${libdir}/connman-qt4.pc \ 58 ${libdir}/connman-qt4.pc \
59" 59"
60 60
61FILES_${PN}-plugin = " \ 61FILES_${PN}-plugin = " \
62 ${PLUGINS_TARGET}/qmldir \ 62 ${PLUGINS_TARGET}/qmldir \
63 ${PLUGINS_TARGET}/lib*.so \ 63 ${PLUGINS_TARGET}/lib*.so \
64" 64"
65 65
66FILES_${PN}-plugin-dbg = " \ 66FILES_${PN}-plugin-dbg = " \
67 ${PLUGINS_TARGET}/.debug \ 67 ${PLUGINS_TARGET}/.debug \
68 ${PLUGINS_TARGET}/.debug/* \ 68 ${PLUGINS_TARGET}/.debug/* \
69" 69"
diff --git a/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb b/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb
index aed190cb6..9bba75008 100644
--- a/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb
+++ b/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb
@@ -16,13 +16,13 @@ S = "${WORKDIR}/qcanobserver/DeviceLib/linux/SocketCAN"
16CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN" 16CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN"
17 17
18do_configure_prepend() { 18do_configure_prepend() {
19 sed -i s:/usr/include/qwt5/:${STAGING_INCDIR}:g *.pro 19 sed -i s:/usr/include/qwt5/:${STAGING_INCDIR}:g *.pro
20} 20}
21 21
22do_install() { 22do_install() {
23 install -d ${D}${datadir}/qcanobserver/lib 23 install -d ${D}${datadir}/qcanobserver/lib
24 24
25 install -m 0755 ${S}/lib* ${D}${datadir}/qcanobserver/lib/ 25 install -m 0755 ${S}/lib* ${D}${datadir}/qcanobserver/lib/
26} 26}
27 27
28FILES_${PN} += "${datadir}/qcanobserver/lib" 28FILES_${PN} += "${datadir}/qcanobserver/lib"
diff --git a/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb b/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb
index 3d79fdc6c..ef866b445 100644
--- a/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb
+++ b/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb
@@ -19,23 +19,23 @@ S = "${WORKDIR}/qcanobserver/"
19CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN" 19CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN"
20 20
21do_configure_prepend() { 21do_configure_prepend() {
22 sed -i -e s:/usr/include/qwt5/:${STAGING_INCDIR}:g -e 's:-L/usr/lib/:-L${STAGING_DIR_TARGET}/lib -ldl:g' *.pro 22 sed -i -e s:/usr/include/qwt5/:${STAGING_INCDIR}:g -e 's:-L/usr/lib/:-L${STAGING_DIR_TARGET}/lib -ldl:g' *.pro
23} 23}
24 24
25do_configure_append() { 25do_configure_append() {
26 sed -i -e s:-L/usr/lib::g Makefile 26 sed -i -e s:-L/usr/lib::g Makefile
27} 27}
28 28
29do_install() { 29do_install() {
30 install -d ${D}${datadir}/qcanobserver 30 install -d ${D}${datadir}/qcanobserver
31 install -d ${D}${datadir}/qcanobserver/cfg 31 install -d ${D}${datadir}/qcanobserver/cfg
32 install -d ${D}${datadir}/qcanobserver/lib 32 install -d ${D}${datadir}/qcanobserver/lib
33 install -d ${D}${datadir}/qcanobserver/db 33 install -d ${D}${datadir}/qcanobserver/db
34 34
35 install -m 0755 ${S}/QCanObserver ${D}${datadir}/qcanobserver 35 install -m 0755 ${S}/QCanObserver ${D}${datadir}/qcanobserver
36 36
37 install -m 0644 ${WORKDIR}/candemo.xml ${D}${datadir}/qcanobserver/db 37 install -m 0644 ${WORKDIR}/candemo.xml ${D}${datadir}/qcanobserver/db
38 install -m 0644 ${S}/db/*.xml ${D}${datadir}/qcanobserver/db 38 install -m 0644 ${S}/db/*.xml ${D}${datadir}/qcanobserver/db
39} 39}
40 40
41FILES_${PN}-dbg += "${datadir}/qcanobserver/.debug" 41FILES_${PN}-dbg += "${datadir}/qcanobserver/.debug"
diff --git a/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb b/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb
index da6521583..617319ab1 100644
--- a/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb
+++ b/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb
@@ -15,7 +15,7 @@ inherit qt4x11 pkgconfig
15DEPENDS = "udev" 15DEPENDS = "udev"
16 16
17SRC_URI = " \ 17SRC_URI = " \
18 http://qextserialport.googlecode.com/files/qextserialport-${REAL_PV}.zip \ 18 http://qextserialport.googlecode.com/files/qextserialport-${REAL_PV}.zip \
19" 19"
20 20
21SRC_URI[md5sum] = "ffa061edb9f64666468d18402eee6108" 21SRC_URI[md5sum] = "ffa061edb9f64666468d18402eee6108"
@@ -26,30 +26,30 @@ S = "${WORKDIR}/qextserialport-${REAL_PV}"
26FILES_${PN} = "${libdir}/libqextserialport${SOLIBS}" 26FILES_${PN} = "${libdir}/libqextserialport${SOLIBS}"
27 27
28FILES_${PN}-dev = " \ 28FILES_${PN}-dev = " \
29 ${libdir}/libqextserialport${SOLIBSDEV} \ 29 ${libdir}/libqextserialport${SOLIBSDEV} \
30 ${libdir}/libqextserialport.prl \ 30 ${libdir}/libqextserialport.prl \
31 ${includedir}/QtExtSerialPort/*.h \ 31 ${includedir}/QtExtSerialPort/*.h \
32 ${datadir}/qt4/mkspecs/features/extserialport.prf \ 32 ${datadir}/qt4/mkspecs/features/extserialport.prf \
33" 33"
34 34
35FILES_${PN}-dbg += " \ 35FILES_${PN}-dbg += " \
36 ${libdir}/.debug/libqextserialport.so* \ 36 ${libdir}/.debug/libqextserialport.so* \
37" 37"
38 38
39do_configure_prepend() { 39do_configure_prepend() {
40 # based on the documentation, this line make sure we use udev in linux 40 # based on the documentation, this line make sure we use udev in linux
41 cd ${S} && echo "linux*:CONFIG += qesp_linux_udev" > .qmake.cache 41 cd ${S} && echo "linux*:CONFIG += qesp_linux_udev" > .qmake.cache
42 42
43 # Hacking hardcoded qmake variables 43 # Hacking hardcoded qmake variables
44 find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_HEADERS\],${includedir},g' '{}' ';' 44 find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_HEADERS\],${includedir},g' '{}' ';'
45 find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_LIBS\],${libdir},g' '{}' ';' 45 find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_LIBS\],${libdir},g' '{}' ';'
46 find *.pro -exec sed -i -e 's,$$\[QMAKE_MKSPECS\],${datadir}/qt4/mkspecs/,g' '{}' ';' 46 find *.pro -exec sed -i -e 's,$$\[QMAKE_MKSPECS\],${datadir}/qt4/mkspecs/,g' '{}' ';'
47} 47}
48 48
49do_install() { 49do_install() {
50 export INSTALL_ROOT=${D} 50 export INSTALL_ROOT=${D}
51 oe_runmake install 51 oe_runmake install
52 52
53 # This is necessary to make it work with the qt based SDK 53 # This is necessary to make it work with the qt based SDK
54 cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|${STAGING_INCDIR_NATIVE}/qt4|\$(OE_QMAKE_INCDIR_QT)/..|" ./extserialport.prf 54 cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|${STAGING_INCDIR_NATIVE}/qt4|\$(OE_QMAKE_INCDIR_QT)/..|" ./extserialport.prf
55} 55}