summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/qwt
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-qt/qwt
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-qt/qwt')
-rw-r--r--meta-oe/recipes-qt/qwt/files/qwt6-fix-linking-with-ld-gold.patch34
-rw-r--r--meta-oe/recipes-qt/qwt/files/qwt6.patch86
-rw-r--r--meta-oe/recipes-qt/qwt/qwt-e_6.0.1.bb14
-rw-r--r--meta-oe/recipes-qt/qwt/qwt.inc40
-rw-r--r--meta-oe/recipes-qt/qwt/qwt_6.0.1.bb10
5 files changed, 184 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/qwt/files/qwt6-fix-linking-with-ld-gold.patch b/meta-oe/recipes-qt/qwt/files/qwt6-fix-linking-with-ld-gold.patch
new file mode 100644
index 000000000..1fdd9cf4b
--- /dev/null
+++ b/meta-oe/recipes-qt/qwt/files/qwt6-fix-linking-with-ld-gold.patch
@@ -0,0 +1,34 @@
1Upstream-Status: Pending
2
3diff -urpN qwt-6.0.1_orig/qwtbuild.pri qwt-6.0.1/qwtbuild.pri
4--- qwt-6.0.1_orig/qwtbuild.pri 2011-08-02 00:33:53.000000000 +1000
5+++ qwt-6.0.1/qwtbuild.pri 2012-08-21 10:27:30.721990849 +1000
6@@ -67,3 +67,13 @@ unix {
7 error( "local build will conflict with $${QMAKE_LIBDIR_QT}/libqwt.*" )
8 }
9 }
10+
11+######################################################################
12+# libs for building qwt
13+######################################################################
14+
15+unix {
16+ # Some linkers require explicit linking with librt (eg ld.gold)
17+ LIBS += -lrt
18+}
19+
20diff -urpN qwt-6.0.1_orig/qwt.prf qwt-6.0.1/qwt.prf
21--- qwt-6.0.1_orig/qwt.prf 2011-08-02 00:33:51.000000000 +1000
22+++ qwt-6.0.1/qwt.prf 2012-08-21 11:19:49.435240439 +1000
23@@ -9,6 +9,11 @@
24
25 include ( ./qwtconfig.pri )
26
27+unix {
28+
29+ LIBS += -lrt
30+}
31+
32 contains(QWT_CONFIG, QwtDll) {
33
34 DEFINES *= QWT_DLL
diff --git a/meta-oe/recipes-qt/qwt/files/qwt6.patch b/meta-oe/recipes-qt/qwt/files/qwt6.patch
new file mode 100644
index 000000000..4fb1a9bdf
--- /dev/null
+++ b/meta-oe/recipes-qt/qwt/files/qwt6.patch
@@ -0,0 +1,86 @@
1- add support for SUFFIX_STR
2---
3diff --git a/examples/examples.pri b/examples/examples.pri
4index a6911c8..854ce89 100644
5--- a/examples/examples.pri
6+++ b/examples/examples.pri
7@@ -13,9 +13,17 @@ include( $${QWT_ROOT}/qwtbuild.pri )
8
9 TEMPLATE = app
10
11+SUFFIX_STR =
12+CONFIG(debug, debug|release) {
13+ SUFFIX_STR = $${DEBUG_SUFFIX}
14+}
15+else {
16+ SUFFIX_STR = $${RELEASE_SUFFIX}
17+}
18+
19 INCLUDEPATH += $${QWT_ROOT}/src
20 DEPENDPATH += $${QWT_ROOT}/src
21-DESTDIR = $${QWT_ROOT}/examples/bin
22+DESTDIR = $${QWT_ROOT}/examples/bin$${SUFFIX_STR}
23
24 QMAKE_RPATHDIR *= $${QWT_ROOT}/lib
25
26diff --git a/qwtconfig.pri b/qwtconfig.pri
27index b0d2110..be119b7 100644
28--- a/qwtconfig.pri
29+++ b/qwtconfig.pri
30@@ -30,6 +30,13 @@ QWT_INSTALL_DOCS = $${QWT_INSTALL_PREFIX}/doc
31 QWT_INSTALL_HEADERS = $${QWT_INSTALL_PREFIX}/include
32 QWT_INSTALL_LIBS = $${QWT_INSTALL_PREFIX}/lib
33
34+DEBUG_SUFFIX =
35+RELEASE_SUFFIX =
36+
37+win32 {
38+ DEBUG_SUFFIX = d
39+}
40+
41 ######################################################################
42 # Designer plugin
43 ######################################################################
44diff --git a/src/src.pro b/src/src.pro
45index beb7125..ebf8ea6 100644
46--- a/src/src.pro
47+++ b/src/src.pro
48@@ -13,8 +13,16 @@ QWT_ROOT = $${PWD}/..
49 include( $${QWT_ROOT}/qwtconfig.pri )
50 include( $${QWT_ROOT}/qwtbuild.pri )
51
52+SUFFIX_STR =
53+CONFIG(debug, debug|release) {
54+ SUFFIX_STR = $${DEBUG_SUFFIX}
55+}
56+else {
57+ SUFFIX_STR = $${RELEASE_SUFFIX}
58+}
59+
60 TEMPLATE = lib
61-TARGET = $$qtLibraryTarget(qwt)
62+TARGET = $$qtLibraryTarget(qwt)$${SUFFIX_STR}
63
64 DESTDIR = $${QWT_ROOT}/lib
65
66diff --git a/textengines/mathml/mathml.pro b/textengines/mathml/mathml.pro
67index b0ed9f9..403828b 100644
68--- a/textengines/mathml/mathml.pro
69+++ b/textengines/mathml/mathml.pro
70@@ -12,7 +12,15 @@ message(Beside the Qwt license you also have to take care of its license. )
71
72 include( $${PWD}/../textengines.pri )
73
74-TARGET = $$qtLibraryTarget(qwtmathml)
75+SUFFIX_STR =
76+CONFIG(debug, debug|release) {
77+ SUFFIX_STR = $${DEBUG_SUFFIX}
78+}
79+else {
80+ SUFFIX_STR = $${RELEASE_SUFFIX}
81+}
82+
83+TARGET = $$qtLibraryTarget(qwtmathml$${SUFFIX_STR})
84 QT += xml
85
86 HEADERS = \
diff --git a/meta-oe/recipes-qt/qwt/qwt-e_6.0.1.bb b/meta-oe/recipes-qt/qwt/qwt-e_6.0.1.bb
new file mode 100644
index 000000000..c80130913
--- /dev/null
+++ b/meta-oe/recipes-qt/qwt/qwt-e_6.0.1.bb
@@ -0,0 +1,14 @@
1inherit qt4e
2
3require qwt.inc
4
5PR = "r1"
6
7SRC_URI[qwt.md5sum] = "ace68558eab873e2da7e641179c4ef0c"
8SRC_URI[qwt.sha256sum] = "3fe19dd5962d705632fc2ef616b009299de6cf1e702538296924dbfdc8003cb2"
9
10RPROVIDES_${PN}-dev = "libqwt-dev"
11
12# Conflicts with qwt, only one qwt* can be built in world
13# | Project ERROR: local build will conflict with sysroots/qemuarm/usr/lib/libqwt.*
14EXCLUDE_FROM_WORLD = "1"
diff --git a/meta-oe/recipes-qt/qwt/qwt.inc b/meta-oe/recipes-qt/qwt/qwt.inc
new file mode 100644
index 000000000..60f73a657
--- /dev/null
+++ b/meta-oe/recipes-qt/qwt/qwt.inc
@@ -0,0 +1,40 @@
1DESCRIPTION = "Qt Widget Extension for Technical Applications"
2SECTION = "libs"
3
4# LGPLv2.1 + some exceptions
5LICENSE = "QWTv1.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=dac2743472b0462ff3cfb4af42051c88"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/qwt/qwt-${PV}.tar.bz2;name=qwt \
9 file://qwt6.patch \
10 file://qwt6-fix-linking-with-ld-gold.patch"
11
12S = "${WORKDIR}/qwt-${PV}"
13
14do_configure_prepend() {
15 sed -i -e 's:RELEASE_SUFFIX = :RELEASE_SUFFIX = ${QT_LIBINFIX}:' *.pri
16 sed -i -e 's:qtAddLibrary(qwt:qtAddLibrary(qwt)${QT_LIBINFIX}:g' *.prf
17 sed -e 's/# QWT_CONFIG += QwtExamples/QWT_CONFIG += QwtExamples/g' -i qwtconfig.pri
18 sed -i -e 's:/usr/local/qwt-$$QWT_VERSION:${D}${prefix}:g' ${S}/*.pri
19}
20
21do_install() {
22 oe_runmake -e install
23 install -d ${D}${datadir}/doc/${PN}
24 mv ${D}${prefix}/doc/* ${D}${datadir}/doc/${PN}/
25 rmdir ${D}${prefix}/doc
26 cd ${S}/examples
27 install -d ${D}/${bindir}
28 cd bin${QT_LIBINFIX}/
29 for i in * ; do
30 cp -pPR ${i} ${D}/${bindir}/${i}${QT_LIBINFIX}
31 done
32 install -d ${D}${libdir}/${QT_DIR_NAME}
33 mv ${D}${prefix}/plugins ${D}${libdir}/${QT_DIR_NAME}
34}
35
36PACKAGES_prepend = "${PN}-examples ${PN}-features ${PN}-plugins "
37FILES_${PN}-examples = "${bindir}/*"
38FILES_${PN}-features = "${prefix}/features"
39FILES_${PN}-plugins = "${libdir}/${QT_DIR_NAME}/plugins/designer/*.so"
40FILES_${PN}-dbg += "${libdir}/${QT_DIR_NAME}/plugins/designer/.debug"
diff --git a/meta-oe/recipes-qt/qwt/qwt_6.0.1.bb b/meta-oe/recipes-qt/qwt/qwt_6.0.1.bb
new file mode 100644
index 000000000..f38816a90
--- /dev/null
+++ b/meta-oe/recipes-qt/qwt/qwt_6.0.1.bb
@@ -0,0 +1,10 @@
1inherit qt4x11
2
3require qwt.inc
4
5PR = "r1"
6
7SRC_URI[qwt.md5sum] = "ace68558eab873e2da7e641179c4ef0c"
8SRC_URI[qwt.sha256sum] = "3fe19dd5962d705632fc2ef616b009299de6cf1e702538296924dbfdc8003cb2"
9
10RPROVIDES_${PN}-dev = "libqwt-dev"