summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/qt-creator
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-01-07 15:57:45 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-14 11:30:15 +0100
commit2bd11da4b50f401c9c49975aeedaaafa6a59d08b (patch)
treedb1b531c534d13cd51d0b9fa4c418b89e899879e /meta-oe/recipes-qt/qt-creator
parent8700ba38804af3c27f3662737f679afa1bdc86da (diff)
downloadmeta-openembedded-2bd11da4b50f401c9c49975aeedaaafa6a59d08b.tar.gz
recipes: remove recipes using or depending on qt4 bbclasses or recipes
* anki is removed because it runtime depends on python-pyqt, other recipes are inheriting one of bbclasses removed from oe-core in: commit cb89d2b25b4edb1241bc5426a69a6bc44df9be2c Author: Alexander Kanavin <alexander.kanavin@linux.intel.com> Date: Fri Nov 27 15:48:20 2015 +0200 qt4: remove recipes and classes * if you're still using one of these recipes add it to meta-qt4 layer Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-qt/qt-creator')
-rw-r--r--meta-oe/recipes-qt/qt-creator/qt-creator_2.8.1.bb54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta-oe/recipes-qt/qt-creator/qt-creator_2.8.1.bb b/meta-oe/recipes-qt/qt-creator/qt-creator_2.8.1.bb
deleted file mode 100644
index 88f7a45f5..000000000
--- a/meta-oe/recipes-qt/qt-creator/qt-creator_2.8.1.bb
+++ /dev/null
@@ -1,54 +0,0 @@
1SUMMARY = "Lightweight, cross-platform integrated development environment"
2
3HOMEPAGE = "http://qt-project.org/"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LGPL_EXCEPTION.TXT;md5=eb6c371255e1262c55ae9b652a90b528 \
6 file://LICENSE.LGPL;md5=243b725d71bb5df4a1e5920b344b86ad"
7SECTION = "qt/app"
8
9SRC_URI = "http://download.qt-project.org/official_releases/qtcreator/2.8/${PV}/${BP}-src.tar.gz \
10 file://fix.missing.cpuid.h.patch \
11 file://qbs_transformer_product.patch"
12SRC_URI[md5sum] = "79ef6c6ece0c00035ef744c9d6e3bd3b"
13SRC_URI[sha256sum] = "d5ae007a297a4288d0e95fd605edbfb8aee80f6788c7a6cfb9cb297f50c364b9"
14
15S = "${WORKDIR}/${BP}-src"
16
17inherit qt4x11
18
19EXTRA_QMAKEVARS_PRE += "IDE_LIBRARY_BASENAME=${baselib}"
20
21do_install() {
22 oe_runmake INSTALL_ROOT=${D}${prefix} install
23 oe_runmake INSTALL_ROOT=${D}${prefix} install_docs
24 rm -f ${D}${libdir}/qtcreator/lib*.so
25}
26
27FILES_${PN} += "${datadir}/icons \
28 ${datadir}/qtcreator \
29 ${libdir}/qtcreator/*"
30FILES_${PN}-dbg += "${datadir}/qtcreator/*/*/*/*/.debug \
31 ${libdir}/qtcreator/.debug \
32 ${libdir}/qtcreator/*/*/.debug"
33RRECOMMENDS_${PN} += "packagegroup-core-buildessential \
34 packagegroup-qt-toolchain-target \
35 qt4-plugin-sqldriver-sqlite \
36"
37
38# avoid conflicts with meta-qt5's qt-creator and do install nothing to sysroot
39# this does no harm cause nothing depends on qt-creator
40sysroot_stage_all() {
41}
42
43# the regexp in insane.bbclass doesn't allow this valid path:
44# qt-creator-2.8.1: qt-creator: found library in wrong location: /usr/share/qtcreator/qbs/lib/qbs/plugins/libqbs_cpp_scanner.so
45# qt-creator: found library in wrong location: /usr/share/qtcreator/qbs/lib/qbs/plugins/libqbs_qt_scanner.so
46# qt-creator-dbg: found library in wrong location: /usr/share/qtcreator/qbs/lib/qbs/plugins/.debug/libqbs_cpp_scanner.so
47# qt-creator-dbg: found library in wrong location: /usr/share/qtcreator/qbs/lib/qbs/plugins/.debug/libqbs_qt_scanner.so
48INSANE_SKIP_${PN} += "libdir"
49INSANE_SKIP_${PN}-dbg += "libdir"
50
51RDEPENDS_${PN} += "perl"
52
53# /usr/include/qt4/QtCore/qsharedpointer_impl.h:336:11: error: 'product' may be used uninitialized in this function [-Werror=maybe-uninitialized]
54PNBLACKLIST[qt-creator] ?= "BROKEN: fails to build with gcc-5 and conflicts with qt5-creator"