summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/qconnman
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-qt/qconnman
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-qt/qconnman')
-rw-r--r--meta-oe/recipes-qt/qconnman/qconnman-e_git.bb12
-rw-r--r--meta-oe/recipes-qt/qconnman/qconnman.inc15
-rw-r--r--meta-oe/recipes-qt/qconnman/qconnman_git.bb10
3 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/qconnman/qconnman-e_git.bb b/meta-oe/recipes-qt/qconnman/qconnman-e_git.bb
new file mode 100644
index 000000000..e307a72c1
--- /dev/null
+++ b/meta-oe/recipes-qt/qconnman/qconnman-e_git.bb
@@ -0,0 +1,12 @@
1require qconnman.inc
2
3RCONFLICTS_${PN} = "qconnman"
4
5inherit qt4e
6
7PNBLACKLIST[qconnman-e] ?= "BROKEN: doesn't work with B!=S, ls: cannot access *.pro: No such file or directory"
8
9EXTRA_QMAKEVARS_PRE += "PREFIX=/usr"
10EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
11
12FILES_${PN} += "${datadir}/qconnman/"
diff --git a/meta-oe/recipes-qt/qconnman/qconnman.inc b/meta-oe/recipes-qt/qconnman/qconnman.inc
new file mode 100644
index 000000000..664f2a02f
--- /dev/null
+++ b/meta-oe/recipes-qt/qconnman/qconnman.inc
@@ -0,0 +1,15 @@
1DESCRIPTION = "ConnMan management interface done in Qt"
2DEPENDS = "connman"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6
7PR = "r2"
8
9inherit autotools
10
11PV = "0.0+gitr${SRCPV}"
12SRCREV = "f976b18c7c5584627224784801803e9fd3ebe0ff"
13SRC_URI = "git://github.com/OSSystems/qconnman-ui.git;branch=stable"
14
15S = "${WORKDIR}/git/"
diff --git a/meta-oe/recipes-qt/qconnman/qconnman_git.bb b/meta-oe/recipes-qt/qconnman/qconnman_git.bb
new file mode 100644
index 000000000..2f8cca25a
--- /dev/null
+++ b/meta-oe/recipes-qt/qconnman/qconnman_git.bb
@@ -0,0 +1,10 @@
1require qconnman.inc
2
3RCONFLICTS_${PN} = "qconnman-e"
4
5inherit qt4x11
6
7PNBLACKLIST[qconnman] ?= "BROKEN: doesn't work with B!=S, ls: cannot access *.pro: No such file or directory"
8
9EXTRA_QMAKEVARS_PRE += "PREFIX=/usr"
10EXTRA_OEMAKE += "INSTALL_ROOT=${D}"