summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/libconnman-qt
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-qt/libconnman-qt
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-qt/libconnman-qt')
-rw-r--r--meta-oe/recipes-qt/libconnman-qt/libconnman-qt.inc52
-rw-r--r--meta-oe/recipes-qt/libconnman-qt/libconnman-qt_git.bb3
-rw-r--r--meta-oe/recipes-qt/libconnman-qt/libconnman-qte/plugin.pro-fix-build-with-custom-target-suffix.patch42
-rw-r--r--meta-oe/recipes-qt/libconnman-qt/libconnman-qte_git.bb5
4 files changed, 102 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/libconnman-qt/libconnman-qt.inc b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt.inc
new file mode 100644
index 000000000..3f91be2a4
--- /dev/null
+++ b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt.inc
@@ -0,0 +1,52 @@
1DESCRIPTION = "Qt Library for ConnMan"
2HOMEPAGE = "https://github.com/nemomobile/libconnman-qt"
3SECTION = "qt/lib"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://libconnman-qt/clockmodel.h;endline=8;md5=ea9f724050803f15d2d900ce3c5dac88"
6SRCREV = "80ac184d859ea90c026403f5a520644945a5081a"
7PV = "1.0.50+git${SRCPV}"
8
9SRC_URI = "git://github.com/nemomobile/libconnman-qt.git;branch=master"
10
11S = "${WORKDIR}/git"
12
13inherit pkgconfig
14
15EXTRA_QMAKEVARS_PRE += "CONFIG+=notests TARGET_SUFFIX=${QT_DIR_NAME}"
16
17do_configure_prepend() {
18 # Hack *.pro variables
19 find ${S}/plugin/*.pro -exec sed -i -e 's,$$\[QT_INSTALL_IMPORTS\],${QT_IMPORTS_DIR},g' '{}' ';'
20}
21do_install() {
22 oe_runmake install INSTALL_ROOT=${D}
23}
24
25PACKAGES =+ "${PN}-plugin ${PN}-plugin-dbg"
26
27RDEPENDS_${PN} = "connman"
28RDEPENDS_${PN}-plugin = "${PN}"
29
30RRECOMMENDS_${PN} = "${PN}-plugin"
31
32FILES_${PN} = " \
33 ${libdir}/libconnman-qt*${SOLIBS} \
34"
35FILES_${PN}-dev = " \
36 ${includedir}/connman-qt*/* \
37 ${libdir}/libconnman-qt*${SOLIBSDEV} \
38 ${libdir}/libconnman-qt*.prl \
39 ${libdir}/pkgconfig/connman-qt*.pc \
40"
41FILES_${PN}-plugin = " \
42 ${PLUGINS_TARGET}/qmldir \
43 ${PLUGINS_TARGET}/lib*.so \
44"
45FILES_${PN}-plugin-dbg = " \
46 ${PLUGINS_TARGET}/.debug \
47 ${PLUGINS_TARGET}/.debug/* \
48"
49
50QT_IMPORTS_DIR = "${libdir}/${QT_DIR_NAME}/imports"
51# the plugin target needs to be the same as 'target.path' and 'qmldir.path' in ${S}/plugin/plugin.pro
52PLUGINS_TARGET = "${QT_IMPORTS_DIR}/MeeGo/Connman"
diff --git a/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_git.bb b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_git.bb
new file mode 100644
index 000000000..8d8822c5e
--- /dev/null
+++ b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_git.bb
@@ -0,0 +1,3 @@
1inherit qt4x11
2
3require libconnman-qt.inc
diff --git a/meta-oe/recipes-qt/libconnman-qt/libconnman-qte/plugin.pro-fix-build-with-custom-target-suffix.patch b/meta-oe/recipes-qt/libconnman-qt/libconnman-qte/plugin.pro-fix-build-with-custom-target-suffix.patch
new file mode 100644
index 000000000..3ff68c8dc
--- /dev/null
+++ b/meta-oe/recipes-qt/libconnman-qt/libconnman-qte/plugin.pro-fix-build-with-custom-target-suffix.patch
@@ -0,0 +1,42 @@
1Upstream-Status: Submitted [https://github.com/nemomobile/libconnman-qt/pull/105]
2
3From 48da520b971af69d22e691a0ef6ff1c3ce901f0d Mon Sep 17 00:00:00 2001
4From: Andreas Oberritter <obi@opendreambox.org>
5Date: Tue, 11 Mar 2014 21:55:37 +0100
6Subject: [PATCH] plugin.pro: fix build with custom target suffix
7
8This went unnoticed because of a previously installed libconnman-qt4.
9
10Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
11---
12 plugin/plugin.pro | 8 ++++++--
13 1 file changed, 6 insertions(+), 2 deletions(-)
14
15diff --git a/plugin/plugin.pro b/plugin/plugin.pro
16index c9534cf..9cdaa63 100644
17--- a/plugin/plugin.pro
18+++ b/plugin/plugin.pro
19@@ -8,14 +8,18 @@ INCLUDEPATH += ../libconnman-qt
20 LIBS += -L../libconnman-qt
21 QT -= gui
22
23+isEmpty(TARGET_SUFFIX) {
24+ TARGET_SUFFIX = qt$$QT_MAJOR_VERSION
25+}
26+
27+LIBS += -l$$qtLibraryTarget(connman-$$TARGET_SUFFIX)
28+
29 equals(QT_MAJOR_VERSION, 4): {
30 QT += declarative
31- LIBS += -lconnman-qt4
32 }
33
34 equals(QT_MAJOR_VERSION, 5): {
35 QT += qml
36- LIBS += -lconnman-qt5
37 OTHER_FILES += plugin.json qmldirs
38 }
39
40--
411.8.3.2
42
diff --git a/meta-oe/recipes-qt/libconnman-qt/libconnman-qte_git.bb b/meta-oe/recipes-qt/libconnman-qt/libconnman-qte_git.bb
new file mode 100644
index 000000000..9d44957ac
--- /dev/null
+++ b/meta-oe/recipes-qt/libconnman-qt/libconnman-qte_git.bb
@@ -0,0 +1,5 @@
1inherit qt4e
2
3require libconnman-qt.inc
4
5SRC_URI += "file://plugin.pro-fix-build-with-custom-target-suffix.patch"