summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-printing
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2023-11-13 02:13:36 +0100
committerKhem Raj <raj.khem@gmail.com>2023-11-12 23:35:22 -0800
commitf1109887083d97365e3e0c292a76cb0195af269d (patch)
tree0d7525b18f361eb0f309ff0284347b62a50dbfb8 /meta-oe/recipes-printing
parentdba4071b696df1d399f9320fb40eb8b6eeae266c (diff)
downloadmeta-openembedded-f1109887083d97365e3e0c292a76cb0195af269d.tar.gz
qpdf: cleanup
- remove autotools remains - select tls depending on packageconfig instead of doing autoselect - preselect gnutls because thats the default if both gnutls/openssl are built - disable the internal tls fallback - enable pkgconfig - fix license, it was changed to Apache-2.0 - dont create an additional package just to rdepend on it afterwards - dont build static lib - fetch source from git Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-printing')
-rw-r--r--meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb41
1 files changed, 16 insertions, 25 deletions
diff --git a/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
index b56f8a822a..ceb9f25aeb 100644
--- a/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
+++ b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
@@ -1,40 +1,31 @@
1DESCRIPTION = "PDF transformation/inspection software" 1DESCRIPTION = "PDF transformation/inspection software"
2HOMEPAGE = "http://qpdf.sourceforge.net" 2HOMEPAGE = "http://qpdf.sourceforge.net"
3LICENSE = "Artistic-2.0" 3LICENSE = "Apache-2.0"
4SECTION = "libs" 4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
5DEPENDS = "libpcre zlib libjpeg-turbo openssl gnutls"
6 5
7SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf/qpdf-${PV}.tar.gz" 6DEPENDS = "zlib jpeg ${@bb.utils.contains('PACKAGECONFIG', 'gnutls', 'gnutls', 'openssl', d)}"
8SRC_URI[sha256sum] = "c394b1b0cff4cd9d13b0f5e16bdf3cf54da424dc434f9d40264b7fe67acd90bc"
9 7
10LIC_FILES_CHKSUM = "file://Artistic-2.0;md5=7806296b9fae874361e6fb10072b7ee3" 8SRC_URI = "git://github.com/qpdf/qpdf.git;protocol=https;branch=main"
9SRCREV = "81823f4032caefd1050bccb207d315839c1c48db"
11 10
12inherit cmake gettext 11inherit cmake pkgconfig gettext
13 12
14# disable random file detection for cross-compile 13EXTRA_OECMAKE = ' \
15EXTRA_OECONF = "--without-random \ 14 -DRANDOM_DEVICE="/dev/random" \
16 --disable-static \ 15 -DBUILD_STATIC_LIBS=OFF \
17 --disable-check-autofiles \ 16 -DALLOW_CRYPTO_NATIVE=OFF \
18 " 17 -DUSE_IMPLICIT_CRYPTO=OFF \
19 18'
20EXTRA_OECMAKE = '-DRANDOM_DEVICE="/dev/random"'
21 19
22LDFLAGS:append:mipsarch = " -latomic" 20LDFLAGS:append:mipsarch = " -latomic"
23LDFLAGS:append:riscv32 = " -latomic" 21LDFLAGS:append:riscv32 = " -latomic"
24 22
25S="${WORKDIR}/${BPN}-${PV}" 23S="${WORKDIR}/git"
24
25PACKAGECONFIG ?= "gnutls"
26PACKAGECONFIG[gnutls] = "-DREQUIRE_CRYPTO_GNUTLS=ON,-DREQUIRE_CRYPTO_OPENSSL=ON"
26 27
27do_install:append() { 28do_install:append() {
28 # Change the fully defined path on the target 29 # Change the fully defined path on the target
29 sed -i -e 's|${STAGING_LIBDIR}|${libdir}|g' ${D}${libdir}/cmake/${BPN}/libqpdfTargets.cmake 30 sed -i -e 's|${STAGING_LIBDIR}|${libdir}|g' ${D}${libdir}/cmake/${BPN}/libqpdfTargets.cmake
30} 31}
31
32# avoid Makefile returning error on 'make clean' before configure was run
33CLEANBROKEN = "1"
34
35DEBIAN_NOAUTONAME:libqpdf = "1"
36
37PACKAGES =+ "libqpdf"
38FILES:libqpdf = "${libdir}/libqpdf.so.*"
39
40RDEPENDS:${PN} = "libqpdf"