diff options
author | Markus Volk <f_l_k@t-online.de> | 2023-11-24 19:37:41 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-11-24 13:46:34 -0800 |
commit | 304fd6a06e17add7fac0067a32a356874fb247d4 (patch) | |
tree | 5fc3fa0476c9b439569d803ba23c526a90f20a80 /meta-oe/recipes-printing | |
parent | 45ce72729513da4aaa0033ad767c25ff5840f751 (diff) | |
download | meta-openembedded-304fd6a06e17add7fac0067a32a356874fb247d4.tar.gz |
cups-filters: fix Makefile race condition
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-printing')
-rw-r--r-- | meta-oe/recipes-printing/cups/cups-filters/fix-make-race.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb | 5 |
2 files changed, 37 insertions, 1 deletions
diff --git a/meta-oe/recipes-printing/cups/cups-filters/fix-make-race.patch b/meta-oe/recipes-printing/cups/cups-filters/fix-make-race.patch new file mode 100644 index 0000000000..9a4e31c1d2 --- /dev/null +++ b/meta-oe/recipes-printing/cups/cups-filters/fix-make-race.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 7aba7c690fd84ca1e48d0cb6829410eeb658c594 Mon Sep 17 00:00:00 2001 | ||
2 | From: Markus Volk <f_l_k@t-online.de> | ||
3 | Date: Fri, 24 Nov 2023 17:53:49 +0100 | ||
4 | Subject: [PATCH] Fix a Makefile race condition | ||
5 | |||
6 | utils/driverless-fax script may be written before utils directory was created | ||
7 | |||
8 | | make[2]: Entering directory '/home/flk/poky/build/tmp/work/corei7-64-poky-linux/cups-filters/2.0.0/build' | ||
9 | | sed \ | ||
10 | | -e "s|\@CUPS_SERVERBIN\@|/usr/libexec/cups|" \ | ||
11 | | ../cups-filters-2.0.0/utils/driverless-fax.in > utils/driverless-fax | ||
12 | | /bin/bash: line 2: utils/driverless-fax: No such file or directory | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | --- | ||
16 | Makefile.am | 5 +---- | ||
17 | 1 file changed, 1 insertion(+), 4 deletions(-) | ||
18 | |||
19 | --- a/Makefile.am 2023-09-22 18:14:03.000000000 +0200 | ||
20 | +++ b/Makefile.am 2023-11-24 19:09:09.339653936 +0100 | ||
21 | @@ -62,7 +62,7 @@ | ||
22 | # "driverless" utility | ||
23 | # ==================== | ||
24 | utils/driverless-fax: utils/driverless-fax.in Makefile | ||
25 | - sed \ | ||
26 | + mkdir -p utils && sed \ | ||
27 | -e "s|\@CUPS_SERVERBIN\@|$(CUPS_SERVERBIN)|" \ | ||
28 | $< > $@ | ||
29 | |||
30 | |||
31 | |||
32 | |||
33 | |||
diff --git a/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb b/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb index 0370ae79d2..efcd1aab8a 100644 --- a/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb +++ b/meta-oe/recipes-printing/cups/cups-filters_2.0.0.bb | |||
@@ -5,7 +5,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6d5b952b53dbe7752199903d082e5f07" | |||
5 | 5 | ||
6 | DEPENDS = "libcupsfilters libppd glib-2.0 poppler" | 6 | DEPENDS = "libcupsfilters libppd glib-2.0 poppler" |
7 | 7 | ||
8 | SRC_URI = "https://github.com/OpenPrinting/${BPN}/releases/download/${PV}/${BP}.tar.xz" | 8 | SRC_URI = " \ |
9 | https://github.com/OpenPrinting/${BPN}/releases/download/${PV}/${BP}.tar.xz \ | ||
10 | file://fix-make-race.patch \ | ||
11 | " | ||
9 | SRC_URI[sha256sum] = "b5152e3dd148ed73835827ac2f219df7cf5808dbf9dbaec2aa0127b44de800d8" | 12 | SRC_URI[sha256sum] = "b5152e3dd148ed73835827ac2f219df7cf5808dbf9dbaec2aa0127b44de800d8" |
10 | 13 | ||
11 | inherit autotools gettext pkgconfig github-releases | 14 | inherit autotools gettext pkgconfig github-releases |