summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-09-10 14:46:20 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-23 15:37:16 +0200
commit8b18ff5c34897b765c7a5d70bdef06e6c1a96f6c (patch)
treea6601423483f1a6738c7ed6b957111f2f6e0489d /meta-oe/recipes-navigation
parent82a00431d7bb48ba2d2e7201c7fe4faa6a3bf3ad (diff)
downloadmeta-openembedded-8b18ff5c34897b765c7a5d70bdef06e6c1a96f6c.tar.gz
gpsd: Fix build with gcc-5.2
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Include-stdatomic.h-only-in-C-mode.patch43
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb1
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Include-stdatomic.h-only-in-C-mode.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Include-stdatomic.h-only-in-C-mode.patch
new file mode 100644
index 000000000..bc9167eee
--- /dev/null
+++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Include-stdatomic.h-only-in-C-mode.patch
@@ -0,0 +1,43 @@
1From 79f6d9133378325d70a92e66f7352c1becefbb88 Mon Sep 17 00:00:00 2001
2From: Gleb Smirnoff <glebius@FreeBSD.org>
3Date: Sat, 16 May 2015 02:47:28 +0300
4Subject: [PATCH] Include <stdatomic.h> only in C mode.
5
6Upstream-Status: Backport from 3.15
7
8Without this build with gcc-5.2 fails with:
9| arm-oe-linux-gnueabi-g++ -march=armv4t -mthumb -mthumb-interwork -mtune=arm920t --sysroot=/OE/build/shr-core/tmp-glibc/sysroots/om-gta02 -o clock_gettime-qt.os -c -O2 -pipe -g -feliminate-unused-debug-types --sysroot=/OE/build/shr-core/tmp-glibc/sysroots/om-gta02 -Wextra -Wall -Wno-uninitialized -Wno-missing-field-initializers -Wcast-align -Wmissing-declarations -Wpointer-arith -Wreturn-type -pthread -Wmissing-declarations -g -O0 -pthread -fPIC -DUSE_QT -DQT_SHARED -I/OE/build/shr-core/tmp-glibc/sysroots/om-gta02/usr/include/dbus-1.0 -I/OE/build/shr-core/tmp-glibc/sysroots/om-gta02/usr/lib/dbus-1.0/include -I/OE/build/shr-core/tmp-glibc/sysroots/om-gta02/usr/include/qt4/QtNetwork -I/OE/build/shr-core/tmp-glibc/sysroots/om-gta02/usr/include/qt4 -I/OE/build/shr-core/tmp-glibc/sysroots/om-gta02/usr/include/qt4/QtCore clock_gettime.c
10| In file included from compiler.h:50:0,
11| from clock_gettime.c:10:
12| /OE/build/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/lib/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/5.2.0/include/stdatomic.h:40:9: error: '_Atomic' does not name a type
13| typedef _Atomic _Bool atomic_bool;
14| ^
15....
16
17More info:
18https://gcc.gnu.org/bugzilla/show_bug.cgi?id=60932
19
20Signed-off-by: Gary E. Miller <gem@rellim.com>
21---
22 compiler.h | 4 ++--
23 1 file changed, 2 insertions(+), 2 deletions(-)
24
25diff --git a/compiler.h b/compiler.h
26index 837c935..03430c0 100644
27--- a/compiler.h
28+++ b/compiler.h
29@@ -66,9 +66,9 @@
30 } while (0)
31
32 #ifdef HAVE_STDATOMIC_H
33-#ifndef __COVERITY__ /* Coverity is confused by a GNU typedef */
34+#if !defined(__COVERITY__) && !defined(__cplusplus)
35 #include <stdatomic.h>
36-#endif /* __COVERITY__ */
37+#endif /* __COVERITY__ || __cplusplus */
38 #endif /* HAVE_STDATOMIC_H */
39
40 #ifdef HAVE_OSATOMIC_H
41--
422.5.1
43
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
index 272bba8c2..dae39c24b 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
@@ -15,6 +15,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
15 file://0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch \ 15 file://0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch \
16 file://0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch \ 16 file://0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch \
17 file://0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch \ 17 file://0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch \
18 file://0001-Include-stdatomic.h-only-in-C-mode.patch \
18 file://gpsd-default \ 19 file://gpsd-default \
19 file://gpsd \ 20 file://gpsd \
20 file://60-gpsd.rules \ 21 file://60-gpsd.rules \