summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-07-30 23:50:12 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-07-31 00:14:55 +0200
commit2fba7222716ba4e9782ebc6e5077f99669bf69b3 (patch)
tree98e219ede466bc142955b090e5744724823d9bee /meta-oe/recipes-navigation
parent15b9efea5d229a3a2b108b9eac253417f09687ff (diff)
downloadmeta-openembedded-2fba7222716ba4e9782ebc6e5077f99669bf69b3.tar.gz
mcnavi, monav, omgps, orrery: import from meta-smartphone
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/mcnavi/mcnavi_0.3.3.bb18
-rw-r--r--meta-oe/recipes-navigation/monav/monav/monav.desktop10
-rw-r--r--meta-oe/recipes-navigation/monav/monav/monav.pngbin0 -> 21543 bytes
-rw-r--r--meta-oe/recipes-navigation/monav/monav_0.3.bb37
-rw-r--r--meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch59
-rw-r--r--meta-oe/recipes-navigation/omgps/omgps/gcc-4.4.patch68
-rw-r--r--meta-oe/recipes-navigation/omgps/omgps/sysfs.node.2.6.32.patch11
-rw-r--r--meta-oe/recipes-navigation/omgps/omgps/use.unused.variable.patch12
-rw-r--r--meta-oe/recipes-navigation/omgps/omgps_svn.bb23
-rw-r--r--meta-oe/recipes-navigation/orrery/orrery/orrery.pngbin0 -> 19475 bytes
-rw-r--r--meta-oe/recipes-navigation/orrery/orrery/use.GdkPixbuf.patch59
-rw-r--r--meta-oe/recipes-navigation/orrery/orrery_2.7.bb30
12 files changed, 327 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/mcnavi/mcnavi_0.3.3.bb b/meta-oe/recipes-navigation/mcnavi/mcnavi_0.3.3.bb
new file mode 100644
index 000000000..9c7f3f2a0
--- /dev/null
+++ b/meta-oe/recipes-navigation/mcnavi/mcnavi_0.3.3.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "Free GPS navigation for car and outdoor with OpenStreetMap maps"
2HOMEPAGE = "http://www.gps-routes.info/index.php?name=Content&pa=showpage&pid=1"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
5DEPENDS = "ecore evas imlib2 gpsd edje-native mysql5"
6
7SRC_URI = "http://www.gps-routes.info/debian/pool/main/m/mcnavi/mcnavi_${PV}.tar.gz"
8SRC_URI[md5sum] = "acc07debcdb3ef448b95e6a6cfcf53d8"
9SRC_URI[sha256sum] = "d3ce1f5901f13985d877b2b6ad06b64094ba43a4e13cbfe06c7cb2f1abdda309"
10
11S = "${WORKDIR}/${PN}"
12
13do_configure_prepend() {
14 # for some reason our mysql_config returns just sysroot/include_dir while mysql.h is in include_dir/mysql
15 sed -i 's#`mysql_config --include`#`mysql_config --include`/mysql#g' ${S}/configure.ac
16}
17
18inherit autotools
diff --git a/meta-oe/recipes-navigation/monav/monav/monav.desktop b/meta-oe/recipes-navigation/monav/monav/monav.desktop
new file mode 100644
index 000000000..5e861136f
--- /dev/null
+++ b/meta-oe/recipes-navigation/monav/monav/monav.desktop
@@ -0,0 +1,10 @@
1[Desktop Entry]
2Name=MoNav
3Exec=monav
4Icon=monav
5Terminal=false
6Type=Application
7Categories=Utility;Geography;
8X-MB-SingleInstance=true
9StartupNotify=true
10Comment=Fast navigation system featuring exact routing.
diff --git a/meta-oe/recipes-navigation/monav/monav/monav.png b/meta-oe/recipes-navigation/monav/monav/monav.png
new file mode 100644
index 000000000..75b5a7962
--- /dev/null
+++ b/meta-oe/recipes-navigation/monav/monav/monav.png
Binary files differ
diff --git a/meta-oe/recipes-navigation/monav/monav_0.3.bb b/meta-oe/recipes-navigation/monav/monav_0.3.bb
new file mode 100644
index 000000000..982d68272
--- /dev/null
+++ b/meta-oe/recipes-navigation/monav/monav_0.3.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "MoNav is a fast navigation system featuring exact routing with OpenStreetMap data."
2HOMEPAGE = "http://code.google.com/p/monav"
3SECTION = "x11/applications"
4LICENSE = "GPLv3+"
5LIC_FILES_CHKSUM = "file://misc/license_template_christian;md5=d99c9b3bafdde80adee296762376348d"
6
7DEPENDS = "qt-mobility-x11"
8PR = "r1"
9
10SRC_URI = "http://monav.googlecode.com/files/${BPN}-${PV}.tar.gz \
11 file://monav.png \
12 file://monav.desktop"
13
14SRC_URI[md5sum] = "d048ccef8c6a21e8656aa4af3fcb8329"
15SRC_URI[sha256sum] = "5a3bf9e9f7368b81ba8e2f755960082fc42a2e2c78f9de645f99ba293c77ee7f"
16
17inherit qmake2 qt4x11
18
19EXTRA_QMAKEVARS_PRE="CONFIG+="release""
20QMAKE_PROFILES="monavclient.pro"
21
22do_install_append() {
23 install -d ${D}${datadir}/monav
24 install -d ${D}${datadir}/monav/images
25 cp -a ${S}/images/* ${D}${datadir}/monav/images
26
27 install -d ${D}${datadir}/icons
28 install -m 0644 ${WORKDIR}/monav.png ${D}${datadir}/icons
29
30 install -d ${D}${bindir}
31 install -m 0755 ${S}/bin/monav ${D}${bindir}/monav
32
33 install -d ${D}/${datadir}/applications
34 install -m 0644 ${WORKDIR}/monav.desktop ${D}/${datadir}/applications
35}
36
37FILES_${PN} += "${bindir}/monav ${datadir}/icons/monav.png"
diff --git a/meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch b/meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch
new file mode 100644
index 000000000..56ec3a445
--- /dev/null
+++ b/meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch
@@ -0,0 +1,59 @@
1we need to include config.h first to know if HAVE_SYS_CAPABILITY_H is enabled or no, otherwise
2sys/capability.h is not included and later used
3| src/network.c: In function 'can_ping':
4| src/network.c:198:2: error: 'cap_flag_value_t' undeclared (first use in this function)
5| src/network.c:198:2: note: each undeclared identifier is reported only once for each function it appears in
6| src/network.c:198:19: error: expected ';' before 'cap'
7| src/network.c:199:2: error: 'cap_t' undeclared (first use in this function)
8| src/network.c:199:8: error: expected ';' before 'caps'
9| src/network.c:200:6: error: 'caps' undeclared (first use in this function)
10| cc1: warnings being treated as errors
11| src/network.c:203:2: error: implicit declaration of function 'cap_get_flag'
12| src/network.c:203:21: error: 'CAP_SYS_NICE' undeclared (first use in this function)
13| src/network.c:203:35: error: 'CAP_EFFECTIVE' undeclared (first use in this function)
14| src/network.c:203:51: error: 'cap' undeclared (first use in this function)
15| src/network.c:204:17: error: 'CAP_CLEAR' undeclared (first use in this function)
16| src/network.c:210:1: error: control reaches end of non-void function
17| make[1]: *** [omgps-network.o] Error 1
18
19and -lcap is needed for 2 functions later (should be added only for HAVE_SYS_CAPABILITY_H enabled, but I don't care enough)
20| omgps-network.o: In function `can_ping':
21| /OE/tmpdir-shr/work/armv4t-oe-linux-gnueabi/omgps-0.1+svnr109-r1/omgps/src/network.c:199: undefined reference to `cap_get_proc'
22| /OE/tmpdir-shr/work/armv4t-oe-linux-gnueabi/omgps-0.1+svnr109-r1/omgps/src/network.c:203: undefined reference to `cap_get_flag'
23| collect2: ld returned 1 exit status
24
25--- omgps.orig/src/network.c 2009-10-28 18:51:16.000000000 +0100
26+++ omgps/src/network.c 2011-05-09 09:59:11.637676772 +0200
27@@ -19,16 +19,16 @@
28 #include <assert.h>
29 #include <glib.h>
30
31-#if (HAVE_SYS_CAPABILITY_H)
32-#undef _POSIX_SOURCE
33-#include <sys/capability.h>
34-#endif
35-
36 #include "config.h"
37 #include "util.h"
38 #include "network.h"
39 #include "customized.h"
40
41+#if (HAVE_SYS_CAPABILITY_H)
42+#undef _POSIX_SOURCE
43+#include <sys/capability.h>
44+#endif
45+
46 /**
47 * Ping: reference <Unix network programming>, volume 1, third edition.
48 */
49--- omgps.orig/Makefile.am 2009-10-28 18:51:17.000000000 +0100
50+++ omgps/Makefile.am 2011-05-09 10:04:58.578676679 +0200
51@@ -33,7 +33,7 @@
52
53 omgps_CFLAGS = $(common_CFLAGS) -O2
54 omgps_LDFLAGS =
55-omgps_LDADD = @DEPENDENCIES_LIBS@ -lpython$(PY_VERSION)
56+omgps_LDADD = @DEPENDENCIES_LIBS@ -lcap -lpython$(PY_VERSION)
57
58 omgps_SOURCES = \
59 src/ctx_agps_online.c \
diff --git a/meta-oe/recipes-navigation/omgps/omgps/gcc-4.4.patch b/meta-oe/recipes-navigation/omgps/omgps/gcc-4.4.patch
new file mode 100644
index 000000000..3eae96042
--- /dev/null
+++ b/meta-oe/recipes-navigation/omgps/omgps/gcc-4.4.patch
@@ -0,0 +1,68 @@
1diff -uNr omgps.orig/src/include/map_repo.h omgps/src/include/map_repo.h
2--- omgps.orig/src/include/map_repo.h 2009-07-20 19:54:08.000000000 +0200
3+++ omgps/src/include/map_repo.h 2010-01-17 14:55:24.000000000 +0100
4@@ -3,6 +3,9 @@
5
6 #include <glib.h>
7 #include <gdk/gdk.h>
8+// workaround Python.h unconditionally (re)defines _XOPEN_SOURCE and _POSIX_C_SOURCE
9+#undef _XOPEN_SOURCE
10+#undef _POSIX_C_SOURCE
11 #include <Python.h>
12
13 #define MAP_MAX_BG_COLORS 5
14diff -uNr omgps.orig/src/include/py_ext.h omgps/src/include/py_ext.h
15--- omgps.orig/src/include/py_ext.h 2009-07-20 19:54:08.000000000 +0200
16+++ omgps/src/include/py_ext.h 2010-01-17 14:55:57.000000000 +0100
17@@ -4,8 +4,8 @@
18 void py_ext_init();
19 void py_ext_cleanup();
20
21-void inline py_ext_trylock();
22-void inline py_ext_lock();
23-void inline py_ext_unlock();
24+void py_ext_trylock();
25+void py_ext_lock();
26+void py_ext_unlock();
27
28 #endif /* PY_EXT_H_ */
29diff -uNr omgps.orig/src/include/uart.h omgps/src/include/uart.h
30--- omgps.orig/src/include/uart.h 2009-07-20 19:54:08.000000000 +0200
31+++ omgps/src/include/uart.h 2010-01-17 14:33:00.000000000 +0100
32@@ -12,9 +12,9 @@
33 extern void uart_cleanup();
34 extern void uart_close();
35
36-extern inline int read_with_timeout(U1 *buf, int len);
37-extern inline int write_with_timeout(U1 *buf, int len);
38-extern inline gboolean read_fixed_len(U1 *buf, int expected_len);
39+extern int read_with_timeout(U1 *buf, int len);
40+extern int write_with_timeout(U1 *buf, int len);
41+extern gboolean read_fixed_len(U1 *buf, int expected_len);
42
43 extern int sysfs_get_gps_device_power();
44 extern gboolean gps_device_power_on();
45diff -uNr omgps.orig/src/py_ext.c omgps/src/py_ext.c
46--- omgps.orig/src/py_ext.c 2009-07-20 19:54:08.000000000 +0200
47+++ omgps/src/py_ext.c 2010-01-17 14:56:46.000000000 +0100
48@@ -26,17 +26,17 @@
49 Py_Finalize();
50 }
51
52-void inline py_ext_trylock()
53+void py_ext_trylock()
54 {
55 TRYLOCK_MUTEX(&lock);
56 }
57
58-void inline py_ext_lock()
59+void py_ext_lock()
60 {
61 LOCK_MUTEX(&lock);
62 }
63
64-void inline py_ext_unlock()
65+void py_ext_unlock()
66 {
67 UNLOCK_MUTEX(&lock);
68 }
diff --git a/meta-oe/recipes-navigation/omgps/omgps/sysfs.node.2.6.32.patch b/meta-oe/recipes-navigation/omgps/omgps/sysfs.node.2.6.32.patch
new file mode 100644
index 000000000..d18a2fdb4
--- /dev/null
+++ b/meta-oe/recipes-navigation/omgps/omgps/sysfs.node.2.6.32.patch
@@ -0,0 +1,11 @@
1diff -uNr omgps.orig//src/uart.c omgps/src/uart.c
2--- omgps.orig//src/uart.c 2010-08-22 23:34:09.000000000 +0200
3+++ omgps/src/uart.c 2010-08-22 23:33:54.000000000 +0200
4@@ -30,6 +30,7 @@
5 * NOTE: these file paths are subject to change according to kernel and distribution.
6 */
7 static const char *sysfs_gps_power[] = {
8+ "/sys/bus/platform/devices/gta02-pm-gps.0/power_on",
9 "/sys/bus/platform/devices/neo1973-pm-gps.0/power_on",
10 "/sys/bus/platform/devices/neo1973-pm-gps.0/pwron"
11 };
diff --git a/meta-oe/recipes-navigation/omgps/omgps/use.unused.variable.patch b/meta-oe/recipes-navigation/omgps/omgps/use.unused.variable.patch
new file mode 100644
index 000000000..73d6dbab6
--- /dev/null
+++ b/meta-oe/recipes-navigation/omgps/omgps/use.unused.variable.patch
@@ -0,0 +1,12 @@
1--- a/src/settings.c 2011-12-12 13:21:30.573400795 +0100
2+++ b/src/settings.c 2011-12-12 14:11:05.269606119 +0100
3@@ -278,6 +278,9 @@
4 }
5
6 ret = check_settings(errbuf, ERRBUF_LEN);
7+ if (ret == FALSE) {
8+ snprintf(errbuf, ERRBUF_LEN, "Something wrong while loading settings file");
9+ }
10
11 if (fd > 0)
12 close(fd);
diff --git a/meta-oe/recipes-navigation/omgps/omgps_svn.bb b/meta-oe/recipes-navigation/omgps/omgps_svn.bb
new file mode 100644
index 000000000..59fd9b0ad
--- /dev/null
+++ b/meta-oe/recipes-navigation/omgps/omgps_svn.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "GPS application for openmoko freerunner"
2HOMEPAGE = "http://omgps.googlecode.com"
3SECTION = "openmoko/applications"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
6DEPENDS = "gtk+ python-pygobject dbus-glib"
7SRCREV = "109"
8PV = "0.1+svnr${SRCPV}"
9S = "${WORKDIR}/${PN}"
10
11do_configure_prepend() {
12 sed -i "s#PY_VERSION = 2.6#PY_VERSION = ${PYTHON_BASEVERSION}#g" ${S}/Makefile.am
13 sed -i "s#PY_INC_DIR = \$(OPIEDIR)#PY_INC_DIR = ${STAGING_DIR_HOST}#g" ${S}/Makefile.am
14}
15
16SRC_URI = "svn://omgps.googlecode.com/svn/trunk;module=omgps;protocol=http \
17 file://gcc-4.4.patch \
18 file://sysfs.node.2.6.32.patch \
19 file://fix.capability.patch \
20 file://use.unused.variable.patch \
21"
22
23inherit autotools
diff --git a/meta-oe/recipes-navigation/orrery/orrery/orrery.png b/meta-oe/recipes-navigation/orrery/orrery/orrery.png
new file mode 100644
index 000000000..d9865b70c
--- /dev/null
+++ b/meta-oe/recipes-navigation/orrery/orrery/orrery.png
Binary files differ
diff --git a/meta-oe/recipes-navigation/orrery/orrery/use.GdkPixbuf.patch b/meta-oe/recipes-navigation/orrery/orrery/use.GdkPixbuf.patch
new file mode 100644
index 000000000..92d194de0
--- /dev/null
+++ b/meta-oe/recipes-navigation/orrery/orrery/use.GdkPixbuf.patch
@@ -0,0 +1,59 @@
1From: Benjamin Deering
2Subject: orrery crashing X
3Date: Thursday, September 2, 2010 - 5:25 pm
4Link: http://kerneltrap.org/mailarchive/openmoko-community/2010/9/3/13218
5
6diff -uNr orrery.orig//orrery.c orrery/orrery.c
7--- orrery.orig//orrery.c 2009-11-30 06:59:44.000000000 +0100
8+++ orrery/orrery.c 2010-11-15 22:33:17.000000000 +0100
9@@ -1238,12 +1238,44 @@
10 }
11 currentEntry = currentEntry->forwardPointer;
12 }
13- if (nDarkGreyPoints > 0)
14- gdk_draw_points(pixmap, darkGreyGC, darkGreyPoints, nDarkGreyPoints);
15- if (nGreyPoints > 0)
16- gdk_draw_points(pixmap, greyGC, greyPoints, nGreyPoints);
17- if (nWhitePoints > 0)
18- gdk_draw_points(pixmap, whiteGC, whitePoints, nWhitePoints);
19+ GdkPixbuf* starDrawingBuf = gdk_pixbuf_get_from_drawable( NULL,
20+ pixmap,
21+ gdk_colormap_get_system()
22+ , 0, 0, 0, 0, displayWidth, displayHeight);
23+ g_assert (gdk_pixbuf_get_bits_per_sample (starDrawingBuf) == 8);
24+ guchar* p;
25+ int rowstride = gdk_pixbuf_get_rowstride (starDrawingBuf);
26+ guchar* pixels = gdk_pixbuf_get_pixels (starDrawingBuf);
27+ int n_channels = gdk_pixbuf_get_n_channels (starDrawingBuf);
28+ GdkGCValues starGCval;
29+ GdkColor starColor;
30+ int pointNum;
31+ gdk_gc_get_values(darkGreyGC, &starGCval);
32+ gdk_colormap_query_color( gdk_gc_get_colormap(darkGreyGC),starGCval.foreground.pixel, &starColor );
33+ for( pointNum = 0; pointNum < nDarkGreyPoints; pointNum++) {
34+ p = pixels + darkGreyPoints[pointNum].y * rowstride + darkGreyPoints[pointNum].x * n_channels;
35+ p[0] = starColor.red & 0xff;
36+ p[1] = starColor.green & 0xff;
37+ p[2] = starColor.blue & 0xff;
38+ }
39+ gdk_gc_get_values(greyGC, &starGCval);
40+ gdk_colormap_query_color( gdk_gc_get_colormap(greyGC), starGCval.foreground.pixel, &starColor );
41+ for( pointNum = 0; pointNum < nGreyPoints; pointNum++) {
42+ p = pixels + greyPoints[pointNum].y * rowstride + greyPoints[pointNum].x * n_channels;
43+ p[0] = starColor.red & 0xff;
44+ p[1] = starColor.green & 0xff;
45+ p[2] = starColor.blue & 0xff;
46+ }
47+ gdk_gc_get_values(whiteGC, &starGCval);
48+ gdk_colormap_query_color( gdk_gc_get_colormap(whiteGC), starGCval.foreground.pixel, &starColor );
49+ for( pointNum = 0; pointNum < nWhitePoints; pointNum++) {
50+ p = pixels + whitePoints[pointNum].y * rowstride + whitePoints[pointNum].x * n_channels;
51+ p[0] = starColor.red & 0xff;
52+ p[1] = starColor.green & 0xff;
53+ p[2] = starColor.blue & 0xff;
54+ }
55+ gdk_draw_pixbuf ( pixmap , NULL , starDrawingBuf,
56+ 0, 0, 0, 0, displayWidth, displayHeight, GDK_RGB_DITHER_NORMAL, 0, 0 ) ;
57 }
58
59 void makeTimeString(char *string)
diff --git a/meta-oe/recipes-navigation/orrery/orrery_2.7.bb b/meta-oe/recipes-navigation/orrery/orrery_2.7.bb
new file mode 100644
index 000000000..1e41f5bbd
--- /dev/null
+++ b/meta-oe/recipes-navigation/orrery/orrery_2.7.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Astronomical application which displays the night sky"
2HOMEPAGE = "http://projects.openmoko.org/projects/orrery/"
3SECTION = "x11/scientific"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://orrery.c;endline=25;md5=d792bdf2b591972da175aecc38d88cfe"
6
7inherit autotools
8
9SRC_URI = "http://projects.openmoko.org/frs/download.php/923/orrery_2.7_clean.tar.gz \
10 file://orrery.png \
11 file://use.GdkPixbuf.patch \
12"
13
14SRC_URI[md5sum] = "bd62a33e7554ee1030313dfcdefcda8b"
15SRC_URI[sha256sum] = "645166a5e05b2064ab630534a514697fc47b681951e7fe1d635c259cbdf7a5e6"
16
17S = "${WORKDIR}/${PN}"
18
19do_configure_prepend() {
20 # fix DSO issue with binutils-2.22
21 sed -i 's/ -lrt/ -lrt -lm/g' ${S}/Makefile.am
22}
23do_install_append() {
24 install -d ${D}${datadir}/orrery
25 cp -a ${S}/data/* ${D}${datadir}/orrery
26 install -d ${D}${datadir}/icons
27 install -m 0755 ${WORKDIR}/orrery.png ${D}${datadir}/icons
28}
29
30FILES_${PN} += "${datadir}/icons/orrery.png"