summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-26 18:11:36 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-26 21:52:26 -0800
commit0755cdd5152e00c56eba59820166961aed488e02 (patch)
treeed13e875c4dd99268e08398436260012c19fa91d /meta-oe/recipes-navigation
parent7eff93b1577bfd450e5c8770729314bb3dc5278c (diff)
downloadmeta-openembedded-0755cdd5152e00c56eba59820166961aed488e02.tar.gz
geos: Fix build with gcc13
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/geos/geos/0001-include-missing-cstdint.patch82
-rw-r--r--meta-oe/recipes-navigation/geos/geos_3.9.4.bb3
2 files changed, 84 insertions, 1 deletions
diff --git a/meta-oe/recipes-navigation/geos/geos/0001-include-missing-cstdint.patch b/meta-oe/recipes-navigation/geos/geos/0001-include-missing-cstdint.patch
new file mode 100644
index 000000000..6cfd2e81b
--- /dev/null
+++ b/meta-oe/recipes-navigation/geos/geos/0001-include-missing-cstdint.patch
@@ -0,0 +1,82 @@
1From 11b9ef265a942cb3fdd373520d0c3fce67d3cdf9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 26 Jan 2023 18:05:33 -0800
4Subject: [PATCH] include missing <cstdint>
5
6gcc 13 moved some includes around and as a result <cstdint> is no longer transitively included [1]. Explicitly include it for uint{32,64}_t.
7
8[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
9
10Upstream-Status: Backport [https://github.com/kraj/geos/commit/0e8d4368b]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 include/geos/geomgraph/TopologyLocation.h | 1 +
14 include/geos/io/WKTWriter.h | 1 +
15 include/geos/shape/fractal/HilbertCode.h | 1 +
16 include/geos/shape/fractal/HilbertEncoder.h | 1 +
17 include/geos/shape/fractal/MortonCode.h | 1 +
18 5 files changed, 5 insertions(+)
19
20diff --git a/include/geos/geomgraph/TopologyLocation.h b/include/geos/geomgraph/TopologyLocation.h
21index 4cbbacb3..a3ecd212 100644
22--- a/include/geos/geomgraph/TopologyLocation.h
23+++ b/include/geos/geomgraph/TopologyLocation.h
24@@ -25,6 +25,7 @@
25 #include <geos/inline.h>
26 #include <geos/geom/Location.h>
27
28+#include <cstdint>
29 #include <vector>
30 #include <array>
31 #include <string>
32diff --git a/include/geos/io/WKTWriter.h b/include/geos/io/WKTWriter.h
33index c0af8e71..0d60e975 100644
34--- a/include/geos/io/WKTWriter.h
35+++ b/include/geos/io/WKTWriter.h
36@@ -25,6 +25,7 @@
37
38 #include <string>
39 #include <cctype>
40+#include <cstdint>
41
42 #ifdef _MSC_VER
43 #pragma warning(push)
44diff --git a/include/geos/shape/fractal/HilbertCode.h b/include/geos/shape/fractal/HilbertCode.h
45index 46012efc..beeb28c6 100644
46--- a/include/geos/shape/fractal/HilbertCode.h
47+++ b/include/geos/shape/fractal/HilbertCode.h
48@@ -17,6 +17,7 @@
49
50 #include <geos/export.h>
51 #include <string>
52+#include <cstdint>
53
54 // Forward declarations
55 namespace geos {
56diff --git a/include/geos/shape/fractal/HilbertEncoder.h b/include/geos/shape/fractal/HilbertEncoder.h
57index 61c0010d..0126d3d9 100644
58--- a/include/geos/shape/fractal/HilbertEncoder.h
59+++ b/include/geos/shape/fractal/HilbertEncoder.h
60@@ -16,6 +16,7 @@
61 #pragma once
62
63 #include <geos/export.h>
64+#include <cstdint>
65 #include <string>
66 #include <vector>
67
68diff --git a/include/geos/shape/fractal/MortonCode.h b/include/geos/shape/fractal/MortonCode.h
69index 6743f87c..ad4a42e7 100644
70--- a/include/geos/shape/fractal/MortonCode.h
71+++ b/include/geos/shape/fractal/MortonCode.h
72@@ -17,6 +17,7 @@
73
74 #include <geos/export.h>
75 #include <string>
76+#include <cstdint>
77
78 // Forward declarations
79 namespace geos {
80--
812.39.1
82
diff --git a/meta-oe/recipes-navigation/geos/geos_3.9.4.bb b/meta-oe/recipes-navigation/geos/geos_3.9.4.bb
index 7822cde30..558acd92b 100644
--- a/meta-oe/recipes-navigation/geos/geos_3.9.4.bb
+++ b/meta-oe/recipes-navigation/geos/geos_3.9.4.bb
@@ -5,7 +5,8 @@ SECTION = "libs"
5LICENSE = "LGPL-2.1-or-later" 5LICENSE = "LGPL-2.1-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" 6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7 7
8SRC_URI = "http://download.osgeo.org/${BPN}/${BP}.tar.bz2" 8SRC_URI = "http://download.osgeo.org/${BPN}/${BP}.tar.bz2 \
9 file://0001-include-missing-cstdint.patch"
9SRC_URI[sha256sum] = "70dff2530d8cd2dfaeeb91a5014bd17afb1baee8f0e3eb18e44d5b4dbea47b14" 10SRC_URI[sha256sum] = "70dff2530d8cd2dfaeeb91a5014bd17afb1baee8f0e3eb18e44d5b4dbea47b14"
10 11
11inherit autotools pkgconfig binconfig 12inherit autotools pkgconfig binconfig