summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/gpsd
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-07-11 20:02:06 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:07 +0200
commit87526c2f21b9ae911d74616e0f74b7eef43fa13a (patch)
tree606454c07192ce7b4a01f1f869f78091f710b128 /meta-oe/recipes-navigation/gpsd
parentfca1dffca771f1c6bdcb859ac4fe2d380ee5f404 (diff)
downloadmeta-openembedded-87526c2f21b9ae911d74616e0f74b7eef43fa13a.tar.gz
gpsd: move systemd support to meta-systemd
Diffstat (limited to 'meta-oe/recipes-navigation/gpsd')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service10
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb15
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb15
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_git.bb14
4 files changed, 12 insertions, 42 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service b/meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service
deleted file mode 100644
index 7131a589d..000000000
--- a/meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service
+++ /dev/null
@@ -1,10 +0,0 @@
1[Unit]
2Description=GPS (Global Positioning System) Daemon
3Requires=gpsd.socket
4
5[Service]
6EnvironmentFile=/etc/default/gpsd
7ExecStart=/usr/sbin/gpsd -N $GPS_DEVICES
8
9[Install]
10Also=gpsd.socket
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
index ebc4af6d6..4f3d2d712 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
5DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-native" 5DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-native"
6PROVIDES = "virtual/gpsd" 6PROVIDES = "virtual/gpsd"
7 7
8PR = "r2" 8PR = "r3"
9 9
10SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ 10SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
11 file://0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch \ 11 file://0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch \
@@ -15,20 +15,18 @@ SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
15 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ 15 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
16 file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \ 16 file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
17 file://gpsd-default \ 17 file://gpsd-default \
18 file://gpsd.service \
19 file://gpsd \ 18 file://gpsd \
20 file://60-gpsd.rules \ 19 file://60-gpsd.rules \
21" 20"
22SRC_URI[md5sum] = "c01353459faa68834309109d4e868460" 21SRC_URI[md5sum] = "c01353459faa68834309109d4e868460"
23SRC_URI[sha256sum] = "79f7de9ead63c7f5d2c9a92e85b5f82e53323c4d451ef8e27ea265ac3ef9a70f" 22SRC_URI[sha256sum] = "79f7de9ead63c7f5d2c9a92e85b5f82e53323c4d451ef8e27ea265ac3ef9a70f"
24 23
25inherit scons update-rc.d python-dir systemd 24inherit scons update-rc.d python-dir
26 25
27INITSCRIPT_NAME = "gpsd" 26INITSCRIPT_NAME = "gpsd"
28INITSCRIPT_PARAMS = "defaults 35" 27INITSCRIPT_PARAMS = "defaults 35"
29 28
30SYSTEMD_PACKAGES = "${PN}-systemd" 29SYSTEMD_OESCONS ??= "false"
31SYSTEMD_SERVICE = "${PN}.socket"
32 30
33export STAGING_INCDIR 31export STAGING_INCDIR
34export STAGING_LIBDIR 32export STAGING_LIBDIR
@@ -38,7 +36,7 @@ EXTRA_OESCONS = " \
38 libQgpsmm='false' \ 36 libQgpsmm='false' \
39 debug='true' \ 37 debug='true' \
40 strip='false' \ 38 strip='false' \
41 systemd='true' \ 39 systemd='${SYSTEMD_OESCONS}' \
42" 40"
43# this cannot be used, because then chrpath is not found and only static lib is built 41# this cannot be used, because then chrpath is not found and only static lib is built
44# target=${HOST_SYS} 42# target=${HOST_SYS}
@@ -81,11 +79,6 @@ do_install_append() {
81 #support for python 79 #support for python
82 install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps 80 install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
83 install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps 81 install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
84
85 #support for systemd
86 install -d ${D}${systemd_unitdir}/system/
87 install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service
88 install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket
89} 82}
90 83
91pkg_postinst_${PN}-conf() { 84pkg_postinst_${PN}-conf() {
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb
index 083163b6d..3cac186e6 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
5DEPENDS = "dbus dbus-glib ncurses python libusb1" 5DEPENDS = "dbus dbus-glib ncurses python libusb1"
6PROVIDES = "virtual/gpsd" 6PROVIDES = "virtual/gpsd"
7 7
8PR = "r2" 8PR = "r3"
9 9
10DEFAULT_PREFERENCE = "-1" 10DEFAULT_PREFERENCE = "-1"
11SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \ 11SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
@@ -16,20 +16,18 @@ SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
16 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ 16 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
17 file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \ 17 file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
18 file://gpsd-default \ 18 file://gpsd-default \
19 file://gpsd.service \
20 file://gpsd \ 19 file://gpsd \
21 file://60-gpsd.rules \ 20 file://60-gpsd.rules \
22" 21"
23SRC_URI[md5sum] = "e96881798a0ab67aa3cd5f3249f0e536" 22SRC_URI[md5sum] = "e96881798a0ab67aa3cd5f3249f0e536"
24SRC_URI[sha256sum] = "5ebb0b00c49421eb8fbead81342e5ce63e82065e5ff27da586f10e342b999171" 23SRC_URI[sha256sum] = "5ebb0b00c49421eb8fbead81342e5ce63e82065e5ff27da586f10e342b999171"
25 24
26inherit scons update-rc.d python-dir systemd 25inherit scons update-rc.d python-dir
27 26
28INITSCRIPT_NAME = "gpsd" 27INITSCRIPT_NAME = "gpsd"
29INITSCRIPT_PARAMS = "defaults 35" 28INITSCRIPT_PARAMS = "defaults 35"
30 29
31SYSTEMD_PACKAGES = "${PN}-systemd" 30SYSTEMD_OESCONS ??= "false"
32SYSTEMD_SERVICE = "${PN}.socket"
33 31
34export STAGING_INCDIR 32export STAGING_INCDIR
35export STAGING_LIBDIR 33export STAGING_LIBDIR
@@ -39,7 +37,7 @@ EXTRA_OESCONS = " \
39 libQgpsmm='false' \ 37 libQgpsmm='false' \
40 debug='true' \ 38 debug='true' \
41 strip='false' \ 39 strip='false' \
42 systemd='true' \ 40 systemd='${SYSTEMD_OESCONS}' \
43" 41"
44# this cannot be used, because then chrpath is not found and only static lib is built 42# this cannot be used, because then chrpath is not found and only static lib is built
45# target=${HOST_SYS} 43# target=${HOST_SYS}
@@ -82,11 +80,6 @@ do_install_append() {
82 #support for python 80 #support for python
83 install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps 81 install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
84 install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps 82 install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
85
86 #support for systemd
87 install -d ${D}${systemd_unitdir}/system/
88 install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service
89 install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket
90} 83}
91 84
92pkg_postinst_${PN}-conf() { 85pkg_postinst_${PN}-conf() {
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_git.bb b/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
index 0cf068546..1c7d76fa0 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
5DEPENDS = "dbus dbus-glib ncurses python libusb1" 5DEPENDS = "dbus dbus-glib ncurses python libusb1"
6PROVIDES = "virtual/gpsd" 6PROVIDES = "virtual/gpsd"
7 7
8PR = "r1" 8PR = "r2"
9 9
10SRCREV = "f8744f4af8cef211de698df5d8e6caddfe33f29d" 10SRCREV = "f8744f4af8cef211de698df5d8e6caddfe33f29d"
11 11
@@ -25,13 +25,12 @@ SRC_URI = "git://git.sv.gnu.org/gpsd.git;protocol=git;branch=master \
25" 25"
26S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
27 27
28inherit scons update-rc.d python-dir systemd 28inherit scons update-rc.d python-dir
29 29
30INITSCRIPT_NAME = "gpsd" 30INITSCRIPT_NAME = "gpsd"
31INITSCRIPT_PARAMS = "defaults 35" 31INITSCRIPT_PARAMS = "defaults 35"
32 32
33SYSTEMD_PACKAGES = "${PN}-systemd" 33SYSTEMD_OESCONS ??= "false"
34SYSTEMD_SERVICE = "${PN}.socket"
35 34
36export STAGING_INCDIR 35export STAGING_INCDIR
37export STAGING_LIBDIR 36export STAGING_LIBDIR
@@ -41,7 +40,7 @@ EXTRA_OESCONS = " \
41 libQgpsmm='false' \ 40 libQgpsmm='false' \
42 debug='true' \ 41 debug='true' \
43 strip='false' \ 42 strip='false' \
44 systemd='true' \ 43 systemd='${SYSTEMD_OESCONS}' \
45" 44"
46# this cannot be used, because then chrpath is not found and only static lib is built 45# this cannot be used, because then chrpath is not found and only static lib is built
47# target=${HOST_SYS} 46# target=${HOST_SYS}
@@ -84,11 +83,6 @@ do_install_append() {
84 #support for python 83 #support for python
85 install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps 84 install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
86 install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps 85 install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
87
88 #support for systemd
89 install -d ${D}${systemd_unitdir}/system/
90 install -m 0644 ${S}/systemd/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service
91 install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket
92} 86}
93 87
94pkg_postinst_${PN}-conf() { 88pkg_postinst_${PN}-conf() {