summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2012-08-07 11:08:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-08-20 10:02:09 +0200
commit334b5198e12e95f69af4772c0c2f8e512d63451b (patch)
tree9e49c0acbb06b0c5ea5dc4cd17fe366f8e1204fe /meta-oe/recipes-navigation/gpsd/gpsd_git.bb
parent5fd2b71ccab54b0717ebed21869754de16bd3608 (diff)
downloadmeta-openembedded-334b5198e12e95f69af4772c0c2f8e512d63451b.tar.gz
gpsd: update to 3.7, drop older 3.5 and git recipe
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation/gpsd/gpsd_git.bb')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_git.bb127
1 files changed, 0 insertions, 127 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_git.bb b/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
deleted file mode 100644
index 380f3ba71..000000000
--- a/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
+++ /dev/null
@@ -1,127 +0,0 @@
1DESCRIPTION = "A TCP/IP Daemon simplifying the communication with GPS devices"
2SECTION = "console/network"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
5DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-native"
6PROVIDES = "virtual/gpsd"
7
8PR = "r4"
9
10SRCREV = "f8744f4af8cef211de698df5d8e6caddfe33f29d"
11
12DEFAULT_PREFERENCE = "-1"
13PV = "3.5+gitr${SRCPV}"
14
15SRC_URI = "git://git.sv.gnu.org/gpsd.git;protocol=git;branch=master \
16 file://0001-SConstruct-respect-sysroot-setting-when-prepending-L.patch \
17 file://0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \
18 file://0003-Revert-The-strptime-prototype-is-not-provided-unless.patch \
19 file://0004-SConstruct-remove-rpath.patch \
20 file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
21 file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
22 file://gpsd-default \
23 file://gpsd \
24 file://60-gpsd.rules \
25"
26S = "${WORKDIR}/git"
27
28inherit scons update-rc.d python-dir pythonnative
29
30INITSCRIPT_NAME = "gpsd"
31INITSCRIPT_PARAMS = "defaults 35"
32
33SYSTEMD_OESCONS ??= "false"
34
35export STAGING_INCDIR
36export STAGING_LIBDIR
37
38EXTRA_OESCONS = " \
39 sysroot=${STAGING_DIR_TARGET} \
40 libQgpsmm='false' \
41 debug='true' \
42 strip='false' \
43 systemd='${SYSTEMD_OESCONS}' \
44"
45# this cannot be used, because then chrpath is not found and only static lib is built
46# target=${HOST_SYS}
47
48do_compile_prepend() {
49 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
50 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
51 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
52
53 export BUILD_SYS="${BUILD_SYS}"
54 export HOST_SYS="${HOST_SYS}"
55}
56
57do_install() {
58 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
59 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
60 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
61
62 export BUILD_SYS="${BUILD_SYS}"
63 export HOST_SYS="${HOST_SYS}"
64
65 export DESTDIR="${D}"
66 # prefix is used for RPATH and DESTDIR/prefix for instalation
67 ${STAGING_BINDIR_NATIVE}/scons prefix=${prefix} install ${EXTRA_OESCONS}|| \
68 bbfatal "scons install execution failed."
69}
70
71do_install_append() {
72 install -d ${D}/${sysconfdir}/init.d
73 install -m 0755 ${WORKDIR}/gpsd ${D}/${sysconfdir}/init.d/
74 install -d ${D}/${sysconfdir}/default
75 install -m 0644 ${WORKDIR}/gpsd-default ${D}/${sysconfdir}/default/gpsd.default
76
77 #support for udev
78 install -d ${D}/${sysconfdir}/udev/rules.d
79 install -m 0644 ${WORKDIR}/60-gpsd.rules ${D}/${sysconfdir}/udev/rules.d
80 install -d ${D}${base_libdir}/udev/
81 install -m 0755 ${S}/gpsd.hotplug ${D}${base_libdir}/udev/
82
83 #support for python
84 install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
85 install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
86}
87
88pkg_postinst_${PN}-conf() {
89 update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10
90}
91
92pkg_postrm_${PN}-conf() {
93 update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
94}
95
96PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils"
97
98FILES_gpsd-dev += "${libdir}/pkgconfdir/libgpsd.pc ${libdir}/pkgconfdir/libgps.pc"
99
100FILES_python-pygps-dbg += " ${libdir}/python*/site-packages/gps/.debug"
101
102RDEPENDS_${PN} = "gpsd-gpsctl"
103RRECOMMENDS_${PN} = "gpsd-conf gpsd-udev"
104
105DESCRIPTION_gpsd-udev = "udev relevant files to use gpsd hotplugging"
106FILES_gpsd-udev = "${base_libdir}/udev ${sysconfdir}/udev/*"
107RDEPENDS_gpsd-udev += "udev gpsd-conf"
108
109DESCRIPTION_libgpsd = "C service library used for communicating with gpsd"
110FILES_libgpsd = "${libdir}/libgpsd.so.*"
111
112DESCRIPTION_libgps = "C service library used for communicating with gpsd"
113FILES_libgps = "${libdir}/libgps.so.*"
114
115DESCRIPTION_gpsd-conf = "gpsd configuration files and init scripts"
116FILES_gpsd-conf = "${sysconfdir}"
117
118DESCRIPTION_gpsd-gpsctl = "Tool for tweaking GPS modes"
119FILES_gpsd-gpsctl = "${bindir}/gpsctl"
120
121DESCRIPTION_gps-utils = "Utils used for simulating, monitoring,... a GPS"
122FILES_gps-utils = "${bindir}/*"
123RDEPENDS_gps-utils = "python-pygps"
124
125DESCRIPTION_python-pygps = "Python bindings to gpsd"
126FILES_python-pygps = "${PYTHON_SITEPACKAGES_DIR}/*"
127RDEPENDS_python-pygps = "python-core python-curses gpsd python-json"