summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/geoclue
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-navigation/geoclue
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-navigation/geoclue')
-rw-r--r--meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch30
-rw-r--r--meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb31
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch b/meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch
new file mode 100644
index 000000000..70fe3f55a
--- /dev/null
+++ b/meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch
@@ -0,0 +1,30 @@
1Upstream-Status: Upstream-Status: Inappropriate [poky 9.0 has older libsoup]
2
3Signed-off-by: Felipe F. Tonello <eu@felipetonello.com>
4
5diff --git a/src/gclue-ipclient.c b/src/gclue-ipclient.c
6index 09add30..1771d5c 100644
7--- a/src/gclue-ipclient.c
8+++ b/src/gclue-ipclient.c
9@@ -83,7 +83,7 @@ gclue_ipclient_init (GClueIpclient *ipclient)
10 {
11 ipclient->priv = G_TYPE_INSTANCE_GET_PRIVATE ((ipclient), GCLUE_TYPE_IPCLIENT, GClueIpclientPrivate);
12
13- ipclient->priv->soup_session = soup_session_new ();
14+ ipclient->priv->soup_session = soup_session_sync_new ();
15 }
16
17 /**
18diff --git a/src/geoip-server/geoip-update.c b/src/geoip-server/geoip-update.c
19index 6cce7b2..ef672ba 100644
20--- a/src/geoip-server/geoip-update.c
21+++ b/src/geoip-server/geoip-update.c
22@@ -214,7 +214,7 @@ main (int argc, char **argv)
23 path = GEOIP_DATABASE_PATH;
24 }
25
26- session = soup_session_new ();
27+ session = soup_session_sync_new ();
28
29 for (i = 0; i < G_N_ELEMENTS (db_info_map); i++) {
30 SoupMessage *msg = NULL;
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb b/meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb
new file mode 100644
index 000000000..a0305fb60
--- /dev/null
+++ b/meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb
@@ -0,0 +1,31 @@
1SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPLv2.0+"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=8114b83a0435d8136b47bd70111ce5cd"
10
11DEPENDS = "glib-2.0 dbus dbus-glib json-glib libsoup-2.4"
12
13inherit autotools pkgconfig gtk-doc
14
15SRC_URI = " \
16 http://www.freedesktop.org/software/geoclue/releases/2.0/geoclue-${PV}.tar.xz \
17 file://soup-session-fix.patch \
18"
19
20SRC_URI[md5sum] = "401ff99d530b177c62afacef0a33efd9"
21SRC_URI[sha256sum] = "4a82f184e55a163d86e0ad69bbe1bba9960bb5094220fe1f01350bceda8c67a1"
22
23EXTRA_OECONF += " \
24 --with-dbus-service-user=root \
25 --with-dbus-sys-dir=${sysconfdir}/dbus-1/system.d \
26"
27
28FILES_${PN} += " \
29 ${datadir}/dbus-1/system-services/org.freedesktop.GeoClue2.service \
30 ${datadir}/geoclue-2.0/geoclue-interface.xml \
31"