diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-02-28 14:37:53 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-02-28 15:49:59 +0100 |
commit | f1ffd1299273a92151a4fc766ab2ca3391f59cb0 (patch) | |
tree | 7e67248c6303d04085fd3e09ef67aef5ef35fc61 /meta-oe/recipes-multimedia | |
parent | dd44dc50adaaafd269fab18b09fa6d8b8f7a1759 (diff) | |
download | meta-openembedded-f1ffd1299273a92151a4fc766ab2ca3391f59cb0.tar.gz |
xbmc: add missing python runtime dependencies
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r-- | meta-oe/recipes-multimedia/xbmc/xbmc_git.bb | 8 |
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb b/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb index 7fcf53b3f4..0d3079baf5 100644 --- a/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb +++ b/meta-oe/recipes-multimedia/xbmc/xbmc_git.bb | |||
@@ -9,7 +9,7 @@ DEPENDS = "libusb1 libcec libplist expat yajl gperf-native libxmu fribidi mpeg2d | |||
9 | SRCREV = "1fef727af39c0c6e5264ee14fe4c78f8567f035e" | 9 | SRCREV = "1fef727af39c0c6e5264ee14fe4c78f8567f035e" |
10 | 10 | ||
11 | PV = "11.0" | 11 | PV = "11.0" |
12 | PR = "r7" | 12 | PR = "r8" |
13 | PR_append = "+gitr${SRCPV}" | 13 | PR_append = "+gitr${SRCPV}" |
14 | SRC_URI = "git://github.com/xbmc/xbmc.git;branch=eden;protocol=git \ | 14 | SRC_URI = "git://github.com/xbmc/xbmc.git;branch=eden;protocol=git \ |
15 | file://0001-configure-don-t-run-python-distutils-to-find-STAGING.patch \ | 15 | file://0001-configure-don-t-run-python-distutils-to-find-STAGING.patch \ |
@@ -64,7 +64,11 @@ FILES_${PN} += "${datadir}/xsessions ${datadir}/icons" | |||
64 | FILES_${PN}-dbg += "${libdir}/xbmc/.debug ${libdir}/xbmc/*/.debug ${libdir}/xbmc/*/*/.debug ${libdir}/xbmc/*/*/*/.debug" | 64 | FILES_${PN}-dbg += "${libdir}/xbmc/.debug ${libdir}/xbmc/*/.debug ${libdir}/xbmc/*/*/.debug ${libdir}/xbmc/*/*/*/.debug" |
65 | 65 | ||
66 | # xbmc uses some kind of dlopen() method for libcec so we need to add it manually | 66 | # xbmc uses some kind of dlopen() method for libcec so we need to add it manually |
67 | RRECOMMENDS_${PN}_append = " libcec" | 67 | RRECOMMENDS_${PN}_append = " libcec \ |
68 | python \ | ||
69 | python-lang \ | ||
70 | python-re \ | ||
71 | " | ||
68 | RRECOMMENDS_${PN}_append_libc-glibc = " glibc-charmap-ibm850 glibc-gconv-ibm850" | 72 | RRECOMMENDS_${PN}_append_libc-glibc = " glibc-charmap-ibm850 glibc-gconv-ibm850" |
69 | 73 | ||
70 | 74 | ||