summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-20 22:21:01 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-20 22:21:01 -0700
commit604b30eddee0a516420c65b2d53e377f9885ca73 (patch)
treeb32d7347caeda326a2a263131d78fa0ffb58ff8c /meta-oe/recipes-multimedia
parent0b5b6ad82ec7b28f2b425caa4ec9c8c88d6b189e (diff)
downloadmeta-openembedded-604b30eddee0a516420c65b2d53e377f9885ca73.tar.gz
alsa-oss: Upgrade to 1.1.6
License-Update: FSF Address updated in COPYING file Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r--meta-oe/recipes-multimedia/alsa/alsa-oss_1.0.28.bb20
-rw-r--r--meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.6.bb43
2 files changed, 43 insertions, 20 deletions
diff --git a/meta-oe/recipes-multimedia/alsa/alsa-oss_1.0.28.bb b/meta-oe/recipes-multimedia/alsa/alsa-oss_1.0.28.bb
deleted file mode 100644
index 0c4a9f545..000000000
--- a/meta-oe/recipes-multimedia/alsa/alsa-oss_1.0.28.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1SUMMARY = "Alsa OSS Compatibility Package"
2SECTION = "libs/multimedia"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
5DEPENDS = "alsa-lib"
6
7SRC_URI = "ftp://ftp.alsa-project.org/pub/oss-lib/alsa-oss-${PV}.tar.bz2 \
8 file://libio.patch \
9"
10SRC_URI[md5sum] = "91f57e8cee1ad4cc956caa8b62ac5d43"
11SRC_URI[sha256sum] = "3ae62caa88a0bc7b30ed836dcb794dc6ef4d3650439e2260db54cace7d5c6ad5"
12
13inherit autotools
14
15LEAD_SONAME = "libaoss.so.0"
16
17do_configure_prepend () {
18 touch NEWS README AUTHORS ChangeLog
19 sed -i "s/libaoss.so/${LEAD_SONAME}/" ${S}/alsa/aoss.in
20}
diff --git a/meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.6.bb b/meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.6.bb
new file mode 100644
index 000000000..efc56fe8c
--- /dev/null
+++ b/meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.6.bb
@@ -0,0 +1,43 @@
1# FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'.
2# The following is the difference between the old and the new license text.
3# Please update the LICENSE value if needed, and summarize the changes in
4# the commit message via 'License-Update:' tag.
5# (example: 'License-Update: copyright years updated.')
6#
7# The changes:
8#
9# --- COPYING
10# +++ COPYING
11# @@ -2,7 +2,8 @@
12# Version 2, June 1991
13#
14# Copyright (C) 1989, 1991 Free Software Foundation, Inc.
15# - 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
16# + 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
17# +
18# Everyone is permitted to copy and distribute verbatim copies
19# of this license document, but changing it is not allowed.
20#
21#
22#
23
24SUMMARY = "Alsa OSS Compatibility Package"
25SECTION = "libs/multimedia"
26LICENSE = "GPLv2"
27LIC_FILES_CHKSUM = "file://COPYING;md5=ed055b4eff93da784176a01582e6ec1a"
28DEPENDS = "alsa-lib"
29
30SRC_URI = "ftp://ftp.alsa-project.org/pub/oss-lib/alsa-oss-${PV}.tar.bz2 \
31 file://libio.patch \
32"
33SRC_URI[md5sum] = "fc845cafc4444193510ab1865c7350b8"
34SRC_URI[sha256sum] = "c3d3f743e61f05ff95c5cba3b06bc9c91ff86c37495f1d19dab844e6b90845ea"
35
36inherit autotools
37
38LEAD_SONAME = "libaoss.so.0"
39
40do_configure_prepend () {
41 touch NEWS README AUTHORS ChangeLog
42 sed -i "s/libaoss.so/${LEAD_SONAME}/" ${S}/alsa/aoss.in
43}