summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-12-16 14:23:36 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:24:07 +0100
commit58fbe56044cdd7e48c5cd5c31a85dfce06de8464 (patch)
treea26bc1612588867a7f8b8ca979e16413d845a39b /meta-oe/recipes-multimedia
parente0d4e8f46ebd8d0885e7328b87cbb5c9fb8540b5 (diff)
downloadmeta-openembedded-58fbe56044cdd7e48c5cd5c31a85dfce06de8464.tar.gz
audiofile: update to 0.3.6
License checksum changed by altering address of FSF Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r--meta-oe/recipes-multimedia/audiofile/audiofile_0.2.7.bb15
-rw-r--r--meta-oe/recipes-multimedia/audiofile/audiofile_0.3.6.bb22
-rw-r--r--meta-oe/recipes-multimedia/audiofile/files/0001-fix-negative-shift-constants.patch77
-rw-r--r--meta-oe/recipes-multimedia/audiofile/files/0002-fix-build-on-gcc6.patch75
-rw-r--r--meta-oe/recipes-multimedia/audiofile/files/0003-fix-CVE-2015-7747.patch35
5 files changed, 209 insertions, 15 deletions
diff --git a/meta-oe/recipes-multimedia/audiofile/audiofile_0.2.7.bb b/meta-oe/recipes-multimedia/audiofile/audiofile_0.2.7.bb
deleted file mode 100644
index 61886599a..000000000
--- a/meta-oe/recipes-multimedia/audiofile/audiofile_0.2.7.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1DESCRIPTION = "The Audio File Library provides a uniform and elegant \
2API for accessing a variety of audio file formats, such as AIFF/AIFF-C, \
3WAVE, NeXT/Sun .snd/.au, Berkeley/IRCAM/CARL Sound File, Audio Visual \
4Research, Amiga IFF/8SVX, and NIST SPHERE."
5HOMEPAGE = "http://www.68k.org/~michael/audiofile/"
6SECTION = "libs"
7LICENSE = "LGPLv2 & GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
9 file://COPYING.GPL;md5=0636e73ff0215e8d672dc4c32c317bb3"
10
11SRC_URI = "${GNOME_MIRROR}/audiofile/0.2/${BP}.tar.gz"
12SRC_URI[md5sum] = "a39be317a7b1971b408805dc5e371862"
13SRC_URI[sha256sum] = "a61c4036c2600a645843f16bec4be166093a9df5f15b02c85291213aa9cf15a2"
14
15inherit autotools lib_package binconfig
diff --git a/meta-oe/recipes-multimedia/audiofile/audiofile_0.3.6.bb b/meta-oe/recipes-multimedia/audiofile/audiofile_0.3.6.bb
new file mode 100644
index 000000000..2d67b5a48
--- /dev/null
+++ b/meta-oe/recipes-multimedia/audiofile/audiofile_0.3.6.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "The Audio File Library provides a uniform and elegant \
2API for accessing a variety of audio file formats, such as AIFF/AIFF-C, \
3WAVE, NeXT/Sun .snd/.au, Berkeley/IRCAM/CARL Sound File, Audio Visual \
4Research, Amiga IFF/8SVX, and NIST SPHERE."
5HOMEPAGE = "http://www.68k.org/~michael/audiofile/"
6SECTION = "libs"
7LICENSE = "LGPLv2 & GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
9 file://COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRC_URI = " \
12 ${GNOME_MIRROR}/audiofile/0.3/${BP}.tar.xz \
13 file://0001-fix-negative-shift-constants.patch \
14 file://0002-fix-build-on-gcc6.patch \
15 file://0003-fix-CVE-2015-7747.patch \
16"
17SRC_URI[md5sum] = "235dde14742317328f0109e9866a8008"
18SRC_URI[sha256sum] = "ea2449ad3f201ec590d811db9da6d02ffc5e87a677d06b92ab15363d8cb59782"
19
20inherit autotools lib_package binconfig
21
22DEPENDS = "asciidoc-native libogg flac"
diff --git a/meta-oe/recipes-multimedia/audiofile/files/0001-fix-negative-shift-constants.patch b/meta-oe/recipes-multimedia/audiofile/files/0001-fix-negative-shift-constants.patch
new file mode 100644
index 000000000..ecb310805
--- /dev/null
+++ b/meta-oe/recipes-multimedia/audiofile/files/0001-fix-negative-shift-constants.patch
@@ -0,0 +1,77 @@
1From 99127676dba8f5d607757428bc14a6b7ab52d5ed Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Fri, 16 Dec 2016 12:42:06 +0100
4Subject: [PATCH 1/3] fix negative shift constants
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Stolen from [1]
10
11[1] http://pkgs.fedoraproject.org/cgit/rpms/audiofile.git/tree/audiofile-0.3.6-left-shift-neg.patch
12
13Upstrem-Status: Pending
14
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16---
17 libaudiofile/modules/SimpleModule.h | 2 +-
18 test/FloatToInt.cpp | 2 +-
19 test/IntToFloat.cpp | 2 +-
20 test/Sign.cpp | 2 +-
21 4 files changed, 4 insertions(+), 4 deletions(-)
22
23diff --git a/libaudiofile/modules/SimpleModule.h b/libaudiofile/modules/SimpleModule.h
24index 03c6c69..e4cc138 100644
25--- a/libaudiofile/modules/SimpleModule.h
26+++ b/libaudiofile/modules/SimpleModule.h
27@@ -123,7 +123,7 @@ struct signConverter
28 typedef typename IntTypes<Format>::UnsignedType UnsignedType;
29
30 static const int kScaleBits = (Format + 1) * CHAR_BIT - 1;
31- static const int kMinSignedValue = -1 << kScaleBits;
32+ static const int kMinSignedValue = 0-(1U<<kScaleBits);
33
34 struct signedToUnsigned : public std::unary_function<SignedType, UnsignedType>
35 {
36diff --git a/test/FloatToInt.cpp b/test/FloatToInt.cpp
37index 0d179a8..bf491b2 100644
38--- a/test/FloatToInt.cpp
39+++ b/test/FloatToInt.cpp
40@@ -115,7 +115,7 @@ TEST_F(FloatToIntTest, Int16)
41 EXPECT_EQ(readData[i], expectedData[i]);
42 }
43
44-static const int32_t kMinInt24 = -1<<23;
45+static const int32_t kMinInt24 = 0-(1U<<23);
46 static const int32_t kMaxInt24 = (1<<23) - 1;
47
48 TEST_F(FloatToIntTest, Int24)
49diff --git a/test/IntToFloat.cpp b/test/IntToFloat.cpp
50index b716635..1d91b58 100644
51--- a/test/IntToFloat.cpp
52+++ b/test/IntToFloat.cpp
53@@ -117,7 +117,7 @@ TEST_F(IntToFloatTest, Int16)
54 EXPECT_EQ(readData[i], expectedData[i]);
55 }
56
57-static const int32_t kMinInt24 = -1<<23;
58+static const int32_t kMinInt24 = 0-(1U<<23);
59 static const int32_t kMaxInt24 = (1<<23) - 1;
60
61 TEST_F(IntToFloatTest, Int24)
62diff --git a/test/Sign.cpp b/test/Sign.cpp
63index 7275399..c339514 100644
64--- a/test/Sign.cpp
65+++ b/test/Sign.cpp
66@@ -116,7 +116,7 @@ TEST_F(SignConversionTest, Int16)
67 EXPECT_EQ(readData[i], expectedData[i]);
68 }
69
70-static const int32_t kMinInt24 = -1<<23;
71+static const int32_t kMinInt24 = 0-(1U<<23);
72 static const int32_t kMaxInt24 = (1<<23) - 1;
73 static const uint32_t kMaxUInt24 = (1<<24) - 1;
74
75--
762.7.4
77
diff --git a/meta-oe/recipes-multimedia/audiofile/files/0002-fix-build-on-gcc6.patch b/meta-oe/recipes-multimedia/audiofile/files/0002-fix-build-on-gcc6.patch
new file mode 100644
index 000000000..2c66cf4d0
--- /dev/null
+++ b/meta-oe/recipes-multimedia/audiofile/files/0002-fix-build-on-gcc6.patch
@@ -0,0 +1,75 @@
1From a74c1e9c583375b9e55c29a36442485089e4b7f9 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Fri, 16 Dec 2016 12:42:06 +0100
4Subject: [PATCH 2/3] fix build on gcc6
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Stolen from [1]
10
11[1] http://pkgs.fedoraproject.org/cgit/rpms/audiofile.git/tree/audiofile-0.3.6-narrowing.patch
12
13Upstrem-Status: Pending
14
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16---
17 test/NeXT.cpp | 14 +++++++-------
18 1 file changed, 7 insertions(+), 7 deletions(-)
19
20diff --git a/test/NeXT.cpp b/test/NeXT.cpp
21index 7e39850..a37cea1 100644
22--- a/test/NeXT.cpp
23+++ b/test/NeXT.cpp
24@@ -37,13 +37,13 @@
25
26 #include "TestUtilities.h"
27
28-const char kDataUnspecifiedLength[] =
29+const signed char kDataUnspecifiedLength[] =
30 {
31 '.', 's', 'n', 'd',
32 0, 0, 0, 24, // offset of 24 bytes
33- 0xff, 0xff, 0xff, 0xff, // unspecified length
34+ -1, -1, -1, -1, // unspecified length
35 0, 0, 0, 3, // 16-bit linear
36- 0, 0, 172, 68, // 44100 Hz
37+ 0, 0, -84, 68, // 44100 Hz (0xAC44)
38 0, 0, 0, 1, // 1 channel
39 0, 1,
40 0, 1,
41@@ -57,13 +57,13 @@ const char kDataUnspecifiedLength[] =
42 0, 55
43 };
44
45-const char kDataTruncated[] =
46+const signed char kDataTruncated[] =
47 {
48 '.', 's', 'n', 'd',
49 0, 0, 0, 24, // offset of 24 bytes
50 0, 0, 0, 20, // length of 20 bytes
51 0, 0, 0, 3, // 16-bit linear
52- 0, 0, 172, 68, // 44100 Hz
53+ 0, 0, -84, 68, // 44100 Hz (0xAC44)
54 0, 0, 0, 1, // 1 channel
55 0, 1,
56 0, 1,
57@@ -152,13 +152,13 @@ TEST(NeXT, Truncated)
58 ASSERT_EQ(::unlink(testFileName.c_str()), 0);
59 }
60
61-const char kDataZeroChannels[] =
62+const signed char kDataZeroChannels[] =
63 {
64 '.', 's', 'n', 'd',
65 0, 0, 0, 24, // offset of 24 bytes
66 0, 0, 0, 2, // 2 bytes
67 0, 0, 0, 3, // 16-bit linear
68- 0, 0, 172, 68, // 44100 Hz
69+ 0, 0, -84, 68, // 44100 Hz (0xAC44)
70 0, 0, 0, 0, // 0 channels
71 0, 1
72 };
73--
742.7.4
75
diff --git a/meta-oe/recipes-multimedia/audiofile/files/0003-fix-CVE-2015-7747.patch b/meta-oe/recipes-multimedia/audiofile/files/0003-fix-CVE-2015-7747.patch
new file mode 100644
index 000000000..895e320ba
--- /dev/null
+++ b/meta-oe/recipes-multimedia/audiofile/files/0003-fix-CVE-2015-7747.patch
@@ -0,0 +1,35 @@
1From 746c38105ce4fa1b609995d3386ea6b8b1f2f7bd Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Fri, 16 Dec 2016 12:50:51 +0100
4Subject: [PATCH 3/3] fix CVE-2015-7747
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Stolen from [1]
10
11[1] http://pkgs.fedoraproject.org/cgit/rpms/audiofile.git/tree/audiofile-0.3.6-CVE-2015-7747.patch
12
13Upstream-Status: Pending
14
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16---
17 libaudiofile/modules/ModuleState.cpp | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/libaudiofile/modules/ModuleState.cpp b/libaudiofile/modules/ModuleState.cpp
21index f76c495..0c29d7a 100644
22--- a/libaudiofile/modules/ModuleState.cpp
23+++ b/libaudiofile/modules/ModuleState.cpp
24@@ -402,7 +402,7 @@ status ModuleState::arrange(AFfilehandle file, Track *track)
25 addModule(new Transform(outfc, in.pcm, out.pcm));
26
27 if (in.channelCount != out.channelCount)
28- addModule(new ApplyChannelMatrix(infc, isReading,
29+ addModule(new ApplyChannelMatrix(outfc, isReading,
30 in.channelCount, out.channelCount,
31 in.pcm.minClip, in.pcm.maxClip,
32 track->channelMatrix));
33--
342.7.4
35