summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-22 10:57:56 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-02 12:34:40 +0000
commit107071acc6a0694db61a64b5b8c926790fa14bcf (patch)
tree8a7ca90113fc46d395186a3358b07f4b8c332fa7 /meta-oe/recipes-multimedia
parent3c70b718e04b39e8ae548b712c02d0fe7f9e740e (diff)
downloadmeta-openembedded-107071acc6a0694db61a64b5b8c926790fa14bcf.tar.gz
rcmd: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r--meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb2
-rw-r--r--meta-oe/recipes-multimedia/cdrkit/files/0001-define-__THROW-to-avoid-build-issue-with-musl.patch47
-rw-r--r--meta-oe/recipes-multimedia/cdrkit/files/0002-Do-not-use-rcmd-on-build-with-musl.patch31
3 files changed, 80 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb b/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
index f0efc51e1..c0f220fa6 100644
--- a/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
+++ b/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
@@ -8,6 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b30d3b2750b668133fc17b401e1b98f8"
8SRC_URI = "${DEBIAN_MIRROR}/main/c/${BPN}/${BPN}_${PV}.orig.tar.gz \ 8SRC_URI = "${DEBIAN_MIRROR}/main/c/${BPN}/${BPN}_${PV}.orig.tar.gz \
9 file://0001-do-not-create-a-run-test-to-determine-order-of-bitfi.patch \ 9 file://0001-do-not-create-a-run-test-to-determine-order-of-bitfi.patch \
10 file://0001-genisoimage-Fix-fprintf-format-errors.patch \ 10 file://0001-genisoimage-Fix-fprintf-format-errors.patch \
11 file://0001-define-__THROW-to-avoid-build-issue-with-musl.patch \
12 file://0002-Do-not-use-rcmd-on-build-with-musl.patch \
11 " 13 "
12SRC_URI[md5sum] = "efe08e2f3ca478486037b053acd512e9" 14SRC_URI[md5sum] = "efe08e2f3ca478486037b053acd512e9"
13SRC_URI[sha256sum] = "d1c030756ecc182defee9fe885638c1785d35a2c2a297b4604c0e0dcc78e47da" 15SRC_URI[sha256sum] = "d1c030756ecc182defee9fe885638c1785d35a2c2a297b4604c0e0dcc78e47da"
diff --git a/meta-oe/recipes-multimedia/cdrkit/files/0001-define-__THROW-to-avoid-build-issue-with-musl.patch b/meta-oe/recipes-multimedia/cdrkit/files/0001-define-__THROW-to-avoid-build-issue-with-musl.patch
new file mode 100644
index 000000000..b3beb069e
--- /dev/null
+++ b/meta-oe/recipes-multimedia/cdrkit/files/0001-define-__THROW-to-avoid-build-issue-with-musl.patch
@@ -0,0 +1,47 @@
1From 7c3036609494296f7c29413bf3acba829c81f62c Mon Sep 17 00:00:00 2001
2From: Romain Naour <romain.naour@openwide.fr>
3Date: Sat, 8 Aug 2015 22:58:57 +0200
4Subject: [PATCH 1/2] define __THROW to avoid build issue with musl
5
6Fixes:
7http://autobuild.buildroot.net/results/d27/d2781e70b04a207e2e9397d888032294c7285034/build-end.log
8
9Signed-off-by: Romain Naour <romain.naour@openwide.fr>
10---
11 genisoimage/sha256.h | 4 ++++
12 genisoimage/sha512.h | 4 ++++
13 2 files changed, 8 insertions(+)
14
15diff --git a/genisoimage/sha256.h b/genisoimage/sha256.h
16index e7f4cb9..bcae7ef 100644
17--- a/genisoimage/sha256.h
18+++ b/genisoimage/sha256.h
19@@ -29,6 +29,10 @@
20 #include <stdint.h>
21 #include <stdio.h>
22
23+/* define __THROW to avoid build issue when it's not available from the libc */
24+#ifndef __THROW
25+# define __THROW
26+#endif
27
28 /* Structure to save state of computation between the single steps. */
29 struct sha256_ctx
30diff --git a/genisoimage/sha512.h b/genisoimage/sha512.h
31index 7298355..8cee8b0 100644
32--- a/genisoimage/sha512.h
33+++ b/genisoimage/sha512.h
34@@ -29,6 +29,10 @@
35 #include <stdint.h>
36 #include <stdio.h>
37
38+/* define __THROW to avoid build issue when it's not available from the libc */
39+#ifndef __THROW
40+# define __THROW
41+#endif
42
43 /* Structure to save state of computation between the single steps. */
44 struct sha512_ctx
45--
462.14.1
47
diff --git a/meta-oe/recipes-multimedia/cdrkit/files/0002-Do-not-use-rcmd-on-build-with-musl.patch b/meta-oe/recipes-multimedia/cdrkit/files/0002-Do-not-use-rcmd-on-build-with-musl.patch
new file mode 100644
index 000000000..547a21c67
--- /dev/null
+++ b/meta-oe/recipes-multimedia/cdrkit/files/0002-Do-not-use-rcmd-on-build-with-musl.patch
@@ -0,0 +1,31 @@
1From 510838b2c96a9b097b3ee2694cba1c3623b0bac7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 21 Sep 2017 22:38:05 -0700
4Subject: [PATCH 2/2] Do not use rcmd on build with musl
5
6cdrkit unconditionally enables code using rcmd(3), which isn't available
7on musl.
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 include/xconfig.h.in | 3 ++-
12 1 file changed, 2 insertions(+), 1 deletion(-)
13
14diff --git a/include/xconfig.h.in b/include/xconfig.h.in
15index 476c00b..6b4b298 100644
16--- a/include/xconfig.h.in
17+++ b/include/xconfig.h.in
18@@ -186,8 +186,9 @@
19 * Instead use the tests AC_SMALL_FSEEKO/AC_SMALL/STELLO and make sure
20 * they are placed before the large file tests.
21 */
22-
23+#ifdef __GLIBC__
24 #define HAVE_RCMD 1 /* rcmd() is present in libc/libsocket */
25+#endif
26 #define HAVE_SOCKET 1 /* socket() is present in libc/libsocket */
27 #define HAVE_SOCKETPAIR 1 /* socketpair() is present in libc/libsocket */
28 #define HAVE_GETSERVBYNAME 1 /* getservbyname() is present in libc/libsocket */
29--
302.14.1
31