summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
authorBenjamin Bara <benjamin.bara@skidata.com>2023-08-22 12:14:43 +0200
committerKhem Raj <raj.khem@gmail.com>2023-08-22 13:12:38 -0700
commit0324259cd6ff63e6d487491cffbe31552ea5a883 (patch)
tree1b8965939b667a18742922ad891d351f61dcd206 /meta-oe/recipes-multimedia
parentff32ec898f38eefdc2c5b4e2ccb5fb532e992c5b (diff)
downloadmeta-openembedded-0324259cd6ff63e6d487491cffbe31552ea5a883.tar.gz
libvpx: fix VPXTARGET for non-neon armv7a
The compiler might use non-supported instructions, as the build config requires armv7-linux-gcc targets to have NEON[1] and drops the mtune value[2], which also might use d32 registers on d16 cpus. Falling back to the generic-gnu target respects the toolchain-set values and should therefore be used instead. [1] https://chromium.googlesource.com/webm/libvpx/+/626ff35955c2c35b806b3e0ecf551a1a8611cdbf/build/make/configure.sh#955 [2] https://chromium.googlesource.com/webm/libvpx/+/626ff35955c2c35b806b3e0ecf551a1a8611cdbf/build/make/configure.sh#973 Signed-off-by: Benjamin Bara <benjamin.bara@skidata.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx_1.13.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-multimedia/webm/libvpx_1.13.0.bb b/meta-oe/recipes-multimedia/webm/libvpx_1.13.0.bb
index 79b330c31..558b448ba 100644
--- a/meta-oe/recipes-multimedia/webm/libvpx_1.13.0.bb
+++ b/meta-oe/recipes-multimedia/webm/libvpx_1.13.0.bb
@@ -26,7 +26,7 @@ export LD = "${CC}"
26 26
27VPXTARGET:armv5te = "armv5te-linux-gcc" 27VPXTARGET:armv5te = "armv5te-linux-gcc"
28VPXTARGET:armv6 = "armv6-linux-gcc" 28VPXTARGET:armv6 = "armv6-linux-gcc"
29VPXTARGET:armv7a = "armv7-linux-gcc" 29VPXTARGET:armv7a = "${@bb.utils.contains("TUNE_FEATURES","neon","armv7-linux-gcc","generic-gnu",d)}"
30VPXTARGET ?= "generic-gnu" 30VPXTARGET ?= "generic-gnu"
31 31
32CONFIGUREOPTS = " \ 32CONFIGUREOPTS = " \