summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/v4l2apps
diff options
context:
space:
mode:
authorNeel Gandhi <neel.gandhi@amd.com>2024-06-21 16:53:45 +0530
committerKhem Raj <raj.khem@gmail.com>2024-06-27 09:18:48 -0700
commit5f453c3401e20eb5489fac4d3b54a5bf96d019ab (patch)
tree9b6abf5ea646ffdfa64c71aff727b871c509ca2f /meta-oe/recipes-multimedia/v4l2apps
parent6b077bce55732466f6ab4572655028ac02cd0f5e (diff)
downloadmeta-openembedded-5f453c3401e20eb5489fac4d3b54a5bf96d019ab.tar.gz
v4l-utils: Install media ctrl header and library files
Commit 9389d63fdddcab400cb0b243b74d47bf665aba18 removed a previous patch that caused the recipe to install the header and library files. Restore this behavior to the new meson based build system. Signed-off-by: Neel Gandhi <neel.gandhi@amd.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com> Signed-off-by: Mark Hatle <mark.hatle@kernel.crashing.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/v4l2apps')
-rw-r--r--meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-media-ctl-Install-media-ctl-header-and-library-files.patch78
-rw-r--r--meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.26.1.bb1
2 files changed, 79 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-media-ctl-Install-media-ctl-header-and-library-files.patch b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-media-ctl-Install-media-ctl-header-and-library-files.patch
new file mode 100644
index 000000000..6c946d8c4
--- /dev/null
+++ b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils/0001-media-ctl-Install-media-ctl-header-and-library-files.patch
@@ -0,0 +1,78 @@
1From 3867fcfa4389c7fa271705f1fd1d4bfb74bc1bd1 Mon Sep 17 00:00:00 2001
2From: Neel Gandhi <neel.gandhi@amd.com>
3Date: Wed, 5 Jun 2024 13:51:36 +0530
4Subject: [PATCH] media-ctl: Install media-ctl header and library files
5
6Install mediactl and v4l2subdev header and library
7files, which may be required by 3rd party applications
8to populate and control v4l2subdev device node tree
9
10Install of these files was removed in upstream commit
110911dce53b08b0df3066be2c75f67e8a314d8729.
12
13Upstream-Status: Denied
14
15v4l-utils maintainers do not promise a stable API for this library, and
16do not currently have the time to do so. So exporting the API in this
17way is fine, as long as we understand that it will change and users of
18the API will need to adapt over time.
19
20Signed-off-by: Neel Gandhi <neel.gandhi@amd.com>
21Signed-off-by: Mark Hatle <mark.hatle@amd.com>
22---
23 utils/media-ctl/meson.build | 28 +++++++++++++++++++++-------
24 1 file changed, 21 insertions(+), 7 deletions(-)
25
26diff --git a/utils/media-ctl/meson.build b/utils/media-ctl/meson.build
27index 3a7b0c9a..40669b4c 100644
28--- a/utils/media-ctl/meson.build
29+++ b/utils/media-ctl/meson.build
30@@ -3,14 +3,24 @@ libmediactl_sources = files(
31 'mediactl-priv.h',
32 )
33
34+libmediactl_api = files(
35+ 'mediactl.h',
36+ 'v4l2subdev.h',
37+)
38+
39+install_headers(libmediactl_api, subdir: 'mediactl')
40+
41 libmediactl_deps = [
42 dep_libudev,
43 ]
44
45-libmediactl = static_library('mediactl',
46- libmediactl_sources,
47- dependencies : libmediactl_deps,
48- include_directories : v4l2_utils_incdir)
49+libmediactl = library('mediactl',
50+ libmediactl_sources,
51+ soversion: '0',
52+ version: '0.0.0',
53+ install : true,
54+ dependencies : libmediactl_deps,
55+ include_directories : v4l2_utils_incdir)
56
57 dep_libmediactl = declare_dependency(link_with : libmediactl)
58
59@@ -18,9 +28,13 @@ libv4l2subdev_sources = files('libv4l2subdev.c')
60 libv4l2subdev_sources += media_bus_format_names_h
61 libv4l2subdev_sources += media_bus_format_codes_h
62
63-libv4l2subdev = static_library('v4l2subdev',
64- libv4l2subdev_sources,
65- include_directories : v4l2_utils_incdir)
66+libv4l2subdev = library('v4l2subdev',
67+ libv4l2subdev_sources,
68+ soversion: '0',
69+ version: '0.0.0',
70+ install : true,
71+ dependencies : dep_libmediactl,
72+ include_directories : v4l2_utils_incdir)
73
74 dep_libv4l2subdev = declare_dependency(link_with : libv4l2subdev)
75
76--
772.34.1
78
diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.26.1.bb b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.26.1.bb
index 52759ef18..eb38d9713 100644
--- a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.26.1.bb
+++ b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.26.1.bb
@@ -28,6 +28,7 @@ PACKAGECONFIG[v4l2-tracer] = ",-Dv4l2-tracer=disabled,json-c"
28SRC_URI = "\ 28SRC_URI = "\
29 git://git.linuxtv.org/v4l-utils.git;protocol=https;branch=stable-1.26 \ 29 git://git.linuxtv.org/v4l-utils.git;protocol=https;branch=stable-1.26 \
30 file://0001-keytable-meson-Restrict-the-installation-of-50-rc_ke.patch \ 30 file://0001-keytable-meson-Restrict-the-installation-of-50-rc_ke.patch \
31 file://0001-media-ctl-Install-media-ctl-header-and-library-files.patch \
31" 32"
32 33
33SRCREV = "4aee01a027923cab1e40969f56f8ba58d3e6c0d1" 34SRCREV = "4aee01a027923cab1e40969f56f8ba58d3e6c0d1"