diff options
author | Markus Volk <f_l_k@t-online.de> | 2022-05-29 14:43:31 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-05-29 06:39:14 -0700 |
commit | 753b2161164ef0d508c5f7c3d3cdb985cd38a269 (patch) | |
tree | 5541e64947784bb8d40900c118074567313da6f8 /meta-oe/recipes-multimedia/pulseaudio | |
parent | 59ae457c38eeb830f617d1ce55f3879f37c07bc5 (diff) | |
download | meta-openembedded-753b2161164ef0d508c5f7c3d3cdb985cd38a269.tar.gz |
pavucontrol: update; fix build for wayland only
- Update to v5.0
- Add a patch for wayland builds that removes canberra dependency. Since the
canberra-gtk+3 module paradoxically depends on gtk+2 it is unbuildable for
wayland.
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/pulseaudio')
-rw-r--r-- | meta-oe/recipes-multimedia/pulseaudio/pavucontrol/0001-pavucontrol-remove-canberra-gtk-support.patch | 112 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/pulseaudio/pavucontrol_5.0.bb (renamed from meta-oe/recipes-multimedia/pulseaudio/pavucontrol_4.0.bb) | 15 |
2 files changed, 121 insertions, 6 deletions
diff --git a/meta-oe/recipes-multimedia/pulseaudio/pavucontrol/0001-pavucontrol-remove-canberra-gtk-support.patch b/meta-oe/recipes-multimedia/pulseaudio/pavucontrol/0001-pavucontrol-remove-canberra-gtk-support.patch new file mode 100644 index 0000000000..44169240c5 --- /dev/null +++ b/meta-oe/recipes-multimedia/pulseaudio/pavucontrol/0001-pavucontrol-remove-canberra-gtk-support.patch | |||
@@ -0,0 +1,112 @@ | |||
1 | From 87992a57e5f517d5ceb5dfabaea662ac64983720 Mon Sep 17 00:00:00 2001 | ||
2 | From: Markus Volk <f_l_k@t-online.de> | ||
3 | Date: Fri, 27 May 2022 18:37:53 +0200 | ||
4 | Subject: [PATCH] pavucontrol: remove canberra-gtk support | ||
5 | |||
6 | libcanberra-gtk3 module isn't buildable for wayland. | ||
7 | Remove its dpendency. | ||
8 | |||
9 | Signed-off-by: Markus Volk <f_l_k@t-online.de> | ||
10 | |||
11 | Upstream-Status: Inappropriate | ||
12 | --- | ||
13 | configure.ac | 2 +- | ||
14 | src/pavuapplication.cc | 2 -- | ||
15 | src/pavucontrol.cc | 4 ---- | ||
16 | src/sinkwidget.cc | 17 ----------------- | ||
17 | 4 files changed, 1 insertion(+), 24 deletions(-) | ||
18 | |||
19 | diff --git a/configure.ac b/configure.ac | ||
20 | index 056ba5e..e857563 100644 | ||
21 | --- a/configure.ac | ||
22 | +++ b/configure.ac | ||
23 | @@ -41,7 +41,7 @@ AC_TYPE_SIGNAL | ||
24 | AC_HEADER_STDC | ||
25 | AX_CXX_COMPILE_STDCXX_11 | ||
26 | |||
27 | -PKG_CHECK_MODULES(GUILIBS, [ gtkmm-3.0 >= 3.22 sigc++-2.0 libcanberra-gtk3 >= 0.16 json-glib-1.0 ]) | ||
28 | +PKG_CHECK_MODULES(GUILIBS, [ gtkmm-3.0 >= 3.22 sigc++-2.0 json-glib-1.0 ]) | ||
29 | AC_SUBST(GUILIBS_CFLAGS) | ||
30 | AC_SUBST(GUILIBS_LIBS) | ||
31 | |||
32 | diff --git a/src/pavuapplication.cc b/src/pavuapplication.cc | ||
33 | index 6773b53..60c016c 100644 | ||
34 | --- a/src/pavuapplication.cc | ||
35 | +++ b/src/pavuapplication.cc | ||
36 | @@ -24,8 +24,6 @@ | ||
37 | |||
38 | #include "i18n.h" | ||
39 | |||
40 | -#include <canberra-gtk.h> | ||
41 | - | ||
42 | #include "pavuapplication.h" | ||
43 | #include "pavucontrol.h" | ||
44 | #include "mainwindow.h" | ||
45 | diff --git a/src/pavucontrol.cc b/src/pavucontrol.cc | ||
46 | index 18d5400..10ab646 100644 | ||
47 | --- a/src/pavucontrol.cc | ||
48 | +++ b/src/pavucontrol.cc | ||
49 | @@ -29,8 +29,6 @@ | ||
50 | #include <json-glib/json-glib.h> | ||
51 | #endif | ||
52 | |||
53 | -#include <canberra-gtk.h> | ||
54 | - | ||
55 | #include "pavucontrol.h" | ||
56 | #include "i18n.h" | ||
57 | #include "minimalstreamwidget.h" | ||
58 | @@ -916,8 +914,6 @@ MainWindow* pavucontrol_get_window(pa_glib_mainloop *m, bool maximize, bool _ret | ||
59 | tab_number = _tab_number; | ||
60 | retry = _retry; | ||
61 | |||
62 | - ca_context_set_driver(ca_gtk_context_get(), "pulse"); | ||
63 | - | ||
64 | mainWindow = MainWindow::create(maximize); | ||
65 | |||
66 | api = pa_glib_mainloop_get_api(m); | ||
67 | diff --git a/src/sinkwidget.cc b/src/sinkwidget.cc | ||
68 | index f30bd37..482fd1f 100644 | ||
69 | --- a/src/sinkwidget.cc | ||
70 | +++ b/src/sinkwidget.cc | ||
71 | @@ -24,7 +24,6 @@ | ||
72 | |||
73 | #include "sinkwidget.h" | ||
74 | |||
75 | -#include <canberra-gtk.h> | ||
76 | #if HAVE_EXT_DEVICE_RESTORE_API | ||
77 | # include <pulse/format.h> | ||
78 | # include <pulse/ext-device-restore.h> | ||
79 | @@ -111,7 +110,6 @@ SinkWidget* SinkWidget::create(MainWindow* mainWindow) { | ||
80 | void SinkWidget::executeVolumeUpdate() { | ||
81 | pa_operation* o; | ||
82 | char dev[64]; | ||
83 | - int playing = 0; | ||
84 | |||
85 | if (!(o = pa_context_set_sink_volume_by_index(get_context(), index, &volume, NULL, NULL))) { | ||
86 | show_error(_("pa_context_set_sink_volume_by_index() failed")); | ||
87 | @@ -120,22 +118,7 @@ void SinkWidget::executeVolumeUpdate() { | ||
88 | |||
89 | pa_operation_unref(o); | ||
90 | |||
91 | - ca_context_playing(ca_gtk_context_get(), 2, &playing); | ||
92 | - if (playing) | ||
93 | - return; | ||
94 | - | ||
95 | snprintf(dev, sizeof(dev), "%lu", (unsigned long) index); | ||
96 | - ca_context_change_device(ca_gtk_context_get(), dev); | ||
97 | - | ||
98 | - ca_gtk_play_for_widget(GTK_WIDGET(gobj()), | ||
99 | - 2, | ||
100 | - CA_PROP_EVENT_DESCRIPTION, _("Volume Control Feedback Sound"), | ||
101 | - CA_PROP_EVENT_ID, "audio-volume-change", | ||
102 | - CA_PROP_CANBERRA_CACHE_CONTROL, "permanent", | ||
103 | - CA_PROP_CANBERRA_ENABLE, "1", | ||
104 | - NULL); | ||
105 | - | ||
106 | - ca_context_change_device(ca_gtk_context_get(), NULL); | ||
107 | } | ||
108 | |||
109 | void SinkWidget::onMuteToggleButton() { | ||
110 | -- | ||
111 | 2.25.1 | ||
112 | |||
diff --git a/meta-oe/recipes-multimedia/pulseaudio/pavucontrol_4.0.bb b/meta-oe/recipes-multimedia/pulseaudio/pavucontrol_5.0.bb index 5f9d7a6ba4..012fc3a94d 100644 --- a/meta-oe/recipes-multimedia/pulseaudio/pavucontrol_4.0.bb +++ b/meta-oe/recipes-multimedia/pulseaudio/pavucontrol_5.0.bb | |||
@@ -8,16 +8,19 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" | |||
8 | # AM_GLIB_GNU_GETTEXT macro in configure.ac. That macro is deprecated, so the | 8 | # AM_GLIB_GNU_GETTEXT macro in configure.ac. That macro is deprecated, so the |
9 | # glib-2.0-native dependency may go away at some point (something to keep in | 9 | # glib-2.0-native dependency may go away at some point (something to keep in |
10 | # mind when doing version upgrades). | 10 | # mind when doing version upgrades). |
11 | DEPENDS = "libxml-parser-perl-native intltool-native glib-2.0-native gtkmm3 libcanberra pulseaudio" | 11 | DEPENDS = "libxml-parser-perl-native intltool-native glib-2.0-native gtkmm3 pulseaudio json-glib" |
12 | 12 | ||
13 | inherit autotools features_check perlnative pkgconfig | 13 | inherit autotools features_check perlnative pkgconfig |
14 | 14 | ||
15 | REQUIRED_DISTRO_FEATURES = "x11" | 15 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
16 | 16 | ||
17 | SRC_URI = "http://freedesktop.org/software/pulseaudio/${BPN}/${BP}.tar.xz \ | 17 | SRC_URI = "http://freedesktop.org/software/pulseaudio/${BPN}/${BP}.tar.xz" |
18 | " | 18 | SRC_URI:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'file://0001-pavucontrol-remove-canberra-gtk-support.patch', '', d)}" |
19 | SRC_URI[md5sum] = "9dcc2c76292e7e5e075d51b8dcb20202" | 19 | |
20 | SRC_URI[sha256sum] = "8fc45bac9722aefa6f022999cbb76242d143c31b314e2dbb38f034f4069d14e2" | 20 | SRC_URI[sha256sum] = "ce2b72c3b5f1a70ad0df19dd81750f9455bd20870d1d3a36d20536af2e8f4e7a" |
21 | |||
22 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" | ||
23 | PACKAGECONFIG[x11] = ",,libcanberra" | ||
21 | 24 | ||
22 | EXTRA_OECONF = "--disable-lynx " | 25 | EXTRA_OECONF = "--disable-lynx " |
23 | 26 | ||