summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/libpostproc
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-multimedia/libpostproc
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/libpostproc')
-rw-r--r--meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb b/meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb
new file mode 100644
index 000000000..811175ce8
--- /dev/null
+++ b/meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb
@@ -0,0 +1,43 @@
1SUMMARY = "FFmpeg derived postprocessing library"
2HOMEPAGE = "http://git.videolan.org/?p=libpostproc.git;a=summary"
3SECTION = "libs"
4DEPENDS = "libav"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8PV = "52.3.0+git${SRCPV}"
9
10SRCREV = "811db3b957dfde24aef2d0f82e297e5bf552d873"
11SRC_URI = "git://github.com/lu-zero/postproc;protocol=https"
12
13S = "${WORKDIR}/git"
14
15inherit autotools lib_package pkgconfig
16
17FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fomit-frame-pointer -O4 -ffast-math"
18BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
19
20EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
21EXTRA_FFCONF ?= ""
22
23EXTRA_OECONF = " \
24 --enable-shared \
25 --enable-pthreads \
26 --enable-gpl \
27 --enable-postproc \
28 \
29 --cross-prefix=${TARGET_PREFIX} \
30 --prefix=${prefix} \
31 \
32 --arch=${TARGET_ARCH} \
33 --target-os="linux" \
34 --enable-cross-compile \
35 --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
36 --extra-ldflags="${TARGET_LDFLAGS}" \
37 --sysroot="${STAGING_DIR_TARGET}" \
38 ${EXTRA_FFCONF} \
39"
40
41do_configure() {
42 ${S}/configure ${EXTRA_OECONF}
43}