summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/jack
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-15 20:26:41 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-15 23:17:40 -0800
commit55553fde2d0d8f78a636850f19a8de5e97334ad5 (patch)
tree3047a36d65e25a89d68aaf4004ac6fce30565ee2 /meta-oe/recipes-multimedia/jack
parent42ec7b02e81f47adec8b8fda3f72daa21cc415f7 (diff)
downloadmeta-openembedded-55553fde2d0d8f78a636850f19a8de5e97334ad5.tar.gz
jack: Use c++ compiler for programs which use c++ source files
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/jack')
-rw-r--r--meta-oe/recipes-multimedia/jack/jack/0001-example-clients-Use-c-compiler-for-jack_simdtests.patch33
-rw-r--r--meta-oe/recipes-multimedia/jack/jack_1.19.14.bb4
2 files changed, 36 insertions, 1 deletions
diff --git a/meta-oe/recipes-multimedia/jack/jack/0001-example-clients-Use-c-compiler-for-jack_simdtests.patch b/meta-oe/recipes-multimedia/jack/jack/0001-example-clients-Use-c-compiler-for-jack_simdtests.patch
new file mode 100644
index 0000000000..dda21a32d8
--- /dev/null
+++ b/meta-oe/recipes-multimedia/jack/jack/0001-example-clients-Use-c-compiler-for-jack_simdtests.patch
@@ -0,0 +1,33 @@
1From 76b8a389268275cc13f3b4e61394d40b24ec56f1 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 15 Jan 2020 20:21:58 -0800
4Subject: [PATCH] example-clients: Use c++ compiler for jack_simdtests
5
6It uses c++ sources and runtime therefore its best to use c++ compiler
7to build it so it can find the correct runtime, cross compiling with
8clang fails
9
10x86_64-yoe-linux-ld: example-clients/simdtests.cpp.28.o: undefined reference to symbol '__cxa_call_unexpected@@CXXABI_1.3'
11
12Upstream-Status: Submitted [https://github.com/jackaudio/jack2/pull/536]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 example-clients/wscript | 2 ++
16 1 file changed, 2 insertions(+)
17
18diff --git a/example-clients/wscript b/example-clients/wscript
19index a8857aa7..df9435aa 100644
20--- a/example-clients/wscript
21+++ b/example-clients/wscript
22@@ -69,6 +69,8 @@ def build(bld):
23
24 if bld.env['IS_MACOSX']:
25 prog = bld(features='c cprogram', framework = ['Foundation'])
26+ elif example_program == 'jack_simdtests':
27+ prog = bld(features='cxx cxxprogram')
28 else:
29 prog = bld(features='c cprogram')
30 prog.includes = os_incdir + ['../common/jack', '../common']
31--
322.25.0
33
diff --git a/meta-oe/recipes-multimedia/jack/jack_1.19.14.bb b/meta-oe/recipes-multimedia/jack/jack_1.19.14.bb
index cebc952661..e954341ffe 100644
--- a/meta-oe/recipes-multimedia/jack/jack_1.19.14.bb
+++ b/meta-oe/recipes-multimedia/jack/jack_1.19.14.bb
@@ -14,7 +14,9 @@ LIC_FILES_CHKSUM = " \
14 14
15DEPENDS = "libsamplerate0 libsndfile1 readline" 15DEPENDS = "libsamplerate0 libsndfile1 readline"
16 16
17SRC_URI = "git://github.com/jackaudio/jack2.git" 17SRC_URI = "git://github.com/jackaudio/jack2.git \
18 file://0001-example-clients-Use-c-compiler-for-jack_simdtests.patch \
19 "
18SRCREV = "b54a09bf7ef760d81fdb8544ad10e45575394624" 20SRCREV = "b54a09bf7ef760d81fdb8544ad10e45575394624"
19 21
20S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"