summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/jack
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-multimedia/jack
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/jack')
-rw-r--r--meta-oe/recipes-multimedia/jack/jack/jack_fix_TWL4030_alsa_capture.patch31
-rw-r--r--meta-oe/recipes-multimedia/jack/jack/remove-wrong-host-test.patch68
-rw-r--r--meta-oe/recipes-multimedia/jack/jack_0.121.0.bb40
3 files changed, 139 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/jack/jack/jack_fix_TWL4030_alsa_capture.patch b/meta-oe/recipes-multimedia/jack/jack/jack_fix_TWL4030_alsa_capture.patch
new file mode 100644
index 000000000..77337ff6c
--- /dev/null
+++ b/meta-oe/recipes-multimedia/jack/jack/jack_fix_TWL4030_alsa_capture.patch
@@ -0,0 +1,31 @@
1--- a/drivers/alsa/alsa_driver.c 2009-05-06 06:36:08.000000000 +1000
2+++ b/drivers/alsa/alsa_driver.c 2010-07-28 21:02:57.238101024 +1000
3@@ -2388,7 +2388,7 @@
4 strcpy (params[i].name, "period");
5 params[i].character = 'p';
6 params[i].type = JackDriverParamUInt;
7- params[i].value.ui = 1024U;
8+ params[i].value.ui = 256U; /* TWL4030 capture. */
9 strcpy (params[i].short_desc, "Frames per period");
10 strcpy (params[i].long_desc, params[i].short_desc);
11
12@@ -2396,7 +2396,7 @@
13 strcpy (params[i].name, "nperiods");
14 params[i].character = 'n';
15 params[i].type = JackDriverParamUInt;
16- params[i].value.ui = 2U;
17+ params[i].value.ui = 4U; /* TWL4030 capture. */
18 strcpy (params[i].short_desc, "Number of periods of playback latency");
19 strcpy (params[i].long_desc, params[i].short_desc);
20
21@@ -2518,8 +2518,8 @@
22 driver_initialize (jack_client_t *client, const JSList * params)
23 {
24 jack_nframes_t srate = 48000;
25- jack_nframes_t frames_per_interrupt = 1024;
26- unsigned long user_nperiods = 2;
27+ jack_nframes_t frames_per_interrupt = 256; /* TWL4030 needs small number of frames here. */
28+ unsigned long user_nperiods = 4; /* TWL4030 needs 4 periods to avoid XRuns. */
29 char *playback_pcm_name = "hw:0";
30 char *capture_pcm_name = "hw:0";
31 int hw_monitoring = FALSE;
diff --git a/meta-oe/recipes-multimedia/jack/jack/remove-wrong-host-test.patch b/meta-oe/recipes-multimedia/jack/jack/remove-wrong-host-test.patch
new file mode 100644
index 000000000..b41c98f2a
--- /dev/null
+++ b/meta-oe/recipes-multimedia/jack/jack/remove-wrong-host-test.patch
@@ -0,0 +1,68 @@
1From be5f1439a1f36c0bc714411d20186045bd3e9539 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Tue, 12 Jul 2011 12:48:14 +0200
4Subject: [PATCH] remove bogus check for host-side jack installs, we are crosscompiling and don't care about these misguided checks
5
6---
7 configure.ac | 45 ---------------------------------------------
8 1 files changed, 0 insertions(+), 45 deletions(-)
9
10diff --git a/configure.ac b/configure.ac
11index 0a7e6bc..4033c21 100644
12--- a/configure.ac
13+++ b/configure.ac
14@@ -3,51 +3,6 @@ dnl $Id: configure.ac 4467 2011-06-23 15:10:03Z paul $
15
16 AC_INIT(jackd/jackd.c)
17
18-
19-dnl
20-dnl Check for existing JACK installs
21-dnl
22-
23-AC_MSG_CHECKING([existing, conflicting JACK installs])
24-not_overwriting=0
25-installs=
26-for dir in /usr/lib /usr/local/lib /opt/lib ; do
27- if test -d $dir ; then
28- if test $(find $dir/ -name 'libjack.so.*' 2>/dev/null | wc -l) -gt 0 ; then
29- if echo $prefix/lib | grep -vs $dir >/dev/null 2>&1 ; then
30- not_overwriting=$(expr $not_overwriting + 1)
31- fi
32- installs="$installs $dir"
33- fi
34- fi
35-done
36-
37-if test $not_overwriting -gt 0 ; then
38- echo
39- echo
40- echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
41- echo "You appear to have at least one existing installation of JACK."
42- echo
43- echo "Complete or partial JACK installs exist in:$installs"
44- echo
45- echo "Installing this version will leave at least one of these"
46- echo "existing installations installed and this will probably break"
47- echo "JACK on your machine. "
48- echo
49- echo "Before building, you should first remove the existing JACK"
50- echo "installation(s). "
51- echo
52- echo "Alternatively use ./configure --prefix=... to force overwriting"
53- echo "the existing install."
54- echo
55- echo "WARNING: ON ANY DEBIAN-DERIVED DISTRIBUTION (Debian, Ubuntu etc)"
56- echo "CHANGING THE INSTALLATION PREFIX WILL NOT PRODUCE A WORKING JACK"
57- echo "INSTALL. Please contact the distribution packager for JACK and"
58- echo "ask them to fix their packaging."
59- echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
60- exit 1
61-fi
62-
63 AC_CONFIG_AUX_DIR(config)
64 AC_CANONICAL_TARGET
65
66--
671.6.6.1
68
diff --git a/meta-oe/recipes-multimedia/jack/jack_0.121.0.bb b/meta-oe/recipes-multimedia/jack/jack_0.121.0.bb
new file mode 100644
index 000000000..7b3392721
--- /dev/null
+++ b/meta-oe/recipes-multimedia/jack/jack_0.121.0.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "JACK is a low-latency audio server. It can \
2connect a number of different applications to an audio \
3device, as well as allowing them to share audio between \
4themselves."
5SECTION = "libs/multimedia"
6
7LICENSE = "GPLv2 & LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c030468238b2cf89925a57f2780396a7 \
9 file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
10 file://COPYING.LGPL;md5=e77fe93202736b47c07035910f47974a \
11"
12
13DEPENDS = "alsa-lib libsamplerate0 readline"
14
15SRCREV = "91a688c602b7ce1711d8ad10fb07ebcf2e530a64"
16SRC_URI = "git://github.com/jackaudio/jack1.git \
17 file://remove-wrong-host-test.patch \
18 file://jack_fix_TWL4030_alsa_capture.patch \
19"
20
21S = "${WORKDIR}/git"
22
23inherit autotools pkgconfig
24
25EXTRA_OECONF = "--enable-timestamps \
26 --disable-capabilities \
27 --disable-oldtrans \
28 --disable-portaudio \
29 --disable-coreaudio \
30 --disable-oss \
31 --enable-alsa"
32
33EXTRA_OEMAKE = 'transform="s,^,,"'
34
35PACKAGES =+ "libjack jack-server jack-utils"
36
37FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
38FILES_jack-server = "${bindir}/jackd"
39FILES_jack-utils = "${bindir}/*"
40FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/* "