summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-04-25 12:00:01 +0800
committerKhem Raj <raj.khem@gmail.com>2022-04-25 11:46:44 -0700
commitf2748082e84b70c0a73d7d494b0f02338fedded1 (patch)
treecdfafd69acad87ea8d27c8234a92f69c3ae0c83d /meta-oe/recipes-kernel
parentdafc1efa157a39b76d264a854df0e0e48648cca2 (diff)
downloadmeta-openembedded-f2748082e84b70c0a73d7d494b0f02338fedded1.tar.gz
makedumpfile: Upgrade to 1.7.1
Remove related man pages gz logic as it's removed in new version [1]. [1] https://github.com/makedumpfile/makedumpfile/commit/2169de66ecd4504a3e69e0be0330f492f966ce5e Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch53
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.1.bb (renamed from meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.0.bb)8
2 files changed, 26 insertions, 35 deletions
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
index 1dd87c8b1..f3dc8a466 100644
--- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
@@ -1,6 +1,6 @@
1From af97e2ad643334b4c7c3d66f971ce9ebb2b596af Mon Sep 17 00:00:00 2001 1From 71b5a3905d5cd0feca88a0d61d7657ba5296a052 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com> 2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Thu, 21 Jul 2016 18:06:21 +0800 3Date: Sun, 24 Apr 2022 17:25:33 +0800
4Subject: [PATCH] makedumpfile: replace hardcode CFLAGS 4Subject: [PATCH] makedumpfile: replace hardcode CFLAGS
5 5
6* Create alias for target such as powerpc as powerpc32 6* Create alias for target such as powerpc as powerpc32
@@ -16,9 +16,12 @@ Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
16 16
17[2021-11-18] Patch updated to use CFLAGS_COMMON for zstd 17[2021-11-18] Patch updated to use CFLAGS_COMMON for zstd
18Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> 18Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
19
20Rebase to 1.7.1
21Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
19--- 22---
20 Makefile | 47 ++++++++++++++++++++++++----------------------- 23 Makefile | 42 ++++++++++++++++++++++--------------------
21 1 file changed, 24 insertions(+), 23 deletions(-) 24 1 file changed, 22 insertions(+), 20 deletions(-)
22 25
23--- a/Makefile 26--- a/Makefile
24+++ b/Makefile 27+++ b/Makefile
@@ -35,19 +38,13 @@ Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
35 HOST_ARCH := $(shell uname -m) 38 HOST_ARCH := $(shell uname -m)
36 # Use TARGET as the target architecture if specified. 39 # Use TARGET as the target architecture if specified.
37 # Defaults to uname -m 40 # Defaults to uname -m
38@@ -21,29 +15,36 @@ ifeq ($(strip($TARGET)),) 41@@ -24,26 +18,34 @@ endif
39 TARGET := $(HOST_ARCH) 42 ARCH := $(shell echo ${TARGET} | sed -e s/i.86/x86/ -e s/sun4u/sparc64/ \
40 endif 43 -e s/arm.*/arm/ -e s/sa110/arm/ \
41 44 -e s/s390x/s390/ -e s/parisc64/parisc/ \
42-ARCH := $(shell echo ${TARGET} | sed -e s/i.86/x86/ -e s/sun4u/sparc64/ \
43- -e s/arm.*/arm/ -e s/sa110/arm/ \
44- -e s/s390x/s390/ -e s/parisc64/parisc/ \
45- -e s/ppc64/powerpc64/ -e s/ppc/powerpc32/) 45- -e s/ppc64/powerpc64/ -e s/ppc/powerpc32/)
46+ARCH := $(shell echo __${TARGET}__ | sed -e s/i.86/x86/ -e s/sun4u/sparc64/ \ 46+ -e s/ppc64/powerpc64/ -e s/ppc/powerpc32/ \
47+ -e s/arm.*/arm/ -e s/sa110/arm/ \ 47+ -e s/_powerpc_/_powerpc32_/)
48+ -e s/s390x/s390/ -e s/parisc64/parisc/ \
49+ -e s/ppc64/powerpc64/ -e s/ppc/powerpc32/ \
50+ -e s/_powerpc_/_powerpc32_/)
51 48
52 CROSS := 49 CROSS :=
53 ifneq ($(TARGET), $(HOST_ARCH)) 50 ifneq ($(TARGET), $(HOST_ARCH))
@@ -55,8 +52,7 @@ Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
55 endif 52 endif
56 53
57-CFLAGS += -D__$(ARCH)__ $(CROSS) 54-CFLAGS += -D__$(ARCH)__ $(CROSS)
58-CFLAGS_ARCH += -D__$(ARCH)__ $(CROSS) 55 CFLAGS_ARCH += -D__$(ARCH)__ $(CROSS)
59+CFLAGS_ARCH += -D$(ARCH) $(CROSS)
60 56
61-ifeq ($(ARCH), powerpc64) 57-ifeq ($(ARCH), powerpc64)
62-CFLAGS += -m64 58-CFLAGS += -m64
@@ -79,10 +75,11 @@ Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
79+ -DVERSION='"$(VERSION)"' \ 75+ -DVERSION='"$(VERSION)"' \
80+ -DRELEASE_DATE='"$(DATE)"' 76+ -DRELEASE_DATE='"$(DATE)"'
81+ 77+
78+
82 SRC_BASE = makedumpfile.c makedumpfile.h diskdump_mod.h sadump_mod.h sadump_info.h 79 SRC_BASE = makedumpfile.c makedumpfile.h diskdump_mod.h sadump_mod.h sadump_info.h
83 SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c tools.c printk.c 80 SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c tools.c printk.c detect_cycle.c
84 OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART)) 81 OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART))
85@@ -52,12 +53,12 @@ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH)) 82@@ -52,12 +54,12 @@ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH))
86 83
87 LIBS = -ldw -lbz2 -ldl -lelf -lz 84 LIBS = -ldw -lbz2 -ldl -lelf -lz
88 ifneq ($(LINKTYPE), dynamic) 85 ifneq ($(LINKTYPE), dynamic)
@@ -97,7 +94,7 @@ Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
97 endif 94 endif
98 95
99 ifeq ($(USESNAPPY), on) 96 ifeq ($(USESNAPPY), on)
100@@ -65,12 +66,12 @@ LIBS := -lsnappy $(LIBS) 97@@ -65,12 +67,12 @@ LIBS := -lsnappy $(LIBS)
101 ifneq ($(LINKTYPE), dynamic) 98 ifneq ($(LINKTYPE), dynamic)
102 LIBS := $(LIBS) -lstdc++ 99 LIBS := $(LIBS) -lstdc++
103 endif 100 endif
@@ -112,7 +109,7 @@ Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
112 endif 109 endif
113 110
114 ifeq ($(DEBUG), on) 111 ifeq ($(DEBUG), on)
115@@ -104,14 +105,14 @@ LIBS := $(LIBS) $(call try-run,\ 112@@ -104,14 +106,14 @@ LIBS := $(LIBS) $(call try-run,\
116 all: makedumpfile 113 all: makedumpfile
117 114
118 $(OBJ_PART): $(SRC_PART) 115 $(OBJ_PART): $(SRC_PART)
@@ -126,15 +123,15 @@ Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
126 makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH) 123 makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH)
127- $(CC) $(CFLAGS) $(LDFLAGS) $(OBJ_PART) $(OBJ_ARCH) -rdynamic -o $@ $< $(LIBS) 124- $(CC) $(CFLAGS) $(LDFLAGS) $(OBJ_PART) $(OBJ_ARCH) -rdynamic -o $@ $< $(LIBS)
128+ $(CC) $(CFLAGS_COMMON) $(LDFLAGS) $(OBJ_PART) $(OBJ_ARCH) -rdynamic -o $@ $< $(LIBS) 125+ $(CC) $(CFLAGS_COMMON) $(LDFLAGS) $(OBJ_PART) $(OBJ_ARCH) -rdynamic -o $@ $< $(LIBS)
129 echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8 126 @sed -e "s/@DATE@/$(DATE)/" \
130 grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8 127 -e "s/@VERSION@/$(VERSION)/" \
131 mv temp.8 makedumpfile.8 128 $(VPATH)makedumpfile.8.in > $(VPATH)makedumpfile.8
132@@ -122,7 +123,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $( 129@@ -120,7 +122,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(
133 gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz 130 $(VPATH)makedumpfile.conf.5.in > $(VPATH)makedumpfile.conf.5
134 131
135 eppic_makedumpfile.so: extension_eppic.c 132 eppic_makedumpfile.so: extension_eppic.c
136- $(CC) $(CFLAGS) $(LDFLAGS) -shared -rdynamic -o $@ extension_eppic.c -fPIC -leppic -ltinfo 133- $(CC) $(CFLAGS) $(LDFLAGS) -shared -rdynamic -o $@ extension_eppic.c -fPIC -leppic -ltinfo
137+ $(CC) $(CFLAGS_COMMON) $(LDFLAGS) -shared -rdynamic -o $@ extension_eppic.c -fPIC -leppic -ltinfo 134+ $(CC) $(CFLAGS_COMMON) $(LDFLAGS) -shared -rdynamic -o $@ extension_eppic.c -fPIC -leppic -ltinfo
138 135
139 clean: 136 clean:
140 rm -f $(OBJ) $(OBJ_PART) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz makedumpfile.conf.5.gz 137 rm -f $(OBJ) $(OBJ_PART) $(OBJ_ARCH) makedumpfile makedumpfile.8 makedumpfile.conf.5
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.0.bb b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.1.bb
index d4da03186..c3f965b04 100644
--- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.0.bb
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.7.1.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
11LICENSE = "GPL-2.0-only" 11LICENSE = "GPL-2.0-only"
12 12
13SRCBRANCH ?= "master" 13SRCBRANCH ?= "master"
14SRCREV = "06ef8e2b814feb08a668b7a3783c86674e49a7b1" 14SRCREV = "74bbdd14ec861552ace1ca63953eb2ef73e1f965"
15 15
16DEPENDS = "bzip2 zlib elfutils xz" 16DEPENDS = "bzip2 zlib elfutils xz"
17RDEPENDS:${PN}-tools = "perl ${PN}" 17RDEPENDS:${PN}-tools = "perl ${PN}"
@@ -52,12 +52,6 @@ do_install () {
52 install -m 755 ${S}/makedumpfile ${D}/usr/bin 52 install -m 755 ${S}/makedumpfile ${D}/usr/bin
53 install -m 755 ${S}/makedumpfile-R.pl ${D}/usr/bin 53 install -m 755 ${S}/makedumpfile-R.pl ${D}/usr/bin
54 54
55 mkdir -p ${D}/usr/share/man/man8
56 install -m 644 ${S}/makedumpfile.8.gz ${D}/usr/share/man/man8
57
58 mkdir -p ${D}/usr/share/man/man5
59 install -m 644 ${S}/makedumpfile.conf.5.gz ${D}/usr/share/man/man5
60
61 mkdir -p ${D}/etc/ 55 mkdir -p ${D}/etc/
62 install -m 644 ${S}/makedumpfile.conf ${D}/etc/makedumpfile.conf.sample 56 install -m 644 ${S}/makedumpfile.conf ${D}/etc/makedumpfile.conf.sample
63} 57}