summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-25 22:34:46 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:25 +0200
commitec9f60a6ef6e4434705756511aa76fc4ee6e4f1d (patch)
tree13b8dee1195e43cbc1018a09f9c38e60b0d41d94 /meta-oe/recipes-kernel
parent81a3addfe5b74bd5779ab9cd8fe047d348ab8c25 (diff)
downloadmeta-openembedded-ec9f60a6ef6e4434705756511aa76fc4ee6e4f1d.tar.gz
crash: Upgrade to 7.1.9
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/crash/crash/0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch112
-rw-r--r--meta-oe/recipes-kernel/crash/crash_7.1.9.bb (renamed from meta-oe/recipes-kernel/crash/crash_7.1.8.bb)8
2 files changed, 3 insertions, 117 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch b/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch
deleted file mode 100644
index 9434815d8..000000000
--- a/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch
+++ /dev/null
@@ -1,112 +0,0 @@
1From b8c8fbe0a2481e97fc57dd596346827a692a5768 Mon Sep 17 00:00:00 2001
2From: Dave Anderson <anderson@redhat.com>
3Date: Tue, 28 Mar 2017 15:44:40 -0400
4Subject: [PATCH 1/3] Fix for a compilation error if glibc-2.25 or later has
5 been installed on the host build machine. Without the patch, the build fails
6 with the error message "amd64-linux-nat.c:496:1: error: conflicting types for
7 'ps_get_thread_area'". (anderson@redhat.com)
8
9Upstream-Status: Backport
10
11Signed-off-by: Dengke Du <dengke.du@windriver.com>
12---
13 Makefile | 6 +++++
14 configure.c | 2 +-
15 gdb-7.6-proc_service.h.patch | 55 ++++++++++++++++++++++++++++++++++++++++++++
16 3 files changed, 62 insertions(+), 1 deletion(-)
17 create mode 100644 gdb-7.6-proc_service.h.patch
18
19diff --git a/Makefile b/Makefile
20index 202ef8b..b6b7e80 100644
21--- a/Makefile
22+++ b/Makefile
23@@ -264,6 +264,12 @@ gdb_patch:
24 if [ "${ARCH}" = "x86_64" ] && [ "${TARGET}" = "PPC64" ] && [ -f ${GDB}-ppc64le-support.patch ]; then \
25 patch -d ${GDB} -p1 -F0 < ${GDB}-ppc64le-support.patch ; \
26 fi
27+ if [ -f /usr/include/proc_service.h ]; then \
28+ grep 'extern ps_err_e ps_get_thread_area (struct' /usr/include/proc_service.h; \
29+ if [ $$? -eq 0 ]; then \
30+ patch -p0 < ${GDB}-proc_service.h.patch; \
31+ fi; \
32+ fi
33
34 library: make_build_data ${OBJECT_FILES}
35 ar -rs ${PROGRAM}lib.a ${OBJECT_FILES}
36diff --git a/configure.c b/configure.c
37index d63cdd7..776defe 100644
38--- a/configure.c
39+++ b/configure.c
40@@ -240,7 +240,7 @@ struct supported_gdb_version {
41 "7.6",
42 "GDB_FILES=${GDB_7.6_FILES}",
43 "GDB_OFILES=${GDB_7.6_OFILES}",
44- "GDB_PATCH_FILES=gdb-7.6.patch gdb-7.6-ppc64le-support.patch",
45+ "GDB_PATCH_FILES=gdb-7.6.patch gdb-7.6-ppc64le-support.patch gdb-7.6-proc_service.h.patch",
46 "GDB_FLAGS=-DGDB_7_6",
47 "GPLv3"
48 },
49diff --git a/gdb-7.6-proc_service.h.patch b/gdb-7.6-proc_service.h.patch
50new file mode 100644
51index 0000000..49d18bb
52--- /dev/null
53+++ b/gdb-7.6-proc_service.h.patch
54@@ -0,0 +1,55 @@
55+--- gdb-7.6/gdb/gdb_proc_service.h.orig
56++++ gdb-7.6/gdb/gdb_proc_service.h
57+@@ -115,7 +115,7 @@ extern pid_t ps_getpid (struct ps_procha
58+ /* Fetch the special per-thread address associated with the given LWP.
59+ This call is only used on a few platforms (most use a normal register).
60+ The meaning of the `int' parameter is machine-dependent. */
61+-extern ps_err_e ps_get_thread_area (const struct ps_prochandle *,
62++extern ps_err_e ps_get_thread_area (struct ps_prochandle *,
63+ lwpid_t, int, psaddr_t *);
64+
65+
66+--- gdb-7.6/gdb/amd64-linux-nat.c.orig
67++++ gdb-7.6/gdb/amd64-linux-nat.c
68+@@ -493,7 +493,7 @@ amd64_linux_new_fork (struct lwp_info *p
69+ a request for a thread's local storage address. */
70+
71+ ps_err_e
72+-ps_get_thread_area (const struct ps_prochandle *ph,
73++ps_get_thread_area (struct ps_prochandle *ph,
74+ lwpid_t lwpid, int idx, void **base)
75+ {
76+ if (gdbarch_bfd_arch_info (target_gdbarch ())->bits_per_word == 32)
77+--- gdb-7.6/gdb/aarch64-linux-nat.c.orig
78++++ gdb-7.6/gdb/aarch64-linux-nat.c
79+@@ -750,7 +750,7 @@ aarch64_linux_new_fork (struct lwp_info
80+ storage (or its descriptor). */
81+
82+ ps_err_e
83+-ps_get_thread_area (const struct ps_prochandle *ph,
84++ps_get_thread_area (struct ps_prochandle *ph,
85+ lwpid_t lwpid, int idx, void **base)
86+ {
87+ struct iovec iovec;
88+--- gdb-7.6/gdb/arm-linux-nat.c.orig
89++++ gdb-7.6/gdb/arm-linux-nat.c
90+@@ -613,7 +613,7 @@ supply_fpregset (struct regcache *regcac
91+ /* Fetch the thread-local storage pointer for libthread_db. */
92+
93+ ps_err_e
94+-ps_get_thread_area (const struct ps_prochandle *ph,
95++ps_get_thread_area (struct ps_prochandle *ph,
96+ lwpid_t lwpid, int idx, void **base)
97+ {
98+ if (ptrace (PTRACE_GET_THREAD_AREA, lwpid, NULL, base) != 0)
99+--- gdb-7.6/gdb/i386-linux-nat.c.orig
100++++ gdb-7.6/gdb/i386-linux-nat.c
101+@@ -849,7 +849,7 @@ i386_linux_new_fork (struct lwp_info *pa
102+ storage (or its descriptor). */
103+
104+ ps_err_e
105+-ps_get_thread_area (const struct ps_prochandle *ph,
106++ps_get_thread_area (struct ps_prochandle *ph,
107+ lwpid_t lwpid, int idx, void **base)
108+ {
109+ /* NOTE: cagney/2003-08-26: The definition of this buffer is found
110--
1112.8.1
112
diff --git a/meta-oe/recipes-kernel/crash/crash_7.1.8.bb b/meta-oe/recipes-kernel/crash/crash_7.1.9.bb
index 9cbb291f3..93208e398 100644
--- a/meta-oe/recipes-kernel/crash/crash_7.1.8.bb
+++ b/meta-oe/recipes-kernel/crash/crash_7.1.9.bb
@@ -10,7 +10,7 @@ SECTION = "devel"
10LICENSE = "GPLv3" 10LICENSE = "GPLv3"
11LIC_FILES_CHKSUM = "file://COPYING3;md5=d32239bcb673463ab874e80d47fae504" 11LIC_FILES_CHKSUM = "file://COPYING3;md5=d32239bcb673463ab874e80d47fae504"
12 12
13DEPENDS = "zlib readline" 13DEPENDS = "zlib readline coreutils-native"
14 14
15SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz \ 15SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz \
16 http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz;name=gdb;subdir=${BP} \ 16 http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz;name=gdb;subdir=${BP} \
@@ -22,14 +22,12 @@ SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz;download
22 file://donnot-extract-gdb-during-do-compile.patch \ 22 file://donnot-extract-gdb-during-do-compile.patch \
23 file://gdb_build_jobs_and_not_write_crash_target.patch \ 23 file://gdb_build_jobs_and_not_write_crash_target.patch \
24 file://remove-unrecognized-gcc-option-m32-for-mips.patch \ 24 file://remove-unrecognized-gcc-option-m32-for-mips.patch \
25 file://0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch \
26 file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \ 25 file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \
27 file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \ 26 file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \
28 file://0004-crash-fix-build-failure-with-mips.patch \ 27 file://0004-crash-fix-build-failure-with-mips.patch \
29 " 28 "
30 29SRC_URI[md5sum] = "f3b44a151dbe7046462b9caaa9847ca6"
31SRC_URI[md5sum] = "31787074f267a3536eebff008a0652ec" 30SRC_URI[sha256sum] = "c48e1269443a6a8e8337e328b21b03e4e50248f607eed83fbb27eb0d833d6aa4"
32SRC_URI[sha256sum] = "9965dee9199d7e39764fbee7f21c7c45b1f7b6d17c8e92ad62f468f062876478"
33 31
34SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470" 32SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470"
35SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36" 33SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36"