summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-04-27 11:04:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:33 +0200
commitec9e5ed06256ad92c818474cdb490dc0d3a0d0a3 (patch)
treee16d2a838f4561d5538928a58f805e5f1373225a /meta-oe/recipes-kernel
parent6775acb048dabd624c5c8197b683aba45ed91569 (diff)
downloadmeta-openembedded-ec9e5ed06256ad92c818474cdb490dc0d3a0d0a3.tar.gz
recipes: remove blacklisted recipes
* as PNBLACKLIST message says, these recipes are blacklisted for long time and nobody showed any interest to fix them * remove all unused .patch and .inc files as well Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_git.bb22
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc26
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_git.bb19
3 files changed, 0 insertions, 67 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
deleted file mode 100644
index 1119d4c90..000000000
--- a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3require ktap.inc
4
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6
7inherit module
8
9# See https://github.com/ktap/ktap/issues/80
10PNBLACKLIST[ktap-module] ?= "Not compatible with 3.19 kernel - the recipe will be removed on 2017-09-01 unless the issue is fixed"
11
12# Only build the module
13MAKE_TARGETS = "mod"
14
15# Kernel module packages MUST begin with 'kernel-module-', otherwise
16# multilib image generation can fail.
17#
18# The following line is only necessary if the recipe name does not begin
19# with kernel-module-.
20#
21PKG_${PN} = "kernel-module-${PN}"
22
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
deleted file mode 100644
index c214a020d..000000000
--- a/meta-oe/recipes-kernel/ktap/ktap.inc
+++ /dev/null
@@ -1,26 +0,0 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3HOMEPAGE = "http://www.ktap.org"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE-GPL;md5=eb723b61539feef013de476e68b5c50a"
6
7PV = "0.4+gitr${SRCPV}"
8SRCREV = "c8401e07c89cdec9a5f673da4ddb12b7982b522b"
9SRC_URI = "git://github.com/ktap/ktap.git"
10
11S = "${WORKDIR}/git"
12
13# Package config is abused as a general compile time configuration tool.
14
15# Only supports x86_64 for now!. Needs to be enabled for ktap-module too.
16PACKAGECONFIG[ffi] = ""
17
18# Needed to resolve symbols in DSO and for sdt
19PACKAGECONFIG[libelf] = ",,elfutils"
20
21PACKAGECONFIG ?= "libelf"
22
23EXTRA_OEMAKE = " \
24 ${@bb.utils.contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
25 ${@bb.utils.contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
26"
diff --git a/meta-oe/recipes-kernel/ktap/ktap_git.bb b/meta-oe/recipes-kernel/ktap/ktap_git.bb
deleted file mode 100644
index a947b7fcc..000000000
--- a/meta-oe/recipes-kernel/ktap/ktap_git.bb
+++ /dev/null
@@ -1,19 +0,0 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3require ktap.inc
4
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6DEPENDS = "ktap-module"
7
8PNBLACKLIST[ktap] ?= "Depends on blacklisted kernel-module-ktapvm - the recipe will be removed on 2017-09-01 unless the issue is fixed"
9
10# Only build the userspace app
11EXTRA_OEMAKE += "ktap"
12
13do_install() {
14 install -d ${D}${bindir}
15 install -m 0755 ${S}/ktap ${D}${bindir}/
16}
17
18PACKAGE_ARCH = "${MACHINE_ARCH}"
19RRECOMMENDS_${PN} = "kernel-module-ktapvm"