summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorJohnathan Mantey <johnathanx.mantey@intel.com>2023-11-02 10:27:36 -0700
committerKhem Raj <raj.khem@gmail.com>2023-11-02 10:45:57 -0700
commit762a6880f3e56832441ecacdddeddc3566de1f54 (patch)
tree37c05480f9e18583e5f2f3f38efbe56a166f0a84 /meta-oe/recipes-kernel
parent3b1abede06befcef54ffacf086d985f7283dd8c2 (diff)
downloadmeta-openembedded-762a6880f3e56832441ecacdddeddc3566de1f54.tar.gz
ipmitool: Update and eliminate unneeded patch
The upstream ipmitool code has implemented an autoconfig control to enable and disable dynamic fetching of the IANA numbers file. As a result the patch removing the code that blocks fetching the IANA numbers is no longer relevant. The patch being removed explicitlly blocks downloading the IANA numbers file. Maintain this behavior at this level by using the --disable-registry-download feature. In order for that autoconfig switch to work, the recipe must inherit the pkgconfig feature. Without the pkgconfig dependency the code in the configure.ac file causes a compile time error. Tested: IANA numbers file isn't downloaded. Manually downloaded IANA file is installed in /usr/share/misc Enabling registry download enables dynamic download of IANA numbers Signed-off-by: Johnathan Mantey <johnathanx.mantey@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch41
-rw-r--r--meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb12
2 files changed, 8 insertions, 45 deletions
diff --git a/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch b/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
deleted file mode 100644
index 442f13271..000000000
--- a/meta-oe/recipes-kernel/ipmitool/ipmitool/0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch
+++ /dev/null
@@ -1,41 +0,0 @@
1From 63d72f97bd106dd2101cd7fdac6df4f7a053d67c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 2 Sep 2022 08:27:39 -0700
4Subject: [PATCH] configure: Remove the logic to download IANA PEN database
5 during configure
6
7OE will do all downloading before it starts to configure therefore this
8step is moved out into bitbake recipe, so we can make it immutable build
9
10Upstream-Status: Inappropriate [OE-Specific]
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 configure.ac | 16 +---------------
15 1 file changed, 1 insertion(+), 15 deletions(-)
16
17--- a/configure.ac
18+++ b/configure.ac
19@@ -56,21 +56,7 @@ if test "x$exec_prefix" = "xNONE"; then
20 exec_prefix="$prefix"
21 fi
22
23-if test "x$WGET" = "x"; then
24- if test "x$CURL" = "x"; then
25- AC_MSG_WARN([** Neither wget nor curl could be found.])
26- AC_MSG_WARN([** IANA PEN database will not be installed by `make install` !])
27- else
28- DOWNLOAD="$CURL --location --progress-bar"
29- AM_CONDITIONAL([DOWNLOAD], [true])
30- fi
31-else
32- DOWNLOAD="$WGET -c -nd -O -"
33- AM_CONDITIONAL([DOWNLOAD], [true])
34-fi
35-
36-AC_MSG_WARN([** Download is:])
37-AC_MSG_WARN($DOWNLOAD)
38+AM_CONDITIONAL([DOWNLOAD], [false])
39 AC_SUBST(DOWNLOAD, $DOWNLOAD)
40
41 dnl
diff --git a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
index ab9074bba..a8279f575 100644
--- a/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
+++ b/meta-oe/recipes-kernel/ipmitool/ipmitool_1.8.19.bb
@@ -21,10 +21,9 @@ LICENSE = "BSD-3-Clause"
21LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184" 21LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184"
22 22
23DEPENDS = "openssl readline ncurses" 23DEPENDS = "openssl readline ncurses"
24SRCREV = "19d78782d795d0cf4ceefe655f616210c9143e62" 24SRCREV = "ab5ce5baff097ebb6e2a17a171858be213ee68d3"
25SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \ 25SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \
26 ${IANA_ENTERPRISE_NUMBERS} \ 26 ${IANA_ENTERPRISE_NUMBERS} \
27 file://0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch \
28 " 27 "
29IANA_ENTERPRISE_NUMBERS ?= "" 28IANA_ENTERPRISE_NUMBERS ?= ""
30 29
@@ -34,7 +33,7 @@ IANA_ENTERPRISE_NUMBERS ?= ""
34 33
35S = "${WORKDIR}/git" 34S = "${WORKDIR}/git"
36 35
37inherit autotools 36inherit autotools pkgconfig
38 37
39do_install:append() { 38do_install:append() {
40 if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then 39 if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then
@@ -50,5 +49,10 @@ FILES:${PN} += "${datadir}/misc"
50# --enable-file-security adds some security checks 49# --enable-file-security adds some security checks
51# --disable-intf-free disables FreeIPMI support - we don't want to depend on 50# --disable-intf-free disables FreeIPMI support - we don't want to depend on
52# FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility. 51# FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
52# --disable-registry-download prevents the IANA numbers from being fetched
53# at build time, as it is not repeatable.
53# 54#
54EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free" 55EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free \
56 --disable-registry-download \
57 "
58