summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-06-17 13:43:41 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-23 15:20:05 +0200
commit559c14ac81645f405500238c04f4a018a94eb28b (patch)
treefd58c7c240855abe407e0b401469fd28cd52e1a0 /meta-oe/recipes-kernel
parent80def85257e9676f6ad870f5adc2797349919f0f (diff)
downloadmeta-openembedded-559c14ac81645f405500238c04f4a018a94eb28b.tar.gz
crash: update to version 7.1.5
* Resolves issues with gcc-6 on ARM Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/crash/crash/0001-cross_add_configure_option.patch4
-rw-r--r--meta-oe/recipes-kernel/crash/crash/gdb_build_jobs_and_not_write_crash_target.patch2
-rw-r--r--meta-oe/recipes-kernel/crash/crash/remove-unrecognized-gcc-option-m32-for-mips.patch6
-rw-r--r--meta-oe/recipes-kernel/crash/crash_7.1.5.bb (renamed from meta-oe/recipes-kernel/crash/crash_7.1.3.bb)7
4 files changed, 8 insertions, 11 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash/0001-cross_add_configure_option.patch b/meta-oe/recipes-kernel/crash/crash/0001-cross_add_configure_option.patch
index 229647f00..39732a9ed 100644
--- a/meta-oe/recipes-kernel/crash/crash/0001-cross_add_configure_option.patch
+++ b/meta-oe/recipes-kernel/crash/crash/0001-cross_add_configure_option.patch
@@ -11,13 +11,13 @@ diff --git a/Makefile b/Makefile
11index 9c44633..39bebd0 100644 11index 9c44633..39bebd0 100644
12--- a/Makefile 12--- a/Makefile
13+++ b/Makefile 13+++ b/Makefile
14@@ -229,7 +229,7 @@ gdb_merge: force 14@@ -232,7 +232,7 @@ gdb_merge: force
15 @echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj 15 @echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
16 @rm -f ${PROGRAM} 16 @rm -f ${PROGRAM}
17 @if [ ! -f ${GDB}/config.status ]; then \ 17 @if [ ! -f ${GDB}/config.status ]; then \
18- (cd ${GDB}; ./configure ${GDB_CONF_FLAGS} --with-separate-debug-dir=/usr/lib/debug \ 18- (cd ${GDB}; ./configure ${GDB_CONF_FLAGS} --with-separate-debug-dir=/usr/lib/debug \
19+ (cd ${GDB}; ./configure --host=${GDB_TARGET} --build=${GDB_HOST} --with-separate-debug-dir=/usr/lib/debug \ 19+ (cd ${GDB}; ./configure --host=${GDB_TARGET} --build=${GDB_HOST} --with-separate-debug-dir=/usr/lib/debug \
20 --with-bugurl="" --with-expat=no --with-python=no; \ 20 --with-bugurl="" --with-expat=no --with-python=no --disable-sim; \
21 make --no-print-directory CRASH_TARGET=${TARGET}; echo ${TARGET} > crash.target) \ 21 make --no-print-directory CRASH_TARGET=${TARGET}; echo ${TARGET} > crash.target) \
22 else make --no-print-directory rebuild; fi 22 else make --no-print-directory rebuild; fi
23@@ -277,7 +277,7 @@ force: 23@@ -277,7 +277,7 @@ force:
diff --git a/meta-oe/recipes-kernel/crash/crash/gdb_build_jobs_and_not_write_crash_target.patch b/meta-oe/recipes-kernel/crash/crash/gdb_build_jobs_and_not_write_crash_target.patch
index 3f4d1bc30..aa5f44dd4 100644
--- a/meta-oe/recipes-kernel/crash/crash/gdb_build_jobs_and_not_write_crash_target.patch
+++ b/meta-oe/recipes-kernel/crash/crash/gdb_build_jobs_and_not_write_crash_target.patch
@@ -16,7 +16,7 @@ index 27a1d47..bcf2d2f 100644
16@@ -232,8 +232,8 @@ gdb_merge: force 16@@ -232,8 +232,8 @@ gdb_merge: force
17 @if [ ! -f ${GDB}/config.status ]; then \ 17 @if [ ! -f ${GDB}/config.status ]; then \
18 (cd ${GDB}; ./configure --host=${GDB_TARGET} --build=${GDB_HOST} --with-separate-debug-dir=/usr/lib/debug \ 18 (cd ${GDB}; ./configure --host=${GDB_TARGET} --build=${GDB_HOST} --with-separate-debug-dir=/usr/lib/debug \
19 --with-bugurl="" --with-expat=no --with-python=no; \ 19 --with-bugurl="" --with-expat=no --with-python=no --disable-sim; \
20- make --no-print-directory CRASH_TARGET=${TARGET}; echo ${TARGET} > crash.target) \ 20- make --no-print-directory CRASH_TARGET=${TARGET}; echo ${TARGET} > crash.target) \
21- else make --no-print-directory rebuild; fi 21- else make --no-print-directory rebuild; fi
22+ make --no-print-directory CRASH_TARGET=${TARGET} ${GDB_MAKE_JOBS}; ) \ 22+ make --no-print-directory CRASH_TARGET=${TARGET} ${GDB_MAKE_JOBS}; ) \
diff --git a/meta-oe/recipes-kernel/crash/crash/remove-unrecognized-gcc-option-m32-for-mips.patch b/meta-oe/recipes-kernel/crash/crash/remove-unrecognized-gcc-option-m32-for-mips.patch
index c24db1042..905b4c2cd 100644
--- a/meta-oe/recipes-kernel/crash/crash/remove-unrecognized-gcc-option-m32-for-mips.patch
+++ b/meta-oe/recipes-kernel/crash/crash/remove-unrecognized-gcc-option-m32-for-mips.patch
@@ -13,16 +13,16 @@ diff --git a/configure.c b/configure.c
13index cf1973b..71e97b3 100644 13index cf1973b..71e97b3 100644
14--- a/configure.c 14--- a/configure.c
15+++ b/configure.c 15+++ b/configure.c
16@@ -148,7 +148,7 @@ void add_extra_lib(char *); 16@@ -151,7 +151,7 @@ void add_extra_lib(char *);
17 #define TARGET_CFLAGS_PPC64_ON_X86_64 "TARGET_CFLAGS=" 17 #define TARGET_CFLAGS_PPC64_ON_X86_64 "TARGET_CFLAGS="
18 #define TARGET_CFLAGS_MIPS "TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64" 18 #define TARGET_CFLAGS_MIPS "TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64"
19 #define TARGET_CFLAGS_MIPS_ON_X86 "TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64" 19 #define TARGET_CFLAGS_MIPS_ON_X86 "TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64"
20-#define TARGET_CFLAGS_MIPS_ON_X86_64 "TARGET_CFLAGS=-m32 -D_FILE_OFFSET_BITS=64" 20-#define TARGET_CFLAGS_MIPS_ON_X86_64 "TARGET_CFLAGS=-m32 -D_FILE_OFFSET_BITS=64"
21+#define TARGET_CFLAGS_MIPS_ON_X86_64 "TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64" 21+#define TARGET_CFLAGS_MIPS_ON_X86_64 "TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64"
22 #define TARGET_CFLAGS_SPARC64 "TARGET_CFLAGS="
22 23
23 #define GDB_TARGET_DEFAULT "GDB_CONF_FLAGS=" 24 #define GDB_TARGET_DEFAULT "GDB_CONF_FLAGS="
24 #define GDB_TARGET_ARM_ON_X86 "GDB_CONF_FLAGS=--target=arm-elf-linux" 25@@ -162,7 +162,7 @@ void add_extra_lib(char *);
25@@ -158,7 +158,7 @@ void add_extra_lib(char *);
26 #define GDB_TARGET_ARM64_ON_X86_64 "GDB_CONF_FLAGS=--target=aarch64-elf-linux" /* TBD */ 26 #define GDB_TARGET_ARM64_ON_X86_64 "GDB_CONF_FLAGS=--target=aarch64-elf-linux" /* TBD */
27 #define GDB_TARGET_PPC64_ON_X86_64 "GDB_CONF_FLAGS=--target=powerpc64le-unknown-linux-gnu" 27 #define GDB_TARGET_PPC64_ON_X86_64 "GDB_CONF_FLAGS=--target=powerpc64le-unknown-linux-gnu"
28 #define GDB_TARGET_MIPS_ON_X86 "GDB_CONF_FLAGS=--target=mipsel-elf-linux" 28 #define GDB_TARGET_MIPS_ON_X86 "GDB_CONF_FLAGS=--target=mipsel-elf-linux"
diff --git a/meta-oe/recipes-kernel/crash/crash_7.1.3.bb b/meta-oe/recipes-kernel/crash/crash_7.1.5.bb
index 49b187d19..ce13b71ef 100644
--- a/meta-oe/recipes-kernel/crash/crash_7.1.3.bb
+++ b/meta-oe/recipes-kernel/crash/crash_7.1.5.bb
@@ -24,8 +24,8 @@ SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz;download
24 file://remove-unrecognized-gcc-option-m32-for-mips.patch \ 24 file://remove-unrecognized-gcc-option-m32-for-mips.patch \
25 " 25 "
26 26
27SRC_URI[md5sum] = "155889a233c5230ef1d387858091d294" 27SRC_URI[md5sum] = "7bd06eaec6827d4fac636b2b592d3056"
28SRC_URI[sha256sum] = "ae98529d42b843f07d795b86b8f8529f64cc607ee3c58affc5a8aa8a506e183d" 28SRC_URI[sha256sum] = "c3954412c8557614a0d50092c007aa96b4e3e6e97453dfbb60241ab680caf7b2"
29 29
30SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470" 30SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470"
31SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36" 31SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36"
@@ -110,6 +110,3 @@ RDEPENDS_${PN}_class-cross = ""
110# Causes gcc to get stuck and eat all available memory in qemuarm builds 110# Causes gcc to get stuck and eat all available memory in qemuarm builds
111# jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o - 111# jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o -
112ARM_INSTRUCTION_SET = "arm" 112ARM_INSTRUCTION_SET = "arm"
113
114# http://errors.yoctoproject.org/Errors/Details/68624/
115PNBLACKLIST[crash] ?= "BROKEN: fails to build with gcc-6"