summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authordengke.du@windriver.com <dengke.du@windriver.com>2017-05-04 03:45:06 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-23 15:49:33 +0200
commit0e58538baa101ce2438593369939b383710961b0 (patch)
tree631cd4cebb764862f1d711669b650341637c4db5 /meta-oe/recipes-kernel
parent4c9a7e975cb09b43b1e08f287e42d9c0682e949c (diff)
downloadmeta-openembedded-0e58538baa101ce2438593369939b383710961b0.tar.gz
crash: fix build failure with mips
When build crash with mips: ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ mips-linux-nat.c:157:1: error: conflicting types for 'ps_get_thread_area' ps_get_thread_area (const struct ps_prochandle *ph, ^~~~~~~~~~~~~~~~~~ In file included from gdb_proc_service.h:26:0, from mips-linux-nat.c:32: ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ This problem have been fixed on intel and arm plantform, we can use the similar approch to fix it on mips. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/crash/crash/0004-crash-fix-build-failure-with-mips.patch87
-rw-r--r--meta-oe/recipes-kernel/crash/crash_7.1.8.bb1
2 files changed, 88 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash/0004-crash-fix-build-failure-with-mips.patch b/meta-oe/recipes-kernel/crash/crash/0004-crash-fix-build-failure-with-mips.patch
new file mode 100644
index 000000000..1e7ce6b38
--- /dev/null
+++ b/meta-oe/recipes-kernel/crash/crash/0004-crash-fix-build-failure-with-mips.patch
@@ -0,0 +1,87 @@
1From 423ebdce07aa9f398f32c0adf659353069d023c6 Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Thu, 4 May 2017 07:14:13 +0000
4Subject: [PATCH] crash: fix build failure with mips
5
6When build crash with mips:
7
8~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
9mips-linux-nat.c:157:1: error: conflicting types for 'ps_get_thread_area'
10 ps_get_thread_area (const struct ps_prochandle *ph,
11 ^~~~~~~~~~~~~~~~~~
12In file included from gdb_proc_service.h:26:0,
13 from mips-linux-nat.c:32:
14~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
15
16This problem have been fixed on intel and arm plantform, we can use the
17similar approch to fix it on mips.
18
19Upstream-status: Submitted [https://github.com/crash-utility/crash/pull/11]
20
21Signed-off-by: Dengke Du <dengke.du@windriver.com>
22---
23 Makefile | 1 +
24 crash-fix-build-failure-with-mips.patch | 39 +++++++++++++++++++++++++++++++++
25 2 files changed, 40 insertions(+)
26 create mode 100644 crash-fix-build-failure-with-mips.patch
27
28diff --git a/Makefile b/Makefile
29index 5496523..2ec3325 100644
30--- a/Makefile
31+++ b/Makefile
32@@ -268,6 +268,7 @@ gdb_patch:
33 grep 'extern ps_err_e ps_get_thread_area (struct' ${RECIPE_SYSROOT}/usr/include/proc_service.h; \
34 if [ $$? -eq 0 ]; then \
35 patch -p0 < ${GDB}-proc_service.h.patch; \
36+ patch -p1 < crash-fix-build-failure-with-mips.patch; \
37 fi; \
38 fi
39
40diff --git a/crash-fix-build-failure-with-mips.patch b/crash-fix-build-failure-with-mips.patch
41new file mode 100644
42index 0000000..0c70c5f
43--- /dev/null
44+++ b/crash-fix-build-failure-with-mips.patch
45@@ -0,0 +1,39 @@
46+From 615c802d9c73fad48723b6567042cd54f6795849 Mon Sep 17 00:00:00 2001
47+From: Dengke Du <dengke.du@windriver.com>
48+Date: Thu, 4 May 2017 06:14:47 +0000
49+Subject: [PATCH] crash: fix build failure with mips
50+
51+When build crash with mips:
52+
53+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
54+mips-linux-nat.c:157:1: error: conflicting types for 'ps_get_thread_area'
55+ ps_get_thread_area (const struct ps_prochandle *ph,
56+ ^~~~~~~~~~~~~~~~~~
57+In file included from gdb_proc_service.h:26:0,
58+ from mips-linux-nat.c:32:
59+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
60+
61+This problem have been fixed on intel and arm plantform, we can use the
62+similar approch to fix it on mips.
63+
64+Signed-off-by: Dengke Du <dengke.du@windriver.com>
65+---
66+ gdb-7.6/gdb/mips-linux-nat.c | 2 +-
67+ 1 file changed, 1 insertion(+), 1 deletion(-)
68+
69+diff --git a/gdb-7.6/gdb/mips-linux-nat.c b/gdb-7.6/gdb/mips-linux-nat.c
70+index 61e83c6..d517e37 100644
71+--- a/gdb-7.6/gdb/mips-linux-nat.c
72++++ b/gdb-7.6/gdb/mips-linux-nat.c
73+@@ -154,7 +154,7 @@ mips64_linux_register_addr (struct gdbarch *gdbarch, int regno, int store)
74+ /* Fetch the thread-local storage pointer for libthread_db. */
75+
76+ ps_err_e
77+-ps_get_thread_area (const struct ps_prochandle *ph,
78++ps_get_thread_area (struct ps_prochandle *ph,
79+ lwpid_t lwpid, int idx, void **base)
80+ {
81+ if (ptrace (PTRACE_GET_THREAD_AREA, lwpid, NULL, base) != 0)
82+--
83+2.11.0
84+
85--
862.11.0
87
diff --git a/meta-oe/recipes-kernel/crash/crash_7.1.8.bb b/meta-oe/recipes-kernel/crash/crash_7.1.8.bb
index 012ef1a9a..9cbb291f3 100644
--- a/meta-oe/recipes-kernel/crash/crash_7.1.8.bb
+++ b/meta-oe/recipes-kernel/crash/crash_7.1.8.bb
@@ -25,6 +25,7 @@ SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz;download
25 file://0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch \ 25 file://0001-Fix-for-a-compilation-error-if-glibc-2.25-or-later-h.patch \
26 file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \ 26 file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \
27 file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \ 27 file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \
28 file://0004-crash-fix-build-failure-with-mips.patch \
28 " 29 "
29 30
30SRC_URI[md5sum] = "31787074f267a3536eebff008a0652ec" 31SRC_URI[md5sum] = "31787074f267a3536eebff008a0652ec"