summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-20 07:14:16 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-22 16:03:00 +0200
commit021844a31fb7081da8213338288596df0c281fe2 (patch)
treeaf48041950563e6374f93f8a713df6289e8180fc /meta-oe/recipes-kernel
parent251547bd2ee9417175cf8d4349f83cdbd7f8479e (diff)
downloadmeta-openembedded-021844a31fb7081da8213338288596df0c281fe2.tar.gz
makedumpfile: Fix build with hardening
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-Add-proper-format-string-to-print-a-str.patch35
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.1.bb7
2 files changed, 39 insertions, 3 deletions
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-Add-proper-format-string-to-print-a-str.patch b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-Add-proper-format-string-to-print-a-str.patch
new file mode 100644
index 000000000..056a0bade
--- /dev/null
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-Add-proper-format-string-to-print-a-str.patch
@@ -0,0 +1,35 @@
1From 0fff28f31aef9ad1d5a817216a3c98ba9d605106 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 19 Jun 2017 23:52:14 -0700
4Subject: [PATCH] makedumpfile: Add proper format string to print a string
5
6Fix
7makedumpfile.c: In function 'write_eraseinfo':
8makedumpfile.c:8273:4: error: format not a string literal and no format arguments [-Werror=format-security]
9 DEBUG_MSG(obuf);
10 ^~~~~~~~~
11makedumpfile.c:8273:4: error: format not a string literal and no format arguments [-Werror=format-security]
12
13Upstream-Status: Pending
14
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 makedumpfile.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/makedumpfile.c b/makedumpfile.c
21index e69b6df..8b8a6b0 100644
22--- a/makedumpfile.c
23+++ b/makedumpfile.c
24@@ -8270,7 +8270,7 @@ write_eraseinfo(struct cache_data *cd_page, unsigned long *size_out)
25 }
26 sprintf(obuf, "erase %s %s", erase_info[i].symbol_expr,
27 size_str);
28- DEBUG_MSG(obuf);
29+ DEBUG_MSG("%s", obuf);
30 if (!write_cache(cd_page, obuf, strlen(obuf)))
31 goto out;
32 size_eraseinfo += strlen(obuf);
33--
342.13.1
35
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.1.bb b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.1.bb
index dacc76b04..83bbf7f41 100644
--- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.1.bb
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.1.bb
@@ -7,6 +7,9 @@ DESCRIPTION = "\
7" 7"
8HOMEPAGE = "http://makedumpfile.sourceforge.net" 8HOMEPAGE = "http://makedumpfile.sourceforge.net"
9 9
10LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
11LICENSE = "GPLv2.0"
12
10DEPENDS = "bzip2 zlib elfutils" 13DEPENDS = "bzip2 zlib elfutils"
11RDEPENDS_${PN}-tools = "perl ${PN}" 14RDEPENDS_${PN}-tools = "perl ${PN}"
12 15
@@ -21,10 +24,8 @@ SRC_URI = "\
21 ${SOURCEFORGE_MIRROR}/makedumpfile/${BPN}-${PV}.tar.gz \ 24 ${SOURCEFORGE_MIRROR}/makedumpfile/${BPN}-${PV}.tar.gz \
22 file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \ 25 file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \
23 file://0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch \ 26 file://0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch \
27 file://0001-makedumpfile-Add-proper-format-string-to-print-a-str.patch \
24" 28"
25LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
26LICENSE = "GPLv2.0"
27
28SRC_URI[md5sum] = "16c0ae9902ae57be4a603a6ab1e86c53" 29SRC_URI[md5sum] = "16c0ae9902ae57be4a603a6ab1e86c53"
29SRC_URI[sha256sum] = "0b6e73106998670407887de9e1a505b3a2dbb2fb517a4b968a665eda8fb097ce" 30SRC_URI[sha256sum] = "0b6e73106998670407887de9e1a505b3a2dbb2fb517a4b968a665eda8fb097ce"
30 31