summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/turbostat
diff options
context:
space:
mode:
authorHongzhi.Song <hongzhi.song@windriver.com>2018-05-27 19:00:41 -0700
committerKhem Raj <raj.khem@gmail.com>2018-05-29 12:57:23 -0700
commit09c64e1c05560e7377fcc217aa4e9ae58b4a1270 (patch)
tree1faec14523197629be11a3d0050fe5462c659da6 /meta-oe/recipes-kernel/turbostat
parent543bb9c05a7d579ff8acbd46ee7c4502fa86a93f (diff)
downloadmeta-openembedded-09c64e1c05560e7377fcc217aa4e9ae58b4a1270.tar.gz
turbostat: add the recipe of turbostat to meta-oe
It is an efficient and necessary tool to reflect the status of X86 processors. Turbostat reports processor topology, frequency, idle power-state statistics, temperature and power on X86 processors. Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/turbostat')
-rw-r--r--meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb b/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
new file mode 100644
index 000000000..355941794
--- /dev/null
+++ b/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
@@ -0,0 +1,58 @@
1#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4# This program is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License version 2 as
6# published by the Free Software Foundation.
7#
8SUMMARY = "Frequency and Idle power monitoring tools for Linux"
9
10DESCRIPTION = "The turbostat tool allows you to determine the actual \
11processor frequency and idle power saving state residency on supported \
12processors."
13
14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
16
17COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
18COMPATIBLE_HOST_libc-musl = "null"
19
20DEPENDS = "virtual/kernel"
21
22do_fetch[noexec] = "1"
23do_unpack[noexec] = "1"
24do_patch[noexec] = "1"
25
26# This looks in S, so we better make sure there's
27# something in the directory.
28#
29do_populate_lic[depends] = "${PN}:do_configure"
30
31
32EXTRA_OEMAKE = '\
33 CC="${CC}" \
34 'CFLAGS=-Wall -I${STAGING_KERNEL_DIR}/arch/x86/include/uapi ${LDFLAGS}' \
35 '
36
37# If we build under STAGING_KERNEL_DIR, source will not be put
38# into the dbg rpm. STAGING_KERNEL_DIR will exist by the time
39# do_configure() is invoked so we can safely copy from it.
40#
41do_configure_prepend() {
42 mkdir -p ${S}
43 cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/msr-index.h ${S}
44 cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/intel-family.h ${S}
45 cp -r ${STAGING_KERNEL_DIR}/tools/power/x86/turbostat/* ${S}
46 cp -r ${STAGING_KERNEL_DIR}/COPYING ${S}
47}
48
49do_compile() {
50 sed -i 's#MSRHEADER#"msr-index.h"#' turbostat.c
51 sed -i 's#INTEL_FAMILY_HEADER#"intel-family.h"#' turbostat.c
52 sed -i 's#\$(CC) \$(CFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#\$(CC) \$(CFLAGS) \$(LDFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#' Makefile
53 oe_runmake STAGING_KERNEL_DIR=${STAGING_KERNEL_DIR}
54}
55
56do_install() {
57 oe_runmake DESTDIR="${D}" install
58}