summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/makedumpfile
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2017-01-06 10:04:53 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-25 15:58:54 +0100
commit279a2b3ffd79aac4b2232b54d6992bd5bca4c3fd (patch)
treee5ca8ed9879fbb636366225a5e7e41e5bebdaff4 /meta-oe/recipes-kernel/makedumpfile
parent219e3f925e8809f0c93a1261659f3f46121108ab (diff)
downloadmeta-openembedded-279a2b3ffd79aac4b2232b54d6992bd5bca4c3fd.tar.gz
makedumpfile: update to 1.6.1
* Support 4.8 kernel * Add a patch to fix vmcore compressing for ppc64 Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/makedumpfile')
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile/0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch73
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.1.bb (renamed from meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.0.bb)5
2 files changed, 76 insertions, 2 deletions
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch
new file mode 100644
index 000000000..e0c3d9af6
--- /dev/null
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch
@@ -0,0 +1,73 @@
1From 653fe8e724081d2f289c2245d1220d5f7170538d Mon Sep 17 00:00:00 2001
2From: Alexandru Moise <alexandru.moise@windriver.com>
3Date: Fri, 29 Apr 2016 07:40:46 +0000
4Subject: [PATCH] mem_section: Support only 46 bit for MAX_PHYSMEM_BITS on
5 PPC64
6
7Related to change:
8http://lists.infradead.org/pipermail/kexec/2013-January/007849.html
9
10Linux on PPC64 has supported only 46 bit MAX_PHYSMEM_BITS since commit:
11048ee0993ec8360abb0b51bdf8f8721e9ed62ec4
12
13Also remove set_ppc64_max_physmem_bits and set info->max_physmem_bits in
14get_machdep_info_ppc64 instead. set_ppc64_max_physmem_bits is broken
15for all kernels compiled with CONFIG_SPARSEMEM=n. makedumpfile is
16unable to get mem_section field from powerpc kernel since commit:
17fd59d231f81cb02870b9cf15f456a897f3669b4e
18
19Upstream-Status: Pending
20
21Signed-off-by: Alexandru Moise <alexandru.moise@windriver.com>
22Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
23---
24 arch/ppc64.c | 28 ++--------------------------
25 1 file changed, 2 insertions(+), 26 deletions(-)
26
27diff --git a/arch/ppc64.c b/arch/ppc64.c
28index 89a7f05..6c928ab 100644
29--- a/arch/ppc64.c
30+++ b/arch/ppc64.c
31@@ -302,37 +302,13 @@ ppc64_vtop_level4(unsigned long vaddr)
32 }
33
34 int
35-set_ppc64_max_physmem_bits(void)
36-{
37- long array_len = ARRAY_LENGTH(mem_section);
38- /*
39- * The older ppc64 kernels uses _MAX_PHYSMEM_BITS as 42 and the
40- * newer kernels 3.7 onwards uses 46 bits.
41- */
42-
43- info->max_physmem_bits = _MAX_PHYSMEM_BITS_ORIG ;
44- if ((array_len == (NR_MEM_SECTIONS() / _SECTIONS_PER_ROOT_EXTREME()))
45- || (array_len == (NR_MEM_SECTIONS() / _SECTIONS_PER_ROOT())))
46- return TRUE;
47-
48- info->max_physmem_bits = _MAX_PHYSMEM_BITS_3_7;
49- if ((array_len == (NR_MEM_SECTIONS() / _SECTIONS_PER_ROOT_EXTREME()))
50- || (array_len == (NR_MEM_SECTIONS() / _SECTIONS_PER_ROOT())))
51- return TRUE;
52-
53- return FALSE;
54-}
55-
56-int
57 get_machdep_info_ppc64(void)
58 {
59 unsigned long vmlist, vmap_area_list, vmalloc_start;
60
61 info->section_size_bits = _SECTION_SIZE_BITS;
62- if (!set_ppc64_max_physmem_bits()) {
63- ERRMSG("Can't detect max_physmem_bits.\n");
64- return FALSE;
65- }
66+ info->max_physmem_bits = _MAX_PHYSMEM_BITS_3_7;
67+
68 info->page_offset = __PAGE_OFFSET;
69
70 if (SYMBOL(_stext) == NOT_FOUND_SYMBOL) {
71--
722.5.0
73
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.0.bb b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.1.bb
index 93a6f62c3..dacc76b04 100644
--- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.0.bb
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.1.bb
@@ -20,12 +20,13 @@ FILES_${PN}-tools = "${bindir}/*.pl"
20SRC_URI = "\ 20SRC_URI = "\
21 ${SOURCEFORGE_MIRROR}/makedumpfile/${BPN}-${PV}.tar.gz \ 21 ${SOURCEFORGE_MIRROR}/makedumpfile/${BPN}-${PV}.tar.gz \
22 file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \ 22 file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \
23 file://0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch \
23" 24"
24LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" 25LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
25LICENSE = "GPLv2.0" 26LICENSE = "GPLv2.0"
26 27
27SRC_URI[md5sum] = "041c5c6de2c3066600e4ca646c2397d6" 28SRC_URI[md5sum] = "16c0ae9902ae57be4a603a6ab1e86c53"
28SRC_URI[sha256sum] = "e3147abc52df2ceac1e9affef45bf37e2f2e1d9979bc94a761ee11e4044072ac" 29SRC_URI[sha256sum] = "0b6e73106998670407887de9e1a505b3a2dbb2fb517a4b968a665eda8fb097ce"
29 30
30SECTION = "base" 31SECTION = "base"
31 32