summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-04-24 16:45:38 +0800
committerArmin Kuster <akuster808@gmail.com>2022-05-03 06:58:49 -0700
commit72cc1b4f0a05330f6ebf90c9d26710ba720fcb10 (patch)
treeeaf911993bbe631d32215ed1585a415ecb9bdf11 /meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
parent786d3aa313e31a718acc9611ba3adb60573ec458 (diff)
downloadmeta-openembedded-72cc1b4f0a05330f6ebf90c9d26710ba720fcb10.tar.gz
makedumpfile: Upgrade to 1.6.9hardknott-next
* Linux 5.10 introduces a new lockless ringbuffer. The new ringbuffer is structured completely different to the previous iterations. Add support for retrieving the ringbuffer from debug information and/or using vmcoreinfo. The new ringbuffer is detected based on the availability of the "prb" symbol. * Support newer kernels as follows: - 5.10, 5.11, 5.12 (x86_64 SPARSEMEM) Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb')
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
new file mode 100644
index 000000000..4350ea126
--- /dev/null
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb
@@ -0,0 +1,64 @@
1SUMMARY = "VMcore extraction tool"
2DESCRIPTION = "\
3 This program is used to extract a subset of the memory available either \
4 via /dev/mem or /proc/vmcore (for crashdumps). It is used to get memory \
5 images without extra uneeded information (zero pages, userspace programs, \
6 etc). \
7"
8HOMEPAGE = "https://github.com/makedumpfile/makedumpfile"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
11LICENSE = "GPLv2.0"
12
13SRCBRANCH ?= "master"
14SRCREV = "a9ad811c15e769c8e6d8d915a05cebc32f2ea2f5"
15
16DEPENDS = "bzip2 zlib elfutils xz"
17RDEPENDS_${PN}-tools = "perl ${PN}"
18
19# arm and aarch64 would compile but has never been tested upstream. mips would not compile.
20#
21COMPATIBLE_HOST = "(x86_64|i.86|powerpc|arm|aarch64).*-linux"
22
23PACKAGES =+ "${PN}-tools"
24FILES_${PN}-tools = "${bindir}/*.pl"
25
26SRC_URI = "\
27 git://github.com/makedumpfile/makedumpfile;branch=${SRCBRANCH};protocol=https \
28 file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \
29 file://0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch \
30"
31
32S = "${WORKDIR}/git"
33
34UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
35
36SECTION = "base"
37
38# If we do not specify TARGET, makedumpfile will build for the host but use the
39# target gcc.
40#
41EXTRA_OEMAKE = "\
42 LINKTYPE=static \
43 TARGET=${TARGET_ARCH} \
44 ${PACKAGECONFIG_CONFARGS} \
45"
46
47PACKAGECONFIG ??= ""
48PACKAGECONFIG[lzo] = "USELZO=on,USELZO=off,lzo"
49PACKAGECONFIG[snappy] = "USESNAPPY=on,USESNAPPY=off,snappy"
50
51do_install () {
52 mkdir -p ${D}/usr/bin
53 install -m 755 ${S}/makedumpfile ${D}/usr/bin
54 install -m 755 ${S}/makedumpfile-R.pl ${D}/usr/bin
55
56 mkdir -p ${D}/usr/share/man/man8
57 install -m 644 ${S}/makedumpfile.8.gz ${D}/usr/share/man/man8
58
59 mkdir -p ${D}/usr/share/man/man5
60 install -m 644 ${S}/makedumpfile.conf.5.gz ${D}/usr/share/man/man5
61
62 mkdir -p ${D}/etc/
63 install -m 644 ${S}/makedumpfile.conf ${D}/etc/makedumpfile.conf.sample
64}