summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2019-07-19 02:15:37 -0700
committerKhem Raj <raj.khem@gmail.com>2019-07-21 09:31:09 -0700
commit3a23691a2ca62d7e0b9aec652d80b14d4590c99e (patch)
tree26750e3e08246929f3825b245fd2cc5be4582b86 /meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
parent96ec1963c476470cd4c87d809fda5d88900b8579 (diff)
downloadmeta-openembedded-3a23691a2ca62d7e0b9aec652d80b14d4590c99e.tar.gz
makedumpfile: Upgrade to 1.6.6
Rebase two patches. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch')
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch41
1 files changed, 21 insertions, 20 deletions
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
index a47806526..c0f82f321 100644
--- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch
@@ -1,4 +1,4 @@
1From 8eeb1b15608ce1a9a1f0d5417938fd6da4504406 Mon Sep 17 00:00:00 2001 1From af97e2ad643334b4c7c3d66f971ce9ebb2b596af Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com> 2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Thu, 21 Jul 2016 18:06:21 +0800 3Date: Thu, 21 Jul 2016 18:06:21 +0800
4Subject: [PATCH] makedumpfile: replace hardcode CFLAGS 4Subject: [PATCH] makedumpfile: replace hardcode CFLAGS
@@ -13,30 +13,28 @@ Subject: [PATCH] makedumpfile: replace hardcode CFLAGS
13Upstream-Status: Inappropriate[oe specific] 13Upstream-Status: Inappropriate[oe specific]
14 14
15Signed-off-by: Mingli Yu <mingli.yu@windriver.com> 15Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
16
17--- 16---
18 Makefile | 46 +++++++++++++++++++++++----------------------- 17 Makefile | 45 +++++++++++++++++++++++----------------------
19 1 file changed, 23 insertions(+), 23 deletions(-) 18 1 file changed, 23 insertions(+), 22 deletions(-)
20 19
21diff --git a/Makefile b/Makefile 20diff --git a/Makefile b/Makefile
22index 612b9d0..f6d6265 100644 21index 1fdb628..5dce589 100644
23--- a/Makefile 22--- a/Makefile
24+++ b/Makefile 23+++ b/Makefile
25@@ -8,13 +8,6 @@ ifeq ($(strip $CC),) 24@@ -8,12 +8,6 @@ ifeq ($(strip $CC),)
26 CC = gcc 25 CC = gcc
27 endif 26 endif
28 27
29-CFLAGS = -g -O2 -Wall -D_FILE_OFFSET_BITS=64 \ 28-CFLAGS_BASE := $(CFLAGS) -g -O2 -Wall -D_FILE_OFFSET_BITS=64 \
30- -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE \ 29- -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
31- -DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(DATE)"' 30-CFLAGS := $(CFLAGS_BASE) -DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(DATE)"'
32-CFLAGS_ARCH = -g -O2 -Wall -D_FILE_OFFSET_BITS=64 \ 31-CFLAGS_ARCH := $(CFLAGS_BASE)
33- -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
34-# LDFLAGS = -L/usr/local/lib -I/usr/local/include 32-# LDFLAGS = -L/usr/local/lib -I/usr/local/include
35- 33-
36 HOST_ARCH := $(shell uname -m) 34 HOST_ARCH := $(shell uname -m)
37 # Use TARGET as the target architecture if specified. 35 # Use TARGET as the target architecture if specified.
38 # Defaults to uname -m 36 # Defaults to uname -m
39@@ -22,29 +15,36 @@ ifeq ($(strip($TARGET)),) 37@@ -21,29 +15,36 @@ ifeq ($(strip($TARGET)),)
40 TARGET := $(HOST_ARCH) 38 TARGET := $(HOST_ARCH)
41 endif 39 endif
42 40
@@ -72,18 +70,18 @@ index 612b9d0..f6d6265 100644
72 endif 70 endif
73 71
74+CFLAGS_ARCH += $(CFLAGS) \ 72+CFLAGS_ARCH += $(CFLAGS) \
75+ -D_FILE_OFFSET_BITS=64 \ 73+ -D_FILE_OFFSET_BITS=64 \
76+ -D_LARGEFILE_SOURCE \ 74+ -D_LARGEFILE_SOURCE \
77+ -D_LARGEFILE64_SOURCE 75+ -D_LARGEFILE64_SOURCE
78+ 76+
79+CFLAGS_COMMON = $(CFLAGS_ARCH) \ 77+CFLAGS_COMMON = $(CFLAGS_ARCH) \
80+ -DVERSION='"$(VERSION)"' \ 78+ -DVERSION='"$(VERSION)"' \
81+ -DRELEASE_DATE='"$(DATE)"' 79+ -DRELEASE_DATE='"$(DATE)"'
82+ 80+
83 SRC_BASE = makedumpfile.c makedumpfile.h diskdump_mod.h sadump_mod.h sadump_info.h 81 SRC_BASE = makedumpfile.c makedumpfile.h diskdump_mod.h sadump_mod.h sadump_info.h
84 SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c tools.c 82 SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c tools.c
85 OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART)) 83 OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART))
86@@ -53,17 +53,17 @@ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH)) 84@@ -52,17 +53,17 @@ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH))
87 85
88 LIBS = -ldw -lbz2 -lebl -ldl -lelf -lz 86 LIBS = -ldw -lbz2 -lebl -ldl -lelf -lz
89 ifneq ($(LINKTYPE), dynamic) 87 ifneq ($(LINKTYPE), dynamic)
@@ -104,7 +102,7 @@ index 612b9d0..f6d6265 100644
104 endif 102 endif
105 103
106 LIBS := -lpthread $(LIBS) 104 LIBS := -lpthread $(LIBS)
107@@ -71,14 +71,14 @@ LIBS := -lpthread $(LIBS) 105@@ -82,14 +83,14 @@ LIBS := $(LIBS) $(call try-run,\
108 all: makedumpfile 106 all: makedumpfile
109 107
110 $(OBJ_PART): $(SRC_PART) 108 $(OBJ_PART): $(SRC_PART)
@@ -121,7 +119,7 @@ index 612b9d0..f6d6265 100644
121 echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8 119 echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8
122 grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8 120 grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8
123 mv temp.8 makedumpfile.8 121 mv temp.8 makedumpfile.8
124@@ -89,7 +89,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH) 122@@ -100,7 +101,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH)
125 gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz 123 gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz
126 124
127 eppic_makedumpfile.so: extension_eppic.c 125 eppic_makedumpfile.so: extension_eppic.c
@@ -130,3 +128,6 @@ index 612b9d0..f6d6265 100644
130 128
131 clean: 129 clean:
132 rm -f $(OBJ) $(OBJ_PART) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz makedumpfile.conf.5.gz 130 rm -f $(OBJ) $(OBJ_PART) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz makedumpfile.conf.5.gz
131--
1322.21.0
133