diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2017-06-09 14:40:30 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-06-14 14:51:15 +0200 |
commit | e846a439f3be8ccde00ac156a0d74d417878de29 (patch) | |
tree | a21a59e7749f7ec458ce3d117cc6e0a9cc4fb76b /meta-oe/recipes-kernel/agent-proxy | |
parent | d483a70d22505863036635cbff13963e00cfe093 (diff) | |
download | meta-openembedded-e846a439f3be8ccde00ac156a0d74d417878de29.tar.gz |
agent-proxy: add new recipe
agent-proxy is a simple, small proxy which is intended
for use with kgdb, or gdbserver type connections where
you want to share a text console and a debug session.
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/agent-proxy')
-rw-r--r-- | meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb | 25 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/agent-proxy/files/0001-Makefile-Add-LDFLAGS-variable.patch | 43 |
2 files changed, 68 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb b/meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb new file mode 100644 index 0000000000..8e370f962c --- /dev/null +++ b/meta-oe/recipes-kernel/agent-proxy/agent-proxy_git.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "Proxy for UDP/TCP debug connections" | ||
2 | DESCRIPTION = "The agent-proxy will forward tcp or udp connections as well as allow for script multiplexing of terminal sessions." | ||
3 | HOMEPAGE = "http://kgdb.wiki.kernel.org/" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" | ||
6 | |||
7 | SECTION = "devel" | ||
8 | |||
9 | EXTRA_OEMAKE = "'CC=${CC}'" | ||
10 | |||
11 | SRCREV = "e6c9d3d996bd55e7ab14dbd74deb7841e0c3a4f1" | ||
12 | PV = "1.96+git${SRCPV}" | ||
13 | |||
14 | SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kgdb/agent-proxy.git;protocol=git \ | ||
15 | file://0001-Makefile-Add-LDFLAGS-variable.patch \ | ||
16 | " | ||
17 | |||
18 | BBCLASSEXTEND = "native nativesdk" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | do_install () { | ||
23 | install -d ${D}${bindir} | ||
24 | install -m 0755 agent-proxy ${D}${bindir} | ||
25 | } | ||
diff --git a/meta-oe/recipes-kernel/agent-proxy/files/0001-Makefile-Add-LDFLAGS-variable.patch b/meta-oe/recipes-kernel/agent-proxy/files/0001-Makefile-Add-LDFLAGS-variable.patch new file mode 100644 index 0000000000..5eec91d722 --- /dev/null +++ b/meta-oe/recipes-kernel/agent-proxy/files/0001-Makefile-Add-LDFLAGS-variable.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From 1beb0dad6f8b99eb3bf1b9982e0b49e81ff77bbc Mon Sep 17 00:00:00 2001 | ||
2 | From: Jackie Huang <jackie.huang@windriver.com> | ||
3 | Date: Wed, 23 Nov 2016 19:17:31 +0800 | ||
4 | Subject: [PATCH] Makefile: Add LDFLAGS variable | ||
5 | |||
6 | Add LDFLAGS variable to make sure the extra linkder | ||
7 | flags can be passed. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | ||
12 | --- | ||
13 | Makefile | 6 +++--- | ||
14 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
15 | |||
16 | diff --git a/Makefile b/Makefile | ||
17 | index e20918f..25d92d3 100644 | ||
18 | --- a/Makefile | ||
19 | +++ b/Makefile | ||
20 | @@ -51,7 +51,7 @@ $(CROSS_COMPILE)agent-proxy: $(OBJS) | ||
21 | $(CC) -DAGENT_VER=$(AGENTVER) $(LINKFLAGS) $(CFLAGS) -o $(extpath)$@ $(OBJS) wsock32.lib | ||
22 | else | ||
23 | $(CROSS_COMPILE)agent-proxy: $(OBJS) | ||
24 | - $(CC) -DAGENT_VER=$(AGENTVER) $(CFLAGS) -o $(extpath)$@ $(OBJS) $(LDLIBS) | ||
25 | + $(CC) -DAGENT_VER=$(AGENTVER) $(CFLAGS) $(LDFLAGS) -o $(extpath)$@ $(OBJS) $(LDLIBS) | ||
26 | endif | ||
27 | |||
28 | |||
29 | @@ -61,9 +61,9 @@ clean: | ||
30 | rm -f $(extpath)$(CROSS_COMPILE)agent-proxy $(extpath)agent-proxy $(extpath)*.o $(extpath)*.obj $(extpath)*.exp $(extpath)*.exe $(extpath)*.ilk $(extpath)*.pdb *~ | ||
31 | |||
32 | $(extpath)$(CROSS_COMPILE)%.o::%.c | ||
33 | - $(CC) -DAGENT_VER=$(AGENTVER) $(CFLAGS) -c $< -o $@ | ||
34 | + $(CC) -DAGENT_VER=$(AGENTVER) $(CFLAGS) $(LDFLAGS) -c $< -o $@ | ||
35 | |||
36 | $(extpath)%.obj:%.c | ||
37 | - $(CC) -DAGENT_VER=$(AGENTVER) $(CFLAGS) -c -Fo$@ $(TLSPATH_INC) $< | ||
38 | + $(CC) -DAGENT_VER=$(AGENTVER) $(CFLAGS) $(LDFLAGS) -c -Fo$@ $(TLSPATH_INC) $< | ||
39 | |||
40 | |||
41 | -- | ||
42 | 2.8.3 | ||
43 | |||