summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-02-05 23:46:19 -0800
committerArmin Kuster <akuster808@gmail.com>2018-02-23 20:22:07 -0800
commitcee1608a98d026840f7c2fef18ce43431ae0c0ec (patch)
tree8a1b03cd39435fc5de926994c4525cf2be52dc6e /meta-oe/recipes-graphics
parent2e99ebcd7ed4229921e2c8476f06a8bcd977e21b (diff)
downloadmeta-openembedded-cee1608a98d026840f7c2fef18ce43431ae0c0ec.tar.gz
libyui-ncurses: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-src-Replace-using-sys-errno.h-with-errno.h.patch59
-rw-r--r--meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb4
2 files changed, 62 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-src-Replace-using-sys-errno.h-with-errno.h.patch b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-src-Replace-using-sys-errno.h-with-errno.h.patch
new file mode 100644
index 000000000..ae1b265dc
--- /dev/null
+++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-src-Replace-using-sys-errno.h-with-errno.h.patch
@@ -0,0 +1,59 @@
1From 46f016c4b87bb2a594df1c84e4d494bff0cbeaf9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 5 Feb 2018 12:01:25 -0800
4Subject: [PATCH] src: Replace using sys/errno.h with errno.h
5
6sys/errno.h is no longer the right place for this file
7
8error: #warning redirecting incorrect #include <sys/errno.h> to <errno.h> [-Werror=cpp]
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12Upstream-Status: Submitted [https://github.com/libyui/libyui-ncurses/pull/63]
13 src/NCAskForDirectory.cc | 2 +-
14 src/NCAskForFile.cc | 2 +-
15 src/NCFileSelection.h | 2 +-
16 3 files changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/src/NCAskForDirectory.cc b/src/NCAskForDirectory.cc
19index 06ec6ac..ed1a30c 100644
20--- a/src/NCAskForDirectory.cc
21+++ b/src/NCAskForDirectory.cc
22@@ -39,7 +39,7 @@
23 #include <sys/types.h>
24 #include <unistd.h>
25 #include <dirent.h>
26-#include <sys/errno.h>
27+#include <errno.h>
28
29 /*
30 Textdomain "ncurses"
31diff --git a/src/NCAskForFile.cc b/src/NCAskForFile.cc
32index 31fdb39..63a6679 100644
33--- a/src/NCAskForFile.cc
34+++ b/src/NCAskForFile.cc
35@@ -39,7 +39,7 @@
36 #include <sys/stat.h>
37 #include <unistd.h>
38 #include <dirent.h>
39-#include <sys/errno.h>
40+#include <errno.h>
41
42 /*
43 Textdomain "ncurses"
44diff --git a/src/NCFileSelection.h b/src/NCFileSelection.h
45index d42311f..514d020 100644
46--- a/src/NCFileSelection.h
47+++ b/src/NCFileSelection.h
48@@ -38,7 +38,7 @@
49 #include <sys/stat.h>
50 #include <unistd.h>
51 #include <dirent.h>
52-#include <sys/errno.h>
53+#include <errno.h>
54
55
56 struct NCFileInfo
57--
582.16.1
59
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
index e445ee0cc..3388876e4 100644
--- a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
+++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
@@ -4,7 +4,9 @@ LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
4 file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \ 4 file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \
5" 5"
6 6
7SRC_URI = "git://github.com/libyui/libyui-ncurses.git" 7SRC_URI = "git://github.com/libyui/libyui-ncurses.git \
8 file://0001-src-Replace-using-sys-errno.h-with-errno.h.patch \
9 "
8 10
9SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" 11SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch"
10 12