diff options
author | Armin Kuster <akuster808@gmail.com> | 2017-12-28 09:02:11 -0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-12-30 12:32:34 -0800 |
commit | cae654adc6bfc5de7b8e70ce787664fc06ad7304 (patch) | |
tree | a17561e33cedad765e303d583eea8798897e4a4f /meta-oe/recipes-graphics | |
parent | f5c2f027455266014f201e81a116295d576c7be5 (diff) | |
download | meta-openembedded-cae654adc6bfc5de7b8e70ce787664fc06ad7304.tar.gz |
libyui-ncurses: new add
Add a new recipe libyui-ncurses, which is a rdepend for dnfdragora.
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
fixed patch to apply
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r-- | meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Fix-the-error-of-can-t-find-header-file.patch | 101 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb | 48 |
2 files changed, 149 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Fix-the-error-of-can-t-find-header-file.patch b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Fix-the-error-of-can-t-find-header-file.patch new file mode 100644 index 0000000000..045f3cafab --- /dev/null +++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Fix-the-error-of-can-t-find-header-file.patch | |||
@@ -0,0 +1,101 @@ | |||
1 | From eb0086dc4ea8fe9cda069456287b3a29a2631d30 Mon Sep 17 00:00:00 2001 | ||
2 | From: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | ||
3 | Date: Wed, 13 Dec 2017 16:18:45 +0900 | ||
4 | Subject: [PATCH] Fix the error of can't find header file | ||
5 | |||
6 | Upstream-Status: Inappropriate [embedded specific] | ||
7 | This fix is just for yocto. | ||
8 | |||
9 | Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | ||
10 | --- | ||
11 | src/NCApplication.cc | 2 +- | ||
12 | src/NCstyle.h | 2 +- | ||
13 | src/NCurses.h | 2 +- | ||
14 | src/ncursesp.h | 2 +- | ||
15 | src/ncursesw.cc | 2 +- | ||
16 | src/ncursesw.h | 4 ++-- | ||
17 | 6 files changed, 7 insertions(+), 7 deletions(-) | ||
18 | |||
19 | diff --git a/src/NCApplication.cc b/src/NCApplication.cc | ||
20 | index 5bcf969..510f034 100644 | ||
21 | --- a/src/NCApplication.cc | ||
22 | +++ b/src/NCApplication.cc | ||
23 | @@ -23,7 +23,7 @@ | ||
24 | |||
25 | /-*/ | ||
26 | |||
27 | -#include <ncursesw/curses.h> | ||
28 | +#include <curses.h> | ||
29 | |||
30 | #define YUILogComponent "ncurses" | ||
31 | #include <yui/YUILog.h> | ||
32 | diff --git a/src/NCstyle.h b/src/NCstyle.h | ||
33 | index a40d5a8..3657917 100644 | ||
34 | --- a/src/NCstyle.h | ||
35 | +++ b/src/NCstyle.h | ||
36 | @@ -25,7 +25,7 @@ | ||
37 | #ifndef NCstyle_h | ||
38 | #define NCstyle_h | ||
39 | |||
40 | -#include <ncursesw/ncurses.h> | ||
41 | +#include <ncurses.h> | ||
42 | |||
43 | #include <iosfwd> | ||
44 | #include <string> | ||
45 | diff --git a/src/NCurses.h b/src/NCurses.h | ||
46 | index a07c6bf..d17d3c3 100644 | ||
47 | --- a/src/NCurses.h | ||
48 | +++ b/src/NCurses.h | ||
49 | @@ -34,7 +34,7 @@ | ||
50 | #include <yui/YWidget.h> | ||
51 | #include <yui/YMenuItem.h> | ||
52 | |||
53 | -#include <ncursesw/curses.h> /* curses.h: #define NCURSES_CH_T cchar_t */ | ||
54 | +#include <curses.h> /* curses.h: #define NCURSES_CH_T cchar_t */ | ||
55 | #include <wchar.h> | ||
56 | |||
57 | #include "ncursesw.h" | ||
58 | diff --git a/src/ncursesp.h b/src/ncursesp.h | ||
59 | index d478347..2fcfea5 100644 | ||
60 | --- a/src/ncursesp.h | ||
61 | +++ b/src/ncursesp.h | ||
62 | @@ -28,7 +28,7 @@ | ||
63 | #include <iosfwd> | ||
64 | |||
65 | #include "ncursesw.h" | ||
66 | -#include <ncursesw/panel.h> | ||
67 | +#include <panel.h> | ||
68 | |||
69 | class NCursesPanel : public NCursesWindow | ||
70 | { | ||
71 | diff --git a/src/ncursesw.cc b/src/ncursesw.cc | ||
72 | index 3c771af..bb83210 100644 | ||
73 | --- a/src/ncursesw.cc | ||
74 | +++ b/src/ncursesw.cc | ||
75 | @@ -47,7 +47,7 @@ | ||
76 | #include <iostream> | ||
77 | #include <stdlib.h> | ||
78 | #include <string.h> | ||
79 | -#include <ncursesw/term.h> | ||
80 | +#include <term.h> | ||
81 | #undef line | ||
82 | #undef columns | ||
83 | |||
84 | diff --git a/src/ncursesw.h b/src/ncursesw.h | ||
85 | index d25923a..c140d37 100644 | ||
86 | --- a/src/ncursesw.h | ||
87 | +++ b/src/ncursesw.h | ||
88 | @@ -27,8 +27,8 @@ | ||
89 | |||
90 | #include <iosfwd> | ||
91 | |||
92 | -#include <ncursesw/curses.h> | ||
93 | -#include <ncursesw/etip.h> | ||
94 | +#include <curses.h> | ||
95 | +#include <etip.h> | ||
96 | #include <cstdio> | ||
97 | #include <cstdarg> | ||
98 | #include <climits> | ||
99 | -- | ||
100 | 2.7.4 | ||
101 | |||
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb new file mode 100644 index 0000000000..02bcf44363 --- /dev/null +++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | SUMMARY = "Character Based User Interface for libyui" | ||
2 | LICENSE = "LGPLv3" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ | ||
4 | file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \ | ||
5 | " | ||
6 | |||
7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ | ||
8 | " | ||
9 | |||
10 | SRC_URI_append_class-target += " file://0001-Fix-the-error-of-can-t-find-header-file.patch" | ||
11 | |||
12 | PV = "2.48.3+git" | ||
13 | SRCREV = "7b251c2ff541df6139f3d210d0a0a27d042926bd" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | inherit cmake gettext pkgconfig | ||
18 | |||
19 | DEPENDS += "boost libyui ncurses" | ||
20 | |||
21 | BBCLASSEXTEND = "nativesdk" | ||
22 | |||
23 | do_configure_prepend () { | ||
24 | cd ${S} | ||
25 | git checkout bootstrap.sh | ||
26 | sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" bootstrap.sh | ||
27 | ./bootstrap.sh | ||
28 | mkdir -p ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ | ||
29 | cp ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so* ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ | ||
30 | cd - | ||
31 | sed -i "s#\${YPREFIX}#\${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${S}/CMakeLists.txt | ||
32 | sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${PKG_CONFIG_SYSROOT_DIR}${libdir}/cmake/libyui/LibyuiLibraryDepends-release.cmake | ||
33 | } | ||
34 | |||
35 | do_install_append () { | ||
36 | if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then | ||
37 | mv ${D}/usr/lib64 ${D}/usr/lib | ||
38 | fi | ||
39 | } | ||
40 | |||
41 | do_install_append_class-nativesdk () { | ||
42 | mkdir -p ${D}/${base_prefix} | ||
43 | mv ${D}/usr ${D}/${base_prefix} | ||
44 | } | ||
45 | |||
46 | FILES_${PN} += "${datadir}/*" | ||
47 | |||
48 | FILES_${PN}-dev += "${libdir}/*" | ||