diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-02-04 23:20:02 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-02-05 16:43:12 -0800 |
commit | a07c969aebea4edb66babbc264777f626ed8eb7b (patch) | |
tree | 5451a0700e8137ca6241775777d7182c8faad344 /meta-oe/recipes-graphics | |
parent | 8f6995ddc639a46d825aa0fc294ef589547ca6d3 (diff) | |
download | meta-openembedded-a07c969aebea4edb66babbc264777f626ed8eb7b.tar.gz |
graphviz: Fix cross-build failures with clang
It is detecting cross compile badness for -lexpat since
the check finds it on build host, so aide the build ssytem
to find it in staging sysroot
Disable internal ltdl, use libtool provided one
Define defines to indicate that platform has ssize_t and long_double
Disable java,r,c-sharp, as it is unused
Arrange source URIs before checksums
gtk-doc is not needed, morever it ends up in unknown configure options
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r-- | meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb | 18 |
1 files changed, 14 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb index 96f1efc60a..a9efffaca2 100644 --- a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb +++ b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb | |||
@@ -17,7 +17,7 @@ DEPENDS = " \ | |||
17 | " | 17 | " |
18 | DEPENDS_append_class-target = " ${BPN}-native" | 18 | DEPENDS_append_class-target = " ${BPN}-native" |
19 | 19 | ||
20 | inherit autotools-brokensep pkgconfig gtk-doc gettext | 20 | inherit autotools-brokensep pkgconfig gettext |
21 | 21 | ||
22 | # The source tarball suggested at | 22 | # The source tarball suggested at |
23 | # https://graphviz.gitlab.io/_pages/Download/Download_source.html has no | 23 | # https://graphviz.gitlab.io/_pages/Download/Download_source.html has no |
@@ -25,14 +25,24 @@ inherit autotools-brokensep pkgconfig gtk-doc gettext | |||
25 | # get checksum errors. Fedora people seem to expect same so they use a versioned | 25 | # get checksum errors. Fedora people seem to expect same so they use a versioned |
26 | # source - see https://src.fedoraproject.org/cgit/rpms/graphviz.git/tree/graphviz.spec | 26 | # source - see https://src.fedoraproject.org/cgit/rpms/graphviz.git/tree/graphviz.spec |
27 | 27 | ||
28 | SRC_URI = "https://gitlab.com/graphviz/graphviz/-/archive/stable_release_${PV}/graphviz-stable_release_${PV}.tar.gz" | 28 | SRC_URI = "https://gitlab.com/graphviz/graphviz/-/archive/stable_release_${PV}/graphviz-stable_release_${PV}.tar.gz \ |
29 | SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072" | 29 | " |
30 | SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a" | ||
31 | # Use native mkdefs | 30 | # Use native mkdefs |
32 | SRC_URI_append_class-target = " file://0001-Use-native-mkdefs.patch" | 31 | SRC_URI_append_class-target = " file://0001-Use-native-mkdefs.patch" |
32 | SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072" | ||
33 | SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a" | ||
33 | 34 | ||
34 | S = "${WORKDIR}/${BPN}-stable_release_${PV}" | 35 | S = "${WORKDIR}/${BPN}-stable_release_${PV}" |
35 | 36 | ||
37 | EXTRA_OECONF_class-target = "\ | ||
38 | --with-expatincludedir=${STAGING_INCDIR} \ | ||
39 | --with-expatlibdir=${STAGING_LIBDIR} \ | ||
40 | --without-included-ltdl \ | ||
41 | --disable-java \ | ||
42 | --disable-r \ | ||
43 | --disable-sharp \ | ||
44 | " | ||
45 | CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1" | ||
36 | do_configure_prepend() { | 46 | do_configure_prepend() { |
37 | cd ${S} | 47 | cd ${S} |
38 | # create version.m4 and ignore libtoolize errors | 48 | # create version.m4 and ignore libtoolize errors |