diff options
author | Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | 2018-01-08 21:09:08 +0000 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-01-16 21:39:48 -0800 |
commit | 7919c886cde4b37fa06df43ef2f898792fd59c7c (patch) | |
tree | 6f1378cefd847a6b18dde4b970117b5d9beabc40 /meta-oe/recipes-graphics | |
parent | e4ccc1fdaf6293f0bfcf0e9425a12e248427d32a (diff) | |
download | meta-openembedded-7919c886cde4b37fa06df43ef2f898792fd59c7c.tar.gz |
libyui-ncurses: fix indentation, include SRCPV in PV, don't use += and append.
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r-- | meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb | 39 |
1 files changed, 19 insertions, 20 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb index 02bcf44363..e445ee0ccd 100644 --- a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb +++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb | |||
@@ -1,15 +1,14 @@ | |||
1 | SUMMARY = "Character Based User Interface for libyui" | 1 | SUMMARY = "Character Based User Interface for libyui" |
2 | LICENSE = "LGPLv3" | 2 | LICENSE = "LGPLv3" |
3 | LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ | 3 | LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ |
4 | file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \ | 4 | file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \ |
5 | " | 5 | " |
6 | 6 | ||
7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ | 7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git" |
8 | " | ||
9 | 8 | ||
10 | SRC_URI_append_class-target += " file://0001-Fix-the-error-of-can-t-find-header-file.patch" | 9 | SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" |
11 | 10 | ||
12 | PV = "2.48.3+git" | 11 | PV = "2.48.3+git${SRCPV}" |
13 | SRCREV = "7b251c2ff541df6139f3d210d0a0a27d042926bd" | 12 | SRCREV = "7b251c2ff541df6139f3d210d0a0a27d042926bd" |
14 | 13 | ||
15 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
@@ -21,26 +20,26 @@ DEPENDS += "boost libyui ncurses" | |||
21 | BBCLASSEXTEND = "nativesdk" | 20 | BBCLASSEXTEND = "nativesdk" |
22 | 21 | ||
23 | do_configure_prepend () { | 22 | do_configure_prepend () { |
24 | cd ${S} | 23 | cd ${S} |
25 | git checkout bootstrap.sh | 24 | git checkout bootstrap.sh |
26 | sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" bootstrap.sh | 25 | sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" bootstrap.sh |
27 | ./bootstrap.sh | 26 | ./bootstrap.sh |
28 | mkdir -p ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ | 27 | mkdir -p ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ |
29 | cp ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so* ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ | 28 | cp ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so* ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ |
30 | cd - | 29 | cd - |
31 | sed -i "s#\${YPREFIX}#\${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${S}/CMakeLists.txt | 30 | sed -i "s#\${YPREFIX}#\${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${S}/CMakeLists.txt |
32 | sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${PKG_CONFIG_SYSROOT_DIR}${libdir}/cmake/libyui/LibyuiLibraryDepends-release.cmake | 31 | sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${PKG_CONFIG_SYSROOT_DIR}${libdir}/cmake/libyui/LibyuiLibraryDepends-release.cmake |
33 | } | 32 | } |
34 | 33 | ||
35 | do_install_append () { | 34 | do_install_append () { |
36 | if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then | 35 | if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then |
37 | mv ${D}/usr/lib64 ${D}/usr/lib | 36 | mv ${D}/usr/lib64 ${D}/usr/lib |
38 | fi | 37 | fi |
39 | } | 38 | } |
40 | 39 | ||
41 | do_install_append_class-nativesdk () { | 40 | do_install_append_class-nativesdk () { |
42 | mkdir -p ${D}/${base_prefix} | 41 | mkdir -p ${D}/${base_prefix} |
43 | mv ${D}/usr ${D}/${base_prefix} | 42 | mv ${D}/usr ${D}/${base_prefix} |
44 | } | 43 | } |
45 | 44 | ||
46 | FILES_${PN} += "${datadir}/*" | 45 | FILES_${PN} += "${datadir}/*" |