summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-15 11:12:27 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-17 13:10:10 -0700
commit77817d1c16d4607d79ff326f6a9a5fd00e3357fb (patch)
tree8005b9cdade99eb580169ce7662097797e954d7e /meta-oe/recipes-graphics
parent2e3a4b155cd997dca51ff4be42233ada0e54eec6 (diff)
downloadmeta-openembedded-77817d1c16d4607d79ff326f6a9a5fd00e3357fb.tar.gz
dietsplash: Update and fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/dietsplash/dietsplash/0001-Mimic-GNU-basename-API-for-non-glibc-library-e.g.-mu.patch28
-rw-r--r--meta-oe/recipes-graphics/dietsplash/dietsplash_git.bb7
2 files changed, 32 insertions, 3 deletions
diff --git a/meta-oe/recipes-graphics/dietsplash/dietsplash/0001-Mimic-GNU-basename-API-for-non-glibc-library-e.g.-mu.patch b/meta-oe/recipes-graphics/dietsplash/dietsplash/0001-Mimic-GNU-basename-API-for-non-glibc-library-e.g.-mu.patch
new file mode 100644
index 000000000..aa8406e31
--- /dev/null
+++ b/meta-oe/recipes-graphics/dietsplash/dietsplash/0001-Mimic-GNU-basename-API-for-non-glibc-library-e.g.-mu.patch
@@ -0,0 +1,28 @@
1From 272491297564513c4ce49a11bc1ecc523a3afd63 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 15 Mar 2024 11:05:54 -0700
4Subject: [PATCH] Mimic GNU basename() API for non-glibc library e.g. musl
5
6Upstream-Status: Submitted [https://github.com/lucasdemarchi/dietsplash/pull/7]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 src/util.h | 3 +++
10 1 file changed, 3 insertions(+)
11
12diff --git a/src/util.h b/src/util.h
13index 1f4c3ef..a3ab54a 100644
14--- a/src/util.h
15+++ b/src/util.h
16@@ -60,6 +60,9 @@
17 */
18 #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]) + _array_size_chk(arr))
19
20+#if !defined(__GLIBC__)
21+#define basename(src) (strrchr(src,'/') ? strrchr(src,'/')+1 : src)
22+#endif
23
24 #define DIE_PREFIX "[" PACKAGE_NAME "] ERR: "
25 #define LOG_SUFFIX "\n"
26--
272.44.0
28
diff --git a/meta-oe/recipes-graphics/dietsplash/dietsplash_git.bb b/meta-oe/recipes-graphics/dietsplash/dietsplash_git.bb
index bd94b9ad5..1ee2657bd 100644
--- a/meta-oe/recipes-graphics/dietsplash/dietsplash_git.bb
+++ b/meta-oe/recipes-graphics/dietsplash/dietsplash_git.bb
@@ -4,12 +4,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4 4
5# Really, no depends besides a C library 5# Really, no depends besides a C library
6 6
7PV = "0.3" 7PV = "0.3+git"
8 8
9SRCREV = "ef2e1a390e768e21e6a6268977580ee129a96633" 9SRCREV = "8bed71d860bbb0c8792fa2a1179c9beeae84d577"
10SRC_URI = "git://github.com/lucasdemarchi/dietsplash.git;branch=master;protocol=https \ 10SRC_URI = "git://github.com/lucasdemarchi/dietsplash.git;branch=master;protocol=https \
11 file://0001-configure.ac-Do-not-demand-linker-hash-style.patch \ 11 file://0001-configure.ac-Do-not-demand-linker-hash-style.patch \
12 " 12 file://0001-Mimic-GNU-basename-API-for-non-glibc-library-e.g.-mu.patch \
13"
13 14
14inherit autotools 15inherit autotools
15 16