summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-09-22 23:30:52 +0200
committerKhem Raj <raj.khem@gmail.com>2019-09-23 08:33:10 -0700
commit6dda036fc4450a7d95b428db298c028952e3f2bb (patch)
tree151e09b40784fd5b17afb5f5faefa1d679bf2da7 /meta-oe/recipes-graphics
parent6f560065cffb24f4b2d5274b5511a8ed7550bda2 (diff)
downloadmeta-openembedded-6dda036fc4450a7d95b428db298c028952e3f2bb.tar.gz
jasper: update to 2.0.16
Licence change due to modified copyright years (see @11ef9d44ac9795f4). Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/jasper/jasper_1.900.1.bb18
-rw-r--r--meta-oe/recipes-graphics/jasper/jasper_2.0.16.bb24
2 files changed, 24 insertions, 18 deletions
diff --git a/meta-oe/recipes-graphics/jasper/jasper_1.900.1.bb b/meta-oe/recipes-graphics/jasper/jasper_1.900.1.bb
deleted file mode 100644
index d2c7ffdab..000000000
--- a/meta-oe/recipes-graphics/jasper/jasper_1.900.1.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1SUMMARY = "Jpeg 2000 implementation"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=baa697d7510288a9cdcce9bd7edaf9bc"
4
5PR = "r1"
6
7SRC_URI = "git://github.com/mdadams/jasper.git;protocol=https"
8SRCREV = "b13b8c86be870107f83b0a9a4b77557cb2b65d69"
9
10S = "${WORKDIR}/git"
11
12inherit autotools lib_package
13
14PACKAGECONFIG ??= ""
15PACKAGECONFIG[jpeg] = "--enable-libjpeg,--disable-libjpeg,jpeg"
16PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,freeglut"
17
18EXTRA_OECONF = "--enable-shared"
diff --git a/meta-oe/recipes-graphics/jasper/jasper_2.0.16.bb b/meta-oe/recipes-graphics/jasper/jasper_2.0.16.bb
new file mode 100644
index 000000000..1d5a29438
--- /dev/null
+++ b/meta-oe/recipes-graphics/jasper/jasper_2.0.16.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Jpeg 2000 implementation"
2HOMEPAGE = "https://github.com/mdadams/jasper"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a80440d1d8f17d041c71c7271d6e06eb"
5
6SRC_URI = "git://github.com/mdadams/jasper.git;protocol=https"
7SRCREV = "9aef6d91a82a8a6aecb575cbee57f74470603cc2"
8
9S = "${WORKDIR}/git"
10
11inherit cmake
12
13PACKAGECONFIG ??= ""
14PACKAGECONFIG[jpeg] = "-DJAS_ENABLE_LIBJPEG=true, -DJAS_ENABLE_LIBJPEG=false, jpeg"
15PACKAGECONFIG[opengl] = "-DJAS_ENABLE_OPENGL=true, -DJAS_ENABLE_OPENGL=false, freeglut"
16
17EXTRA_OECMAKE_append = " -DJAS_ENABLE_SHARED=true"
18
19do_install_append() {
20 chrpath -d ${D}${bindir}/jasper
21 chrpath -d ${D}${bindir}/imginfo
22 chrpath -d ${D}${bindir}/imgcmp
23 chrpath -d ${D}${libdir}/libjasper.so.*
24}