summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-08-16 20:27:47 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-19 16:09:28 -0700
commit23561de348d225aba3d01bb1b7355bbd43b309ba (patch)
tree321a118e9db9bc47bfb97d3aa8985b67b15ca12f /meta-oe/recipes-graphics
parent227b687ecd3e92f979d2297982ef72142a3c798b (diff)
downloadmeta-openembedded-23561de348d225aba3d01bb1b7355bbd43b309ba.tar.gz
move all libsdl recipes in one folder and follow oe-core's folder for libsdl
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl-image/configure.patch43
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl-image_1.2.12.bb32
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl-mixer/configure.patch21
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl-mixer_1.2.12.bb39
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl-ttf/use.pkg-config.for.freetype2.patch62
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl-ttf_2.0.11.bb29
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb31
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl2-mixer_2.0.2.bb27
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl2-ttf/automake_foreign.patch21
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl2-ttf/use.pkg-config.for.freetype2.patch62
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.0.14.bb30
11 files changed, 397 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl-image/configure.patch b/meta-oe/recipes-graphics/libsdl/libsdl-image/configure.patch
new file mode 100644
index 000000000..5299d378e
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl-image/configure.patch
@@ -0,0 +1,43 @@
1Index: SDL_image-1.2.12/configure.in
2===================================================================
3--- SDL_image-1.2.12.orig/configure.in 2012-01-21 01:51:33.000000000 +0000
4+++ SDL_image-1.2.12/configure.in 2014-07-18 06:56:56.853466678 +0000
5@@ -1,5 +1,4 @@
6 dnl Process this file with autoconf to produce a configure script.
7-AC_INIT(README)
8
9 dnl Set various version strings - taken gratefully from the GTk sources
10
11@@ -11,12 +10,19 @@
12 # if backwards compatibility has been broken,
13 # set BINARY_AGE and INTERFACE_AGE to 0.
14
15-MAJOR_VERSION=1
16-MINOR_VERSION=2
17-MICRO_VERSION=12
18+m4_define([sdlimage_major_version],[1])
19+m4_define([sdlimage_minor_version],[2])
20+m4_define([sdlimage_micro_version],[12])
21+m4_define([sdlimage_version], [sdlimage_major_version.sdlimage_minor_version.sdlimage_micro_version])
22+
23+AC_INIT([SDL_image], [sdlimage_version])
24+
25+MAJOR_VERSION=sdlimage_major_version
26+MINOR_VERSION=sdlimage_minor_version
27+MICRO_VERSION=sdlimage_micro_version
28 INTERFACE_AGE=4
29 BINARY_AGE=12
30-VERSION=$MAJOR_VERSION.$MINOR_VERSION.$MICRO_VERSION
31+VERSION=sdlimage_version
32
33 AC_SUBST(MAJOR_VERSION)
34 AC_SUBST(MINOR_VERSION)
35@@ -42,7 +48,7 @@
36 AC_CANONICAL_HOST
37
38 dnl Setup for automake
39-AM_INIT_AUTOMAKE(SDL_image, $VERSION)
40+AM_INIT_AUTOMAKE([foreign])
41
42 dnl Check for tools
43 AC_PROG_LIBTOOL
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl-image_1.2.12.bb b/meta-oe/recipes-graphics/libsdl/libsdl-image_1.2.12.bb
new file mode 100644
index 000000000..ea8e9eaa3
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl-image_1.2.12.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Simple DirectMedia Layer image library"
2SECTION = "libs"
3
4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://COPYING;md5=613734b7586e1580ef944961c6d62227"
6
7DEPENDS = "tiff zlib libpng jpeg virtual/libsdl"
8
9SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz \
10 file://configure.patch"
11SRC_URI[md5sum] = "a0f9098ebe5400f0bdc9b62e60797ecb"
12SRC_URI[sha256sum] = "0b90722984561004de84847744d566809dbb9daf732a9e503b91a1b5a84e5699"
13
14S = "${WORKDIR}/SDL_image-${PV}"
15
16inherit autotools pkgconfig
17
18export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
19
20# Disable the run-time loading of the libs and bring back the soname dependencies.
21EXTRA_OECONF += "--disable-jpg-shared --disable-png-shared -disable-tif-shared"
22
23do_configure_prepend() {
24 # Removing these files fixes a libtool version mismatch.
25 rm -f ${S}/acinclude/libtool.m4
26 rm -f ${S}/acinclude/sdl.m4
27 rm -f ${S}/acinclude/pkg.m4
28 rm -f ${S}/acinclude/lt~obsolete.m4
29 rm -f ${S}/acinclude/ltoptions.m4
30 rm -f ${S}/acinclude/ltsugar.m4
31 rm -f ${S}/acinclude/ltversion.m4
32}
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl-mixer/configure.patch b/meta-oe/recipes-graphics/libsdl/libsdl-mixer/configure.patch
new file mode 100644
index 000000000..4c9e8d094
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl-mixer/configure.patch
@@ -0,0 +1,21 @@
1diff -Nurd SDL_mixer-1.2.12/configure.in SDL_mixer-1.2.12/configure.in
2--- SDL_mixer-1.2.12/configure.in 2012-01-16 00:01:05.000000000 +0200
3+++ SDL_mixer-1.2.12/configure.in 2012-12-15 04:08:04.627871456 +0200
4@@ -1,6 +1,5 @@
5 dnl Process this file with autoconf to produce a configure script.
6 AC_INIT(README)
7-AC_CONFIG_AUX_DIR(build-scripts)
8
9 dnl Set various version strings - taken gratefully from the GTk sources
10
11@@ -40,10 +39,6 @@
12 AC_SUBST(LT_REVISION)
13 AC_SUBST(LT_AGE)
14
15-dnl Detect the canonical build and host environments
16-AC_CONFIG_AUX_DIRS($srcdir/build-scripts)
17-dnl AC_CANONICAL_HOST
18-
19 dnl Check for tools
20 AC_PROG_LIBTOOL
21 AC_PROG_CC
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl-mixer_1.2.12.bb b/meta-oe/recipes-graphics/libsdl/libsdl-mixer_1.2.12.bb
new file mode 100644
index 000000000..c83fcc8da
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl-mixer_1.2.12.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Simple DirectMedia Layer mixer library"
2SECTION = "libs"
3DEPENDS = "virtual/libsdl flac libmikmod libvorbis"
4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a37a47a0e579e461474cd03b9e05199d"
6
7SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
8 file://configure.patch \
9"
10
11SRC_URI[md5sum] = "e03ff73d77a55e3572ad0217131dc4a1"
12SRC_URI[sha256sum] = "1644308279a975799049e4826af2cfc787cad2abb11aa14562e402521f86992a"
13
14S = "${WORKDIR}/SDL_mixer-${PV}"
15
16inherit autotools-brokensep pkgconfig
17
18EXTRA_AUTORECONF += "--include=acinclude"
19EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor LIBS=-L${STAGING_LIBDIR}"
20
21PACKAGECONFIG[mad] = "--enable-music-mp3-mad-gpl,--disable-music-mp3-mad-gpl,libmad"
22
23do_configure () {
24 # Remove old libtool macros.
25 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
26 for i in ${MACROS}; do
27 rm -f acinclude/$i
28 done
29 cp build-scripts/* . || true
30 rm -rf build-scripts/
31 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
32
33 autotools_do_configure
34
35 rm config.log
36 for i in $(find -name "Makefile") ; do
37 sed -i -e 's:-L/usr/lib:-L${STAGING_LIBDIR}:g' $i
38 done
39}
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl-ttf/use.pkg-config.for.freetype2.patch b/meta-oe/recipes-graphics/libsdl/libsdl-ttf/use.pkg-config.for.freetype2.patch
new file mode 100644
index 000000000..1116c34d0
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl-ttf/use.pkg-config.for.freetype2.patch
@@ -0,0 +1,62 @@
1From 8cf318197eea91bec6057308befbb29426d69014 Mon Sep 17 00:00:00 2001
2From: Richard Purdie <richard.purdie@linuxfoundation.org>
3Date: Thu, 22 May 2014 10:59:33 +0100
4Subject: [PATCH] freetype-config was removed from oe-core in
5
6commit 5870bd272b0b077d0826fb900b251884c1c05061
7
8 binconfig-disabled: Add class and use
9
10---
11 configure.in | 38 +++++---------------------------------
12 1 file changed, 5 insertions(+), 33 deletions(-)
13
14diff --git a/configure.in b/configure.in
15index 865075e..d7a5a81 100644
16--- a/configure.in
17+++ b/configure.in
18@@ -90,39 +90,11 @@ case "$host" in
19 esac
20 AM_CONDITIONAL(USE_VERSION_RC, test x$use_version_rc = xtrue)
21
22-dnl Check for the FreeType 2 library
23-dnl
24-dnl Get the cflags and libraries from the freetype-config script
25-dnl
26-AC_ARG_WITH(freetype-prefix,[ --with-freetype-prefix=PFX Prefix where FREETYPE is
27-installed (optional)],
28- freetype_prefix="$withval", freetype_prefix="")
29-AC_ARG_WITH(freetype-exec-prefix,[ --with-freetype-exec-prefix=PFX Exec prefix
30-where FREETYPE is installed (optional)],
31- freetype_exec_prefix="$withval", freetype_exec_prefix="")
32-
33-if test x$freetype_exec_prefix != x ; then
34- freetype_args="$freetype_args --exec-prefix=$freetype_exec_prefix"
35- if test x${FREETYPE_CONFIG+set} != xset ; then
36- FREETYPE_CONFIG=$freetype_exec_prefix/bin/freetype-config
37- fi
38-fi
39-if test x$freetype_prefix != x ; then
40- freetype_args="$freetype_args --prefix=$freetype_prefix"
41- if test x${FREETYPE_CONFIG+set} != xset ; then
42- FREETYPE_CONFIG=$freetype_prefix/bin/freetype-config
43- fi
44-fi
45-AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
46-no_freetype=""
47-if test "$FREETYPE_CONFIG" = "no" ; then
48- AC_MSG_ERROR([
49-*** Unable to find FreeType2 library (http://www.freetype.org/)
50-])
51-else
52- CFLAGS="$CFLAGS `$FREETYPE_CONFIG $freetypeconf_args --cflags`"
53- LIBS="$LIBS `$FREETYPE_CONFIG $freetypeconf_args --libs`"
54-fi
55+PKG_CHECK_MODULES(FREETYPE2, freetype2,
56+ CFLAGS="$CFLAGS $FREETYPE2_CFLAGS"
57+ LIBS="$LIBS $FREETYPE2_LIBS",
58+ AC_MSG_ERROR([*** Unable to find FreeType2 library (http://www.freetype.org/)])
59+)
60
61 dnl Check for SDL
62 SDL_VERSION=1.2.4
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl-ttf_2.0.11.bb b/meta-oe/recipes-graphics/libsdl/libsdl-ttf_2.0.11.bb
new file mode 100644
index 000000000..d8b378f2c
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl-ttf_2.0.11.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Simple DirectMedia Layer truetype font library"
2SECTION = "libs"
3DEPENDS = "virtual/libsdl freetype"
4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://COPYING;md5=22800d1b3701377aae0b61ee36f5c303"
6
7SRC_URI = "http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-${PV}.tar.gz \
8 file://use.pkg-config.for.freetype2.patch \
9"
10SRC_URI[md5sum] = "61e29bd9da8d245bc2471d1b2ce591aa"
11SRC_URI[sha256sum] = "724cd895ecf4da319a3ef164892b72078bd92632a5d812111261cde248ebcdb7"
12
13S = "${WORKDIR}/SDL_ttf-${PV}"
14
15inherit autotools pkgconfig
16
17LDFLAGS += "-lm"
18
19do_configure_prepend() {
20 # make autoreconf happy
21 touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog
22
23 # Removing these files fixes a libtool version mismatch.
24 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
25
26 for i in ${MACROS}; do
27 rm -f ${S}/acinclude/$i
28 done
29}
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb b/meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb
new file mode 100644
index 000000000..1f9c794c7
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl2-image_2.0.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Simple DirectMedia Layer image library v2"
2SECTION = "libs"
3
4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=ec65b9778f5584a0bd8dfc17d6340ba0"
6
7DEPENDS = "tiff zlib libpng jpeg virtual/libsdl2 libwebp"
8
9SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL2_image-${PV}.tar.gz"
10SRC_URI[md5sum] = "d94b94555ba022fa249a53a021dc3606"
11SRC_URI[sha256sum] = "3a3eafbceea5125c04be585373bfd8b3a18f259bd7eae3efc4e6d8e60e0d7f64"
12
13S = "${WORKDIR}/SDL2_image-${PV}"
14
15inherit autotools pkgconfig
16
17# Disable the run-time loading of the libs and bring back the soname dependencies.
18EXTRA_OECONF += "--disable-jpg-shared --disable-png-shared -disable-tif-shared"
19
20do_configure_prepend() {
21 # make autoreconf happy
22 touch ${S}/NEWS ${S}/README ${S}/AUTHORS ${S}/ChangeLog
23 # Removing these files fixes a libtool version mismatch.
24 rm -f ${S}/acinclude/libtool.m4
25 rm -f ${S}/acinclude/sdl2.m4
26 rm -f ${S}/acinclude/pkg.m4
27 rm -f ${S}/acinclude/lt~obsolete.m4
28 rm -f ${S}/acinclude/ltoptions.m4
29 rm -f ${S}/acinclude/ltsugar.m4
30 rm -f ${S}/acinclude/ltversion.m4
31}
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl2-mixer_2.0.2.bb b/meta-oe/recipes-graphics/libsdl/libsdl2-mixer_2.0.2.bb
new file mode 100644
index 000000000..718f3f5fd
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl2-mixer_2.0.2.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Simple DirectMedia Layer mixer library V2"
2SECTION = "libs"
3DEPENDS = "virtual/libsdl2 flac libmikmod libvorbis"
4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=95e0c3cf63f71b950911e698a54b7fc5"
6
7SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL2_mixer-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "aaa0551393993c14a13f72b339c0ed6c"
10SRC_URI[sha256sum] = "4e615e27efca4f439df9af6aa2c6de84150d17cbfd12174b54868c12f19c83bb"
11
12S = "${WORKDIR}/SDL2_mixer-${PV}"
13
14inherit autotools-brokensep pkgconfig
15
16EXTRA_AUTORECONF += "--include=acinclude"
17EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor LIBS=-L${STAGING_LIBDIR}"
18
19PACKAGECONFIG[mad] = "--enable-music-mp3-mad-gpl,--disable-music-mp3-mad-gpl,libmad"
20
21do_configure_prepend () {
22 # Remove old libtool macros.
23 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
24 for i in ${MACROS}; do
25 rm -f acinclude/$i
26 done
27}
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl2-ttf/automake_foreign.patch b/meta-oe/recipes-graphics/libsdl/libsdl2-ttf/automake_foreign.patch
new file mode 100644
index 000000000..871e6e94e
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl2-ttf/automake_foreign.patch
@@ -0,0 +1,21 @@
1From f9c4ad3a171d676e3818b8f6897f325ccf0b2203 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 9 May 2017 00:57:10 -0700
4
5---
6 Makefile.am | 2 ++
7 1 file changed, 2 insertions(+)
8
9diff --git a/Makefile.am b/Makefile.am
10index 8166d91..8e05e49 100644
11--- a/Makefile.am
12+++ b/Makefile.am
13@@ -2,6 +2,8 @@
14
15 lib_LTLIBRARIES = libSDL2_ttf.la
16
17+AUTOMAKE_OPTIONS = foreign
18+
19 libSDL2_ttfincludedir = $(includedir)/SDL2
20 libSDL2_ttfinclude_HEADERS = \
21 SDL_ttf.h
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl2-ttf/use.pkg-config.for.freetype2.patch b/meta-oe/recipes-graphics/libsdl/libsdl2-ttf/use.pkg-config.for.freetype2.patch
new file mode 100644
index 000000000..1dfbec6ed
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl2-ttf/use.pkg-config.for.freetype2.patch
@@ -0,0 +1,62 @@
1From e6d2c0e130811c15b5f5cc10221fae182cb8609e Mon Sep 17 00:00:00 2001
2From: Richard Purdie <richard.purdie@linuxfoundation.org>
3Date: Thu, 22 May 2014 10:59:33 +0100
4Subject: [PATCH] freetype-config was removed from oe-core in
5
6commit 5870bd272b0b077d0826fb900b251884c1c05061
7
8 binconfig-disabled: Add class and use
9
10---
11 configure.in | 38 +++++---------------------------------
12 1 file changed, 5 insertions(+), 33 deletions(-)
13
14diff --git a/configure.in b/configure.in
15index 9b36e15..f300cae 100644
16--- a/configure.in
17+++ b/configure.in
18@@ -86,39 +86,11 @@ case "$host" in
19 esac
20 AM_CONDITIONAL(USE_VERSION_RC, test x$use_version_rc = xtrue)
21
22-dnl Check for the FreeType 2 library
23-dnl
24-dnl Get the cflags and libraries from the freetype-config script
25-dnl
26-AC_ARG_WITH(freetype-prefix,[ --with-freetype-prefix=PFX Prefix where FREETYPE is
27-installed (optional)],
28- freetype_prefix="$withval", freetype_prefix="")
29-AC_ARG_WITH(freetype-exec-prefix,[ --with-freetype-exec-prefix=PFX Exec prefix
30-where FREETYPE is installed (optional)],
31- freetype_exec_prefix="$withval", freetype_exec_prefix="")
32-
33-if test x$freetype_exec_prefix != x ; then
34- freetype_args="$freetype_args --exec-prefix=$freetype_exec_prefix"
35- if test x${FREETYPE_CONFIG+set} != xset ; then
36- FREETYPE_CONFIG=$freetype_exec_prefix/bin/freetype-config
37- fi
38-fi
39-if test x$freetype_prefix != x ; then
40- freetype_args="$freetype_args --prefix=$freetype_prefix"
41- if test x${FREETYPE_CONFIG+set} != xset ; then
42- FREETYPE_CONFIG=$freetype_prefix/bin/freetype-config
43- fi
44-fi
45-AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
46-no_freetype=""
47-if test "$FREETYPE_CONFIG" = "no" ; then
48- AC_MSG_ERROR([
49-*** Unable to find FreeType2 library (http://www.freetype.org/)
50-])
51-else
52- CFLAGS="$CFLAGS `$FREETYPE_CONFIG $freetypeconf_args --cflags`"
53- LIBS="$LIBS `$FREETYPE_CONFIG $freetypeconf_args --libs`"
54-fi
55+PKG_CHECK_MODULES(FREETYPE2, freetype2,
56+ CFLAGS="$CFLAGS $FREETYPE2_CFLAGS"
57+ LIBS="$LIBS $FREETYPE2_LIBS",
58+ AC_MSG_ERROR([*** Unable to find FreeType2 library (http://www.freetype.org/)])
59+)
60
61 dnl Check for SDL
62 SDL_VERSION=2.0.0
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.0.14.bb b/meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.0.14.bb
new file mode 100644
index 000000000..4601593ad
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.0.14.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Simple DirectMedia Layer truetype font library"
2SECTION = "libs"
3DEPENDS = "virtual/libsdl2 freetype virtual/libgl"
4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=cb33e7c4df9fbde389f149ad6bc93ce5"
6
7SRC_URI = " \
8 http://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-${PV}.tar.gz \
9 file://use.pkg-config.for.freetype2.patch \
10 file://automake_foreign.patch \
11"
12SRC_URI[md5sum] = "e53c05e1e7f1382c316afd6c763388b1"
13SRC_URI[sha256sum] = "34db5e20bcf64e7071fe9ae25acaa7d72bdc4f11ab3ce59acc768ab62fe39276"
14
15S = "${WORKDIR}/SDL2_ttf-${PV}"
16
17inherit autotools pkgconfig distro_features_check
18
19# links to libGL.so
20REQUIRED_DISTRO_FEATURES += "x11 opengl"
21
22do_configure_prepend() {
23 # Removing these files fixes a libtool version mismatch.
24 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
25
26 for i in ${MACROS}; do
27 rm -f ${S}/acinclude/$i
28 done
29}
30ASNEEDED = ""