summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/xorg-app/xterm_303.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-graphics/xorg-app/xterm_303.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-graphics/xorg-app/xterm_303.bb')
-rw-r--r--meta-oe/recipes-graphics/xorg-app/xterm_303.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/xorg-app/xterm_303.bb b/meta-oe/recipes-graphics/xorg-app/xterm_303.bb
new file mode 100644
index 000000000..fad07d9ff
--- /dev/null
+++ b/meta-oe/recipes-graphics/xorg-app/xterm_303.bb
@@ -0,0 +1,30 @@
1require recipes-graphics/xorg-app/xorg-app-common.inc
2SUMMARY = "xterm is the standard terminal emulator for the X Window System"
3DEPENDS = "libxaw xproto xextproto libxext libxau libxpm ncurses"
4
5LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=540cf18ccc16bc3c5fea40d2ab5d8d51"
6
7SRC_URI = "ftp://invisible-island.net/xterm/${BP}.tgz"
8
9SRC_URI[md5sum] = "48f6d49b2b6b6933d501d767cbed9254"
10SRC_URI[sha256sum] = "8af29987bda9b77205ebf6233aaa5c347e5f2407310b62ac9ba92a658257f058"
11
12EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
13 --x-libraries=${STAGING_LIBDIR} \
14 FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
15 --disable-imake \
16 --disable-rpath-hack \
17 --disable-setuid"
18
19B = "${S}"
20
21do_configure() {
22 gnu-configize --force
23 sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
24 oe_runconf
25}
26
27FILES_${PN} += " /usr/lib/X11"
28
29PACKAGECONFIG ?= ""
30PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig"